summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikhail Pukhlikov <cynede@gentoo.org>2016-07-22 23:06:21 +0400
committerMikhail Pukhlikov <cynede@gentoo.org>2016-07-22 23:06:50 +0400
commit09012dce30215082faecd3fe983b6d82ff1d3a10 (patch)
tree767be23537016692c4b6efe3916282a0b05efe62 /dev-dotnet/nuget
parentdev-ruby/uuidtools: add ruby21 to stable version (diff)
downloadgentoo-09012dce30215082faecd3fe983b6d82ff1d3a10.tar.gz
gentoo-09012dce30215082faecd3fe983b6d82ff1d3a10.tar.bz2
gentoo-09012dce30215082faecd3fe983b6d82ff1d3a10.zip
dev-dotnet/nuget: port bdouxx's fix for certificates problem
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-dotnet/nuget')
-rw-r--r--dev-dotnet/nuget/nuget-2.8.7-r1.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/dev-dotnet/nuget/nuget-2.8.7-r1.ebuild b/dev-dotnet/nuget/nuget-2.8.7-r1.ebuild
new file mode 100644
index 000000000000..d29a54f890c8
--- /dev/null
+++ b/dev-dotnet/nuget/nuget-2.8.7-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit dotnet eutils
+
+# This ebuild provides a forked version of nuget modified to work with MonoDevelop.
+# See https://bugzilla.xamarin.com/show_bug.cgi?id=27693
+# dev-dotnet/nuget-codeplex provides the upstream version.
+
+DESCRIPTION="Nuget - .NET Package Manager"
+HOMEPAGE="http://nuget.codeplex.com"
+SRC_URI="https://github.com/mrward/nuget/archive/Release-${PV}-MonoDevelop.tar.gz -> ${P}.tar.gz"
+S=${WORKDIR}/nuget-Release-${PV}-MonoDevelop
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+# Mask 3.2.0 because of mcs compiler bug : http://stackoverflow.com/a/17926731/238232
+# it fixed in 3.2.3
+DEPEND=">=dev-lang/mono-3.2.3
+ <=dev-dotnet/xdt-for-monodevelop-2.8.2
+ !dev-dotnet/nuget-codeplex
+ app-misc/ca-certificates"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ addwrite "/usr/share/.mono/keypairs"
+ dotnet_pkg_setup
+ cert-sync /etc/ssl/certs/ca-certificates.crt
+}
+
+src_prepare() {
+ sed -i -e 's@RunTests@ @g' "${S}/Build/Build.proj" || die
+ cp "${FILESDIR}/rsa-4096.snk" "${S}/src/Core/" || die
+ epatch "${FILESDIR}/add-keyfile-option-to-csproj.patch"
+ sed -i -E -e "s#(\[assembly: InternalsVisibleTo(.*)\])#/* \1 */#g" "src/Core/Properties/AssemblyInfo.cs" || die
+ epatch "${FILESDIR}/strongnames-for-ebuild-2.8.1.patch"
+}
+
+src_configure() {
+ export EnableNuGetPackageRestore="true"
+}
+
+src_compile() {
+# xbuild Build/Build.proj /p:Configuration=Release /p:TreatWarningsAsErrors=false /tv:4.0 /p:TargetFrameworkVersion="v${FRAMEWORK}" /p:Configuration="Mono Release" /t:GoMono || die
+ source ./build.sh || die
+}
+
+src_install() {
+ elog "Installing NuGet.Core.dll into GAC"
+ egacinstall "src/Core/obj/Mono Release/NuGet.Core.dll"
+ elog "Installing NuGet console application"
+ insinto /usr/lib/mono/NuGet/"${FRAMEWORK}"/
+ doins src/CommandLine/obj/Mono\ Release/NuGet.exe
+ make_wrapper nuget "mono /usr/lib/mono/NuGet/${FRAMEWORK}/NuGet.exe"
+}