summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2021-06-27 12:15:15 -0700
committerZac Medico <zmedico@gentoo.org>2021-06-27 13:44:08 -0700
commit4685f03364f876c53c0b127c8c2bec79dc680647 (patch)
treef325e6c2876d3bf5bb6a70e700ef36ed5732c0ef /dev-dotnet
parentdev-libs/unibilium: keyword x64-macos (diff)
downloadgentoo-4685f03364f876c53c0b127c8c2bec79dc680647.tar.gz
gentoo-4685f03364f876c53c0b127c8c2bec79dc680647.tar.bz2
gentoo-4685f03364f876c53c0b127c8c2bec79dc680647.zip
dev-dotnet/dotnet-sdk-bin: Initial import
This merges the dotnet repo's dotnetcore-sdk-bin-common and dotnetcore-sdk-bin packages into a single dotnet-sdk-bin package. For a complementary dev-dotnet/dotnet-sdk built from source, see https://github.com/gentoo/gentoo/pull/21112. Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'dev-dotnet')
-rw-r--r--dev-dotnet/dotnet-sdk-bin/Manifest3
-rw-r--r--dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-5.0.301.ebuild43
-rw-r--r--dev-dotnet/dotnet-sdk-bin/metadata.xml15
3 files changed, 61 insertions, 0 deletions
diff --git a/dev-dotnet/dotnet-sdk-bin/Manifest b/dev-dotnet/dotnet-sdk-bin/Manifest
new file mode 100644
index 000000000000..0b7ac621e299
--- /dev/null
+++ b/dev-dotnet/dotnet-sdk-bin/Manifest
@@ -0,0 +1,3 @@
+DIST dotnet-sdk-5.0.301-linux-arm.tar.gz 138735656 BLAKE2B c23732749f67bd2ca63cadba9bcb3f5abd4e10d00fed441825e6a59f9d3a3e663101502e5557dd94e737443cc9bbab0d5dbe8f7ebdbde54586596ec5c520a64f SHA512 89663ffb22299ad626d3f1d5129e493fb8784e6ed854b128a364407a060eec2979cd7d3c9e4f3df8e47ccb72b98ff8b18e8d53c7fb65b3455faa7344f67417a2
+DIST dotnet-sdk-5.0.301-linux-arm64.tar.gz 136933875 BLAKE2B 6c48c8a2d47ba5bed47e6176d10e273ec996686cb5a4d5b3239098ff23d44526091f7eae1ce762a2eb2f6f31420cafda84471b936082469eadc8c62aa0dcd8bf SHA512 56e233b8f35abe80984bc8a60028f4f8dbc8543313a0711045ef13c693e11e706ee4809574518f57910ec2c93bed896da32760c8143a298556dc25478caca90f
+DIST dotnet-sdk-5.0.301-linux-x64.tar.gz 142255332 BLAKE2B 172888e2eb78d2f768cff6a7e99d6473b469b7cbde74a4eab63e601d85bad118be374f330a413a9b6b3e6773340bdaef8ead4ed54a194189a50cac6b61fac556 SHA512 81cd7a3550a262d5c907030677429fa9a1cb515071274931ab760bd8bb2a14f40c9384c8757e1c1aa681b1de22035f16bf20b41ed208becd054cc9bb1f620322
diff --git a/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-5.0.301.ebuild b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-5.0.301.ebuild
new file mode 100644
index 000000000000..30e9b4e6de58
--- /dev/null
+++ b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-5.0.301.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+MY_PV="${PV}"
+
+DESCRIPTION=".NET is a free, cross-platform, open-source developer platform"
+HOMEPAGE="https://dotnet.microsoft.com/"
+LICENSE="MIT"
+
+SRC_URI="
+amd64? ( https://dotnetcli.azureedge.net/dotnet/Sdk/${MY_PV}/dotnet-sdk-${MY_PV}-linux-x64.tar.gz )
+arm? ( https://dotnetcli.azureedge.net/dotnet/Sdk/${MY_PV}/dotnet-sdk-${MY_PV}-linux-arm.tar.gz )
+arm64? ( https://dotnetcli.azureedge.net/dotnet/Sdk/${MY_PV}/dotnet-sdk-${MY_PV}-linux-arm64.tar.gz )
+"
+
+SLOT="5.0"
+KEYWORDS="~amd64 ~arm ~arm64"
+IUSE="+dotnet-symlink"
+REQUIRED_USE="elibc_glibc"
+QA_PREBUILT="*"
+RESTRICT+=" splitdebug"
+RDEPEND="dotnet-symlink? ( !dev-dotnet/dotnet-sdk[dotnet-symlink(+)] )"
+
+S=${WORKDIR}
+
+src_install() {
+ local dest="opt/${PN}-${SLOT}"
+ dodir "${dest%/*}"
+
+ { mv "${S}" "${ED}/${dest}" && mkdir "${S}" && fperms 0755 "/${dest}"; } || die
+ dosym "../../${dest}/dotnet" "/usr/bin/dotnet-bin-${SLOT}"
+
+ if use dotnet-symlink; then
+ dosym "../../${dest}/dotnet" "/usr/bin/dotnet"
+ dosym "../../${dest}/dotnet" "/usr/bin/dotnet-${SLOT}"
+
+ # set an env-variable for 3rd party tools
+ echo "DOTNET_ROOT=/${dest}" > "${T}/90${PN}-${SLOT}" || die
+ doenvd "${T}/90${PN}-${SLOT}"
+ fi
+}
diff --git a/dev-dotnet/dotnet-sdk-bin/metadata.xml b/dev-dotnet/dotnet-sdk-bin/metadata.xml
new file mode 100644
index 000000000000..6905cd2c4766
--- /dev/null
+++ b/dev-dotnet/dotnet-sdk-bin/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>dotnet@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <doc>https://docs.microsoft.com/en-us/dotnet/</doc>
+ </upstream>
+ <use>
+ <flag name="dotnet-symlink">
+ Install a dotnet symlink that points to dotnet-bin.
+ </flag>
+ </use>
+</pkgmetadata>