summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-11-24 20:47:05 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-11-24 21:09:29 +0100
commitd436ec927836c7d4635ba4ec2a2b8b3f5d860d7e (patch)
treef8c18c279c581de003d015800c75fb75edf0cbd7 /dev-dotnet
parentdev-dotnet/dotnet-sdk-bin: drop old 7.0.403 (diff)
downloadgentoo-d436ec927836c7d4635ba4ec2a2b8b3f5d860d7e.tar.gz
gentoo-d436ec927836c7d4635ba4ec2a2b8b3f5d860d7e.tar.bz2
gentoo-d436ec927836c7d4635ba4ec2a2b8b3f5d860d7e.zip
dev-dotnet/dotnet-sdk: drop old 7.0.105-r1
Bug: https://bugs.gentoo.org/918418 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-dotnet')
-rw-r--r--dev-dotnet/dotnet-sdk/Manifest1
-rw-r--r--dev-dotnet/dotnet-sdk/dotnet-sdk-7.0.105-r1.ebuild104
2 files changed, 0 insertions, 105 deletions
diff --git a/dev-dotnet/dotnet-sdk/Manifest b/dev-dotnet/dotnet-sdk/Manifest
index 60e2cc286b6b..9529a5a6497a 100644
--- a/dev-dotnet/dotnet-sdk/Manifest
+++ b/dev-dotnet/dotnet-sdk/Manifest
@@ -1,2 +1 @@
-DIST dotnet-sdk-7.0.105-prepared-gentoo-amd64.tar.xz 1617916684 BLAKE2B 729d2027e3c356581f7db763d7da09cba512a1a48ddf6492e632dd15eaa547efa8153abeec73c37b5e31e0b8d94c54e0495dd0e67dbe8d1592dbb93b5484e830 SHA512 f45366830435a3adb03221a684818337b3ad6af6b3d46edbf0a664af1c49e7b949c0d2c4507b61c767fdddfa492d32d341cd22e2e4ad28657504ed34757c6aff
DIST dotnet-sdk-8.0.100-prepared-gentoo-amd64.tar.xz 1714535960 BLAKE2B fd6027b86168d8801b1d8a7bbb08e9c358918a7693b03fa4e7e43e2a58568a65d71e2c5907ec7c7a03b83685608cd16aa010706fb4d14cd44ab0f0669654c8c2 SHA512 75efdcf44383445bc81981e2077be03c7311db316e295aa7f960f50d65367cde9bd86351f345072feb827a569c8de4fa8c9829d92000d2cbeb312ee9ddc17b44
diff --git a/dev-dotnet/dotnet-sdk/dotnet-sdk-7.0.105-r1.ebuild b/dev-dotnet/dotnet-sdk/dotnet-sdk-7.0.105-r1.ebuild
deleted file mode 100644
index c62ef3c73f57..000000000000
--- a/dev-dotnet/dotnet-sdk/dotnet-sdk-7.0.105-r1.ebuild
+++ /dev/null
@@ -1,104 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-## Build the tarball:
-## ./build.sh --configuration Release --architecture x64 \
-## /p:ArcadeBuildTarball=true /p:TarballDir="$(pwd)/dotnet-sdk-7.0.105"
-## cd dotnet-sdk-7.0.105
-## ./prep.sh --bootstrap
-## cd ..
-## tar --create --auto-compress --file dotnet-sdk-7.0.105.tar.xz dotnet-sdk-7.0.105
-## mv dotnet-sdk-7.0.105.tar.xz dotnet-sdk-7.0.1050-prepared-gentoo-amd64.tar.xz
-## upload dotnet-sdk-7.0.1050-amd64.tar.xz
-
-EAPI=8
-
-LLVM_MAX_SLOT=16
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit check-reqs llvm python-any-r1
-
-DESCRIPTION=".NET is a free, cross-platform, open-source developer platform"
-HOMEPAGE="https://dotnet.microsoft.com/"
-SRC_URI="
- amd64? ( https://dev.gentoo.org/~xgqt/distfiles/repackaged/${P}-prepared-gentoo-amd64.tar.xz )
-"
-
-SDK_SLOT="$(ver_cut 1-2)"
-RUNTIME_SLOT="${SDK_SLOT}.5"
-SLOT="${SDK_SLOT}/${RUNTIME_SLOT}"
-
-LICENSE="MIT"
-KEYWORDS="~amd64"
-
-BDEPEND="
- ${PYTHON_DEPS}
- <sys-devel/clang-$(( LLVM_MAX_SLOT + 1 ))
- dev-util/cmake
- dev-vcs/git
-"
-RDEPEND="
- app-crypt/mit-krb5:0/0
- dev-libs/icu
- dev-libs/openssl:=
- dev-util/lttng-ust:0/2.12
- sys-libs/zlib:0/1
-"
-IDEPEND="app-eselect/eselect-dotnet"
-PDEPEND="
- ~dev-dotnet/dotnet-runtime-nugets-${RUNTIME_SLOT}
- ~dev-dotnet/dotnet-runtime-nugets-3.1.32
- ~dev-dotnet/dotnet-runtime-nugets-6.0.16
-"
-
-CHECKREQS_DISK_BUILD="20G"
-
-# QA_PREBUILT="*" # TODO: Which binaries are created by dotnet itself?
-
-pkg_setup() {
- check-reqs_pkg_setup
- llvm_pkg_setup
- python-any-r1_pkg_setup
-}
-
-src_prepare() {
- default
-
- unset DOTNET_ROOT
- unset NUGET_PACKAGES
-
- export DOTNET_CLI_TELEMETRY_OPTOUT=1
- export MSBUILDDISABLENODEREUSE=1
- export UseSharedCompilation=false
-}
-
-src_compile() {
- # Remove .NET leftover files that block build.
- if [[ -f /tmp/PackageVersions.props ]] ; then
- rm /tmp/PackageVersions.props # nonfatal
- fi
-
- ebegin "Building .NET SDK ${SDK_SLOT}"
- bash ./build.sh --clean-while-building
- eend ${?} || die "build failed"
-}
-
-src_install() {
- local dest=/usr/$(get_libdir)/${PN}-${SDK_SLOT}
- dodir ${dest}
-
- ebegin "Extracting SDK archive"
- tar xzf artifacts/*/Release/${P}-*.tar.gz -C "${ED}"/${dest}
- eend ${?} || die "extraction failed"
-
- fperms 0755 ${dest}
- dosym -r ${dest}/dotnet /usr/bin/dotnet-${SDK_SLOT}
-}
-
-pkg_postinst() {
- eselect dotnet update ifunset
-}
-
-pkg_postrm() {
- eselect dotnet update ifunset
-}