summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2019-11-24 20:32:30 +0100
committerManuel Rüger <mrueg@gentoo.org>2019-11-24 20:32:57 +0100
commit08c312f1734dc3b7b1a386c6ffce1244229d5445 (patch)
treecf2a7ee11b12ca3dc043f20712646c970e16ac55 /dev-embedded/esptool/esptool-2.8.ebuild
parentdev-python/fs: move tests to BDEPEND and use python_gen_cond_dep (diff)
downloadgentoo-08c312f1734dc3b7b1a386c6ffce1244229d5445.tar.gz
gentoo-08c312f1734dc3b7b1a386c6ffce1244229d5445.tar.bz2
gentoo-08c312f1734dc3b7b1a386c6ffce1244229d5445.zip
dev-embedded/esptool: Version bump to 2.8
Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Manuel Rüger <mrueg@gentoo.org>
Diffstat (limited to 'dev-embedded/esptool/esptool-2.8.ebuild')
-rw-r--r--dev-embedded/esptool/esptool-2.8.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-embedded/esptool/esptool-2.8.ebuild b/dev-embedded/esptool/esptool-2.8.ebuild
new file mode 100644
index 000000000000..c57c68a8c34c
--- /dev/null
+++ b/dev-embedded/esptool/esptool-2.8.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Utility to communicate with the ROM bootloader in Espressif ESP8266 and ESP32"
+HOMEPAGE="https://github.com/espressif/esptool"
+SRC_URI="https://github.com/espressif/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+RDEPEND="
+ dev-python/ecdsa[${PYTHON_USEDEP}]
+ dev-python/pyaes[${PYTHON_USEDEP}]
+ >=dev-python/pyserial-3.0[${PYTHON_USEDEP}]
+"
+
+DEPEND="
+ test? ( ${RDEPEND}
+ dev-python/pyelftools[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ ${EPYTHON} test/test_imagegen.py || die "imagegen test failed with ${EPYTHON}"
+ ${EPYTHON} test/test_espsecure.py || die "espsecure test failed with ${EPYTHON}"
+}