summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-embedded/gpsim/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-embedded/gpsim/files')
-rw-r--r--dev-embedded/gpsim/files/gpsim-0.26.1-glib-single-include.patch13
-rw-r--r--dev-embedded/gpsim/files/gpsim-0.26.1-gtkextra.patch29
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-embedded/gpsim/files/gpsim-0.26.1-glib-single-include.patch b/dev-embedded/gpsim/files/gpsim-0.26.1-glib-single-include.patch
new file mode 100644
index 000000000000..cd0f798281b5
--- /dev/null
+++ b/dev-embedded/gpsim/files/gpsim-0.26.1-glib-single-include.patch
@@ -0,0 +1,13 @@
+http://gpsim.svn.sourceforge.net/viewvc/gpsim/trunk/src/bitlog.h?r1=2107&r2=2182
+
+--- trunk/src/bitlog.h 2010/06/05 06:41:12 2107
++++ trunk/src/bitlog.h 2012/01/03 02:54:49 2182
+@@ -25,7 +25,7 @@
+
+ // include the absolute minimum portion of GLIB to get the definitions
+ // for guint64, etc.
+-#include <glibconfig.h>
++#include <glib.h>
+
+ /**********************************************************************
+ * boolean event logging
diff --git a/dev-embedded/gpsim/files/gpsim-0.26.1-gtkextra.patch b/dev-embedded/gpsim/files/gpsim-0.26.1-gtkextra.patch
new file mode 100644
index 000000000000..913290970516
--- /dev/null
+++ b/dev-embedded/gpsim/files/gpsim-0.26.1-gtkextra.patch
@@ -0,0 +1,29 @@
+=== modified file 'configure.ac'
+--- configure.ac 2012-06-02 20:11:32 +0000
++++ configure.ac 2012-06-02 20:11:44 +0000
+@@ -79,15 +79,20 @@
+ else
+ dnl gtk2 checks
+
+- $PKGCONFIG --exists gtkextra-2.0
++ GTKEXTRAMOD="gtkextra-2.0"
++ $PKGCONFIG --exists $GTKEXTRAMOD
+ if test $? != 0; then
+- AC_MSG_ERROR(Cannot find gtkextra-2.0 package)
++ GTKEXTRAMOD="gtkextra-3.0"
++ $PKGCONFIG --exists $GTKEXTRAMOD
++ if test $? != 0; then
++ AC_MSG_ERROR(Cannot find gtkextra-2.0 or gtkextra-3.0 package)
++ fi
+ fi
+
+ X_LDFLAGS=`$PKGCONFIG --libs gtk+-2.0 gthread-2.0`
+ X_CFLAGS=`$PKGCONFIG --cflags gtk+-2.0`
+- Y_LDFLAGS=`$PKGCONFIG --libs gtkextra-2.0`
+- Y_CFLAGS=`$PKGCONFIG --cflags gtkextra-2.0`
++ Y_LDFLAGS=`$PKGCONFIG --libs $GTKEXTRAMOD`
++ Y_CFLAGS=`$PKGCONFIG --cflags $GTKEXTRAMOD`
+ GTK_VERSION_T=`$PKGCONFIG --modversion gtk+-2.0`
+ echo linking with gtk-$GTK_VERSION_T
+ AC_DEFINE_UNQUOTED([GTK_VERSION],"$GTK_VERSION_T",[gtk version])
+