summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-embedded/kobs-ng
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-embedded/kobs-ng')
-rw-r--r--dev-embedded/kobs-ng/Manifest1
-rw-r--r--dev-embedded/kobs-ng/files/kobs-ng-fix-array-violation.patch13
-rw-r--r--dev-embedded/kobs-ng/files/kobs-ng-fix-mtd-defines.patch75
-rw-r--r--dev-embedded/kobs-ng/files/kobs-ng-fix-open-without-mode.patch13
-rw-r--r--dev-embedded/kobs-ng/kobs-ng-3.0.35.4.1.0.ebuild27
-rw-r--r--dev-embedded/kobs-ng/metadata.xml5
6 files changed, 134 insertions, 0 deletions
diff --git a/dev-embedded/kobs-ng/Manifest b/dev-embedded/kobs-ng/Manifest
new file mode 100644
index 000000000000..965bf5e1035c
--- /dev/null
+++ b/dev-embedded/kobs-ng/Manifest
@@ -0,0 +1 @@
+DIST kobs-ng-3.0.35-4.1.0.tar.gz 145817 SHA256 92d2f23add8c5d3102c77f241cae26ca55871ccc613a7af833bebbbac7afb8ea SHA512 b2bb27202ecbf31bebec8eadcf04362178ec74337400416259237880b94ac2e5fcffae59b48857e9fcfa1b1aae584b181901d4dafea63eb1e0972ed3bc3b9e6e WHIRLPOOL 03674167651e9bb9fa71983ea71eb207fc96da4c881fb5def3ebfffdb86a8a2cee08de741d102c7aa1781619959064d54b79f74959940c2177c2f15d65acd76e
diff --git a/dev-embedded/kobs-ng/files/kobs-ng-fix-array-violation.patch b/dev-embedded/kobs-ng/files/kobs-ng-fix-array-violation.patch
new file mode 100644
index 000000000000..28b1ef97c7f0
--- /dev/null
+++ b/dev-embedded/kobs-ng/files/kobs-ng-fix-array-violation.patch
@@ -0,0 +1,13 @@
+the part array is declared as part[2], so trying to index [2] isn't going to work
+
+--- a/src/mtd.c
++++ b/src/mtd.c
+@@ -786,7 +786,7 @@
+ mp->ecc = 1;
+ }
+
+- if (md->part[1].fd >= 0 && md->part[2].fd >=0)
++ if (md->part[1].fd >= 0)
+ md->flags |= F_MULTICHIP;
+
+ /* if a second partition has been opened, verify that are compatible */
diff --git a/dev-embedded/kobs-ng/files/kobs-ng-fix-mtd-defines.patch b/dev-embedded/kobs-ng/files/kobs-ng-fix-mtd-defines.patch
new file mode 100644
index 000000000000..b7dfbe3e2e39
--- /dev/null
+++ b/dev-embedded/kobs-ng/files/kobs-ng-fix-mtd-defines.patch
@@ -0,0 +1,75 @@
+# Source: http://git.buildroot.net/buildroot/plain/package/kobs-ng/kobs-ng-fix-mtd-defines.patch?id=b6fb2f5018fe0ae9bba275991efc502236422924
+
+Newer kernel headers renamed mtd mode defines and no longer support
+MEMSETOOBSEL. Allow code to work with both older and newer kernel
+versions.
+
+Signed-off-by: Paul B. Henson <henson@acm.org>
+
+diff -u -r kobs-ng-3.0.35-4.0.0-orig/src/mtd.c kobs-ng-3.0.35-4.0.0/src/mtd.c
+--- kobs-ng-3.0.35-4.0.0-orig/src/mtd.c 2012-12-17 22:37:40.000000000 -0800
++++ kobs-ng-3.0.35-4.0.0/src/mtd.c 2013-07-28 19:39:59.000000000 -0700
+@@ -852,8 +852,11 @@
+ mp = &md->part[i];
+
+ if (mp->fd != -1) {
++/* Newer kernels dropped MEMSETOOBSEL */
++#ifdef MEMSETOOBSEL
+ (void)ioctl(mp->fd, MEMSETOOBSEL,
+ &mp->old_oobinfo);
++#endif
+ close(mp->fd);
+ }
+
+@@ -896,6 +899,8 @@
+ continue;
+ }
+
++/* Newer kernels dropped MEMSETOOBSEL */
++#ifdef MEMSETOOBSEL
+ if (r == -ENOTTY) {
+ r = ioctl(mp->fd, MEMSETOOBSEL, &mp->old_oobinfo);
+ if (r != 0) {
+@@ -904,6 +909,7 @@
+ }
+ mp->oobinfochanged = 0;
+ }
++#endif
+ } else {
+ r = ioctl(mp->fd, MTDFILEMODE, (void *)MTD_MODE_RAW);
+ if (r != 0 && r != -ENOTTY) {
+@@ -911,6 +917,8 @@
+ continue;
+ }
+
++/* Newer kernels dropped MEMSETOOBSEL */
++#ifdef MEMSETOOBSEL
+ if (r == -ENOTTY) {
+ r = ioctl(mp->fd, MEMSETOOBSEL, &none_oobinfo);
+ if (r != 0) {
+@@ -920,6 +928,7 @@
+ mp->oobinfochanged = 1;
+ } else
+ mp->oobinfochanged = 2;
++#endif
+ }
+
+ mp->ecc = ecc;
+diff -u -r kobs-ng-3.0.35-4.0.0-orig/src/mtd.h kobs-ng-3.0.35-4.0.0/src/mtd.h
+--- kobs-ng-3.0.35-4.0.0-orig/src/mtd.h 2012-12-17 22:37:40.000000000 -0800
++++ kobs-ng-3.0.35-4.0.0/src/mtd.h 2013-07-28 19:33:57.000000000 -0700
+@@ -31,6 +31,14 @@
+ #include "BootControlBlocks.h"
+ #include "rom_nand_hamming_code_ecc.h"
+
++// Newer kernel headers renamed define
++#ifndef MTD_MODE_NORMAL
++#define MTD_MODE_NORMAL MTD_FILE_MODE_NORMAL
++#endif
++#ifndef MTD_MODE_RAW
++#define MTD_MODE_RAW MTD_FILE_MODE_RAW
++#endif
++
+ //------------------------------------------------------------------------------
+ // Re-definitions of true and false, because the standard ones aren't good
+ // enough?
diff --git a/dev-embedded/kobs-ng/files/kobs-ng-fix-open-without-mode.patch b/dev-embedded/kobs-ng/files/kobs-ng-fix-open-without-mode.patch
new file mode 100644
index 000000000000..47fd33170b2e
--- /dev/null
+++ b/dev-embedded/kobs-ng/files/kobs-ng-fix-open-without-mode.patch
@@ -0,0 +1,13 @@
+add missing mode to open() when using O_CREAT
+
+--- kobs-ng-3.0.35-4.1.0/src/main.c
++++ kobs-ng-3.0.35-4.1.0/src/main.c
+@@ -563,7 +563,7 @@
+ int sz = getpagesize();
+
+ from = open(file_name, O_RDONLY);
+- to = open(tmp_file, O_CREAT | O_RDWR);
++ to = open(tmp_file, O_CREAT | O_RDWR, 0644);
+ if (from < 0 || to < 0) {
+ fprintf(stderr, "unable to create a temporary file\n");
+ exit(5);
diff --git a/dev-embedded/kobs-ng/kobs-ng-3.0.35.4.1.0.ebuild b/dev-embedded/kobs-ng/kobs-ng-3.0.35.4.1.0.ebuild
new file mode 100644
index 000000000000..a1dd4e859cbb
--- /dev/null
+++ b/dev-embedded/kobs-ng/kobs-ng-3.0.35.4.1.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils versionator
+
+MY_PV="$(get_version_component_range 1-3)-$(get_version_component_range 4-)"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="utility to write u-boot images to NAND on Freescale iMX devices"
+HOMEPAGE="http://www.freescale.com/webapp/sps/site/prod_summary.jsp?code=IMX6_SW"
+SRC_URI="http://storage.googleapis.com/chromeos-localmirror/distfiles/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/kobs-ng-fix-mtd-defines.patch
+ epatch "${FILESDIR}"/kobs-ng-fix-open-without-mode.patch
+ epatch "${FILESDIR}"/kobs-ng-fix-array-violation.patch
+}
diff --git a/dev-embedded/kobs-ng/metadata.xml b/dev-embedded/kobs-ng/metadata.xml
new file mode 100644
index 000000000000..92114080841c
--- /dev/null
+++ b/dev-embedded/kobs-ng/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>dev-embedded</herd>
+</pkgmetadata>