summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-embedded/openocd/openocd-0.9.0.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-embedded/openocd/openocd-0.9.0.ebuild')
-rw-r--r--dev-embedded/openocd/openocd-0.9.0.ebuild128
1 files changed, 128 insertions, 0 deletions
diff --git a/dev-embedded/openocd/openocd-0.9.0.ebuild b/dev-embedded/openocd/openocd-0.9.0.ebuild
new file mode 100644
index 000000000000..c61aec8386f6
--- /dev/null
+++ b/dev-embedded/openocd/openocd-0.9.0.ebuild
@@ -0,0 +1,128 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils multilib flag-o-matic toolchain-funcs udev
+
+# One ebuild to rule them all
+if [[ ${PV} == "9999" ]] ; then
+ inherit autotools git-2
+ EGIT_REPO_URI="git://git.code.sf.net/p/${PN}/code"
+else
+ MY_PV="${PV/_/-}"
+ MY_P="${PN}-${MY_PV}"
+ S="${WORKDIR}"/${MY_P}
+ KEYWORDS="~amd64 ~arm ~x86"
+ SRC_URI="mirror://sourceforge/project/${PN}/${PN}/${MY_PV}/${MY_P}.tar.gz"
+fi
+
+DESCRIPTION="OpenOCD - Open On-Chip Debugger"
+HOMEPAGE="http://openocd.sourceforge.net"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="cmsis-dap dummy ftdi parport +usb verbose-io"
+RESTRICT="strip" # includes non-native binaries
+
+RDEPEND=">=dev-lang/jimtcl-0.76
+ cmsis-dap? ( dev-libs/hidapi )
+ usb? (
+ virtual/libusb:0
+ virtual/libusb:1
+ )
+ ftdi? ( dev-embedded/libftdi )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch_user
+
+ if [[ ${PV} == "9999" ]] ; then
+ AT_NO_RECURSIVE=yes eautoreconf
+ fi
+}
+
+src_configure() {
+ # Here are some defaults
+ local myconf=(
+ --enable-buspirate
+ --disable-werror
+ --disable-internal-jimtcl
+ --enable-amtjtagaccel
+ --enable-ep93xx
+ --enable-at91rm9200
+ --enable-gw16012
+ --enable-oocd_trace
+ --enable-arm-jtag-ew
+ --enable-sysfsgpio
+ --enable-bcm2835gpio
+ )
+
+ # Adapters requiring usb/libusb-1.X support
+ if use usb; then
+ myconf+=(
+ --enable-aice
+ --enable-usb-blaster-2
+ --enable-ftdi
+ --enable-ti-icdi
+ --enable-ulink
+ --enable-osbdm
+ --enable-opendous
+ --enable-usbprog
+ --enable-jlink
+ --enable-rlink
+ --enable-stlink
+ --enable-vsllink
+ --enable-armjtagew
+ $(use_enable verbose-io verbose-usb-io)
+ $(use_enable verbose-io verbose_usb_comms)
+ )
+ else
+ myconf+=(
+ --disable-aice
+ --disable-usb-blaster-2
+ --disable-ftdi
+ --disable-ti-icdi
+ --disable-ulink
+ --disable-osbdm
+ --disable-opendous
+ --disable-usbprog
+ --disable-jlink
+ --disable-rlink
+ --disable-stlink
+ --disable-vsllink
+ --disable-armjtagew
+ )
+ fi
+
+ if use ftdi; then
+ myconf+=(
+ --enable-usb_blaster_libftdi
+ --enable-openjtag_ftdi
+ --enable-presto_libftdi
+ )
+ else
+ myconf+=(
+ --disable-openjtag_ftdi
+ --disable-presto_libftdi
+ --disable-usb_blaster_libftdi
+ )
+ fi
+
+ econf \
+ $(use_enable dummy) \
+ $(use_enable cmsis-dap) \
+ $(use_enable parport) \
+ $(use_enable parport parport_ppdev) \
+ $(use_enable verbose-io verbose-jtag-io) \
+ "${myconf[@]}"
+}
+
+src_install() {
+ default
+ env -uRESTRICT prepstrip "${ED}"/usr/bin
+ udev_dorules ${D}/usr/share/${PN}/contrib/*.rules
+}