summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2020-10-14 13:43:29 +0300
committerAlexey Shvetsov <alexxy@gentoo.org>2020-10-14 13:43:29 +0300
commit3d58e601b1d01f29245c39787a190ccb0f1ae57e (patch)
tree9576f95096e3d9839aa4757e04a5441603c7a577 /dev-embedded/platformio/platformio-5.0.1.ebuild
parentdev-python/marshmallow: Add py39 (diff)
downloadgentoo-3d58e601b1d01f29245c39787a190ccb0f1ae57e.tar.gz
gentoo-3d58e601b1d01f29245c39787a190ccb0f1ae57e.tar.bz2
gentoo-3d58e601b1d01f29245c39787a190ccb0f1ae57e.zip
dev-embedded/platformio: Version bump
Added py39 Closes: https://bugs.gentoo.org/746776 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Alexey Shvetsov <alexxy@gentoo.org>
Diffstat (limited to 'dev-embedded/platformio/platformio-5.0.1.ebuild')
-rw-r--r--dev-embedded/platformio/platformio-5.0.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-embedded/platformio/platformio-5.0.1.ebuild b/dev-embedded/platformio/platformio-5.0.1.ebuild
new file mode 100644
index 000000000000..4a0f1155325f
--- /dev/null
+++ b/dev-embedded/platformio/platformio-5.0.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="An open source ecosystem for IoT development"
+HOMEPAGE="https://platformio.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(python_gen_cond_dep '
+ dev-python/setuptools[${PYTHON_MULTI_USEDEP}]
+ ')"
+RDEPEND="${DEPEND}
+ $(python_gen_cond_dep '
+ <dev-python/bottle-0.13[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/click-5[${PYTHON_MULTI_USEDEP}]
+ <dev-python/click-8[${PYTHON_MULTI_USEDEP}]
+ dev-python/colorama[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/pyserial-3[${PYTHON_MULTI_USEDEP}]
+ <dev-python/pyserial-4[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/requests-2.4[${PYTHON_MULTI_USEDEP}]
+ <dev-python/requests-3[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/semantic_version-2.8.1[${PYTHON_MULTI_USEDEP}]
+ <dev-python/semantic_version-3[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/tabulate-0.8.3[${PYTHON_MULTI_USEDEP}]
+ <dev-python/tabulate-1[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/pyelftools-0.25[${PYTHON_MULTI_USEDEP}]
+ <dev-python/pyelftools-1[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/marshmallow-2.20.5[${PYTHON_MULTI_USEDEP}]
+ ')"