summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-03-08 21:42:47 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-03-08 22:13:59 +0100
commitba5919427df1c775617142031cf83e31a0133a9c (patch)
tree4d4d5299a9d48d5e66eeb78033668038d544a45d /dev-embedded/ponyprog/ponyprog-2.07c-r2.ebuild
parentapp-office/calligraplan: Drop 3.2.2-r1 (diff)
downloadgentoo-ba5919427df1c775617142031cf83e31a0133a9c.tar.gz
gentoo-ba5919427df1c775617142031cf83e31a0133a9c.tar.bz2
gentoo-ba5919427df1c775617142031cf83e31a0133a9c.zip
dev-embedded/ponyprog: Drop 2.07c-r2
Closes: https://bugs.gentoo.org/528844 Closes: https://bugs.gentoo.org/770676 Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-embedded/ponyprog/ponyprog-2.07c-r2.ebuild')
-rw-r--r--dev-embedded/ponyprog/ponyprog-2.07c-r2.ebuild62
1 files changed, 0 insertions, 62 deletions
diff --git a/dev-embedded/ponyprog/ponyprog-2.07c-r2.ebuild b/dev-embedded/ponyprog/ponyprog-2.07c-r2.ebuild
deleted file mode 100644
index f24977b23f45..000000000000
--- a/dev-embedded/ponyprog/ponyprog-2.07c-r2.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="Serial device programmer"
-HOMEPAGE="http://www.lancos.com/ppwin95.html"
-SRC_URI="mirror://sourceforge/${PN}/Pony_Prog2000-${PV}.tar.gz"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-RDEPEND="x11-libs/libXaw
- x11-libs/libXmu
- x11-libs/libXt
- x11-libs/libXext
- x11-libs/libX11
- x11-misc/xdg-utils"
-DEPEND="${RDEPEND}
- virtual/imagemagick-tools"
-
-S="${WORKDIR}/PonyProg2000-${PV}"
-
-src_prepare() {
- sed -i -e '/CFLAGS/s:-O2::' v/Config.mk || die
- sed -i -e '/include.*<asm\/io.h>/s:asm:sys:' *.cpp || die
- sed -i -e 's/netscape/xdg-open/' e2cmdw.cpp || die
-
- convert ponyprog.ico ponyprog.png
-
- epatch \
- "${FILESDIR}/${PN}-2.07a-gcc43.patch" \
- "${FILESDIR}/${PN}-2.07c-build.patch"
- epatch_user
-}
-
-src_compile() {
- tc-export CC CXX
- # most of build is C++, but it uses CFLAGS
- CFLAGS="${CXXFLAGS}" emake HOMEV="${S}/v"
-}
-
-src_install() {
- dobin bin/ponyprog2000
- keepdir /var/lock/uucp
- fowners uucp:uucp /var/lock/uucp
- fperms 755 /var/lock/uucp
- doicon ponyprog.png
- make_desktop_entry ponyprog2000 PonyProg2000 ponyprog
-}
-
-pkg_postinst() {
- elog "To use the COM port in user mode (not as root), you need to"
- elog "be in the 'uucp' group."
- elog
- elog "To use the LPT port in user mode (not as root) you need a kernel with"
- elog "ppdev, parport and parport_pc compiled in or as modules. You need the"
- elog "rights to write to /dev/parport? devices."
-}