summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorktrace <coyote@bks.tv>2018-03-29 11:03:50 +0300
committerDavid Seifert <soap@gentoo.org>2018-04-16 23:12:37 +0200
commitcbb6b76bb0a1f24b59237c7a4d3dcfc569b0d890 (patch)
tree2b9f7ea79d457cc7402503297d5cc89dbb6340b6 /dev-embedded/ponyprog/ponyprog-3.0.0.ebuild
parentdev-embedded/ponyprog: add maintainer, add github (diff)
downloadgentoo-cbb6b76bb0a1f24b59237c7a4d3dcfc569b0d890.tar.gz
gentoo-cbb6b76bb0a1f24b59237c7a4d3dcfc569b0d890.tar.bz2
gentoo-cbb6b76bb0a1f24b59237c7a4d3dcfc569b0d890.zip
dev-embedded/ponyprog: bump version to 3.0.0
new version, dynamically linked with app-editors/qhexedit2 Package-Manager: Portage-2.3.13, Repoman-2.3.3 Closes: https://github.com/gentoo/gentoo/pull/6763
Diffstat (limited to 'dev-embedded/ponyprog/ponyprog-3.0.0.ebuild')
-rw-r--r--dev-embedded/ponyprog/ponyprog-3.0.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-embedded/ponyprog/ponyprog-3.0.0.ebuild b/dev-embedded/ponyprog/ponyprog-3.0.0.ebuild
new file mode 100644
index 000000000000..4c7bfaeb8f8c
--- /dev/null
+++ b/dev-embedded/ponyprog/ponyprog-3.0.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="EEPROM and microcontroller programmer/flasher"
+HOMEPAGE="https://github.com/lancos/ponyprog/"
+SRC_URI="https://github.com/lancos/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND=">=app-editors/qhexedit2-0.8.4_p20170719
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtprintsupport:5"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-build-system.patch
+ "${FILESDIR}"/${P}-desktop-qa.patch
+)
+
+src_configure() {
+ local mycmakeargs=( -DCMAKE_INSTALL_DOCDIR="share/doc/${PF}" )
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ elog "To use the COM port in user mode (not as root), you need to"
+ elog "be in the 'uucp' group."
+ elog
+ elog "To use the LPT port in user mode (not as root) you need a kernel with"
+ elog "ppdev, parport and parport_pc compiled in or as modules. You need the"
+ elog "rights to write to /dev/parport? devices."
+}