summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Kustov <ktrace@yandex.ru>2022-04-18 21:45:04 +0300
committerJoonas Niilola <juippis@gentoo.org>2022-05-02 15:08:36 +0300
commit1590184db7716ffb12bfec6409448a93ff4873b2 (patch)
tree04f3b48e6e12b994d47099fdc0bffce35422f3a2 /dev-embedded/ponyprog/ponyprog-3.1.3.ebuild
parentnet-misc/dropbox: drop 144.4.4491, 145.4.4921, 146.4.4836 (diff)
downloadgentoo-1590184db7716ffb12bfec6409448a93ff4873b2.tar.gz
gentoo-1590184db7716ffb12bfec6409448a93ff4873b2.tar.bz2
gentoo-1590184db7716ffb12bfec6409448a93ff4873b2.zip
dev-embedded/ponyprog: bump version to 3.1.3
- bump version to 3.1.3, qhexedit to 0.8.9 - fix build system Signed-off-by: Victor Kustov <ktrace@yandex.ru> Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-embedded/ponyprog/ponyprog-3.1.3.ebuild')
-rw-r--r--dev-embedded/ponyprog/ponyprog-3.1.3.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-embedded/ponyprog/ponyprog-3.1.3.ebuild b/dev-embedded/ponyprog/ponyprog-3.1.3.ebuild
new file mode 100644
index 000000000000..7445c12350a5
--- /dev/null
+++ b/dev-embedded/ponyprog/ponyprog-3.1.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="EEPROM and microcontroller programmer/flasher"
+HOMEPAGE="https://github.com/lancos/ponyprog/"
+SRC_URI="https://github.com/lancos/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="
+ >app-editors/qhexedit2-0.8.8_p20200625
+ dev-embedded/libftdi:1[cxx]
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtwidgets:5
+ virtual/libusb:1
+"
+# blocker on libftdi-1.5-r2: see #775116
+RDEPEND="${DEPEND}
+ !=dev-embedded/libftdi-1.5-r2
+"
+
+PATCHES=( "${FILESDIR}"/${P}-fix-build-system.patch )
+
+pkg_postinst() {
+ elog "To use the COM port in user mode (not as root), you need to"
+ elog "be in the 'uucp' group."
+ elog
+ elog "To use the LPT port in user mode (not as root) you need a kernel with"
+ elog "ppdev, parport and parport_pc compiled in or as modules. You need the"
+ elog "rights to write to /dev/parport? devices."
+}