summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-embedded/powersoftplus-libftdi
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-embedded/powersoftplus-libftdi')
-rw-r--r--dev-embedded/powersoftplus-libftdi/Manifest1
-rw-r--r--dev-embedded/powersoftplus-libftdi/metadata.xml7
-rw-r--r--dev-embedded/powersoftplus-libftdi/powersoftplus-libftdi-0.1.8-r1.ebuild39
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-embedded/powersoftplus-libftdi/Manifest b/dev-embedded/powersoftplus-libftdi/Manifest
new file mode 100644
index 000000000000..ac4a0349cec3
--- /dev/null
+++ b/dev-embedded/powersoftplus-libftdi/Manifest
@@ -0,0 +1 @@
+DIST powersoftplus-0.1.8-x86.tar.gz 4746235 SHA256 a22643a320fb8154c38b1483c279535c898381cdc79394fddb09f45aa8a712a2 SHA512 13d499bcad3044ec50502026f5d61b11693c9ff5996978ff3101a705b71569749961f82855b9179d9da89a8e51c745ca5cf308ae6dbbd21242dd1d480323ba0b WHIRLPOOL f285095cfa1c5f8d6783721dfc1ec59df80ddb16ede8bc66068c2931690a43efd53d7d921f3c53c6ce05f6f05cbbccdeaaa93816bb51a77d01eb7a4b3d5985e7
diff --git a/dev-embedded/powersoftplus-libftdi/metadata.xml b/dev-embedded/powersoftplus-libftdi/metadata.xml
new file mode 100644
index 000000000000..ff62877c67ae
--- /dev/null
+++ b/dev-embedded/powersoftplus-libftdi/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-embedded/powersoftplus-libftdi/powersoftplus-libftdi-0.1.8-r1.ebuild b/dev-embedded/powersoftplus-libftdi/powersoftplus-libftdi-0.1.8-r1.ebuild
new file mode 100644
index 000000000000..b9ff5197e685
--- /dev/null
+++ b/dev-embedded/powersoftplus-libftdi/powersoftplus-libftdi-0.1.8-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit multilib toolchain-funcs
+
+MY_PN="${PN/-libftdi/}"
+MY_P="${MY_PN}-${PV}"
+
+TABFILE="libd2xx_table.so"
+TABFILEDIR="libftdi/lib_table"
+
+DESCRIPTION="Library which includes a table of VIDs and PIDs of Ever UPS devices"
+HOMEPAGE="http://www.ever.com.pl"
+SRC_URI="http://www.ever.com.pl/pl/pliki/${MY_P}-x86.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ cd "${TABFILEDIR}"
+
+ # Wipe out precompiled binary
+ emake clean
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ ftditabfile="${TABFILEDIR}/${TABFILE}"
+ dolib.so ${ftditabfile}
+}