summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2022-03-07 15:53:15 +0100
committerJakov Smolić <jsmolic@gentoo.org>2022-03-07 20:07:56 +0100
commit95fbec2242f7bc7ecd982f146bfd334d30193b38 (patch)
tree2c1a32cd2e9dd6bf9532d59b28b58aaa313d2116 /dev-embedded/u-boot-tools
parentsys-cluster/charliecloud: Fix Python shebang. (diff)
downloadgentoo-95fbec2242f7bc7ecd982f146bfd334d30193b38.tar.gz
gentoo-95fbec2242f7bc7ecd982f146bfd334d30193b38.tar.bz2
gentoo-95fbec2242f7bc7ecd982f146bfd334d30193b38.zip
dev-embedded/u-boot-tools: drop 2021.10
Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'dev-embedded/u-boot-tools')
-rw-r--r--dev-embedded/u-boot-tools/Manifest1
-rw-r--r--dev-embedded/u-boot-tools/u-boot-tools-2021.10.ebuild79
2 files changed, 0 insertions, 80 deletions
diff --git a/dev-embedded/u-boot-tools/Manifest b/dev-embedded/u-boot-tools/Manifest
index d16e492eb34b..4d6ee54ddb83 100644
--- a/dev-embedded/u-boot-tools/Manifest
+++ b/dev-embedded/u-boot-tools/Manifest
@@ -1,2 +1 @@
-DIST u-boot-2021.10.tar.bz2 17358295 BLAKE2B 2471e31236ae24778b985b8e7a032fe2d480e935e9c5ee77a6aff4821c61f7fb8b3d64f9f964d62d0c076e8ac526f1b9c19f7fa1a974f4665737ab0bfd950d03 SHA512 be5be1c9a54b270307a04177d5577a21c57a02b307bf8b63d0fa2655d1f025c7ce010dca6a1f7f60d4e639c2e6fb6f0a292a2e5d190f1fad478eb12dd786c9da
DIST u-boot-2022.01.tar.bz2 17449627 BLAKE2B 574f9d248a8c19aa20b1b16cb55bb201d6c1ab2162da3f8789d39286a4f4a5a76b772d4a49c17e5572ff69f489d1d6fdc02d6e8f67a8bf6c50159b1a41e7c81d SHA512 d83c62bd8f0f51664d2aca329a3ce1379cfd1dfff439dccd6cfc2cb33cfef89a2b01855c97716f591b5550bfdf99e2f3aef7efa33f2e7834c820648f9eef3825
diff --git a/dev-embedded/u-boot-tools/u-boot-tools-2021.10.ebuild b/dev-embedded/u-boot-tools/u-boot-tools-2021.10.ebuild
deleted file mode 100644
index 92b7d18e73fb..000000000000
--- a/dev-embedded/u-boot-tools/u-boot-tools-2021.10.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit toolchain-funcs
-
-MY_P="u-boot-${PV/_/-}"
-DESCRIPTION="utilities for working with Das U-Boot"
-HOMEPAGE="https://www.denx.de/wiki/U-Boot/WebHome"
-SRC_URI="https://ftp.denx.de/pub/u-boot/${MY_P}.tar.bz2"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ppc ~ppc64 ~riscv x86"
-IUSE="envtools"
-
-RDEPEND="dev-libs/openssl:="
-DEPEND="${RDEPEND}"
-BDEPEND="
- sys-devel/bison
- sys-devel/flex
- virtual/pkgconfig
-"
-
-src_prepare() {
- default
- sed -i 's:\bpkg-config\b:${PKG_CONFIG}:g' \
- scripts/kconfig/{g,m,n,q}conf-cfg.sh \
- scripts/kconfig/Makefile \
- tools/Makefile || die
-}
-
-src_configure() {
- tc-export AR BUILD_CC CC PKG_CONFIG
-}
-
-src_compile() {
- # Unset a few KBUILD variables. Bug #540476
- unset KBUILD_OUTPUT KBUILD_SRC
-
- local myemakeargs=(
- V=1
- AR="${AR}"
- CC="${CC}"
- HOSTCC="${BUILD_CC}"
- HOSTCFLAGS="${CFLAGS} ${CPPFLAGS}"' $(HOSTCPPFLAGS)'
- HOSTLDFLAGS="${LDFLAGS}"
- )
-
- emake "${myemakeargs[@]}" tools-only_defconfig
-
- emake "${myemakeargs[@]}" \
- NO_SDL=1 \
- HOSTSTRIP=: \
- STRIP=: \
- CONFIG_ENV_OVERWRITE=y \
- $(usex envtools envtools tools-all)
-}
-
-src_test() { :; }
-
-src_install() {
- cd tools || die
-
- if ! use envtools; then
- dobin bmp_logo dumpimage fdtgrep gen_eth_addr img2srec mkenvimage mkimage
- fi
-
- dobin env/fw_printenv
-
- dosym fw_printenv /usr/bin/fw_setenv
-
- insinto /etc
- doins env/fw_env.config
-
- doman ../doc/mkimage.1
-}