summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2023-04-22 17:52:41 +0300
committerViorel Munteanu <ceamac@gentoo.org>2023-04-22 17:53:15 +0300
commit205d1e19c660c26a0a33cd4c485b8ed0888e92ba (patch)
treefefe17e499e7d427f1074e5fa620c61a4088efa6 /dev-embedded
parentdev-ruby/tty-platform: enable ruby32 (diff)
downloadgentoo-205d1e19c660c26a0a33cd4c485b8ed0888e92ba.tar.gz
gentoo-205d1e19c660c26a0a33cd4c485b8ed0888e92ba.tar.bz2
gentoo-205d1e19c660c26a0a33cd4c485b8ed0888e92ba.zip
dev-embedded/ponyprog: drop 3.1.2
Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'dev-embedded')
-rw-r--r--dev-embedded/ponyprog/Manifest1
-rw-r--r--dev-embedded/ponyprog/files/ponyprog-3.1.2-fix-build-system.patch47
-rw-r--r--dev-embedded/ponyprog/ponyprog-3.1.2.ebuild41
3 files changed, 0 insertions, 89 deletions
diff --git a/dev-embedded/ponyprog/Manifest b/dev-embedded/ponyprog/Manifest
index dfd8d4148d94..2c76d4063274 100644
--- a/dev-embedded/ponyprog/Manifest
+++ b/dev-embedded/ponyprog/Manifest
@@ -1,2 +1 @@
-DIST ponyprog-3.1.2.tar.gz 1364636 BLAKE2B a913903278791d937266da50fcd5b5bda892dcc316011117816e37fc4ef03becce893b597fb34f2a6ef05b5692bb375e4ba10b04c079a63eb735aa0ddadb5ab9 SHA512 697c6fdc775629086a1c01ad94f291fda550a9ad6065e5fdff9db9fb035b8270ed9058894db7ca17d0daf2a26cc5e431415c160d61f65214677eae2109d87603
DIST ponyprog-3.1.3.tar.gz 11479313 BLAKE2B 56704b28877687c356c72b1f28f28115cb11f40c701e207f5d3ec4aa4fa7194991162f0940400016d9ee5d42ff0a7e7da5b252f9b76417d0d8272638989fedec SHA512 09e702f3f98e65799e8c59b9c8eca6f477db3f36a2648a1fab3797f91d56c7c4e9533e32bef1fe4c641512e31828a39df4d3d83639b7541714a3cc9050cd4e67
diff --git a/dev-embedded/ponyprog/files/ponyprog-3.1.2-fix-build-system.patch b/dev-embedded/ponyprog/files/ponyprog-3.1.2-fix-build-system.patch
deleted file mode 100644
index aefbd707d585..000000000000
--- a/dev-embedded/ponyprog/files/ponyprog-3.1.2-fix-build-system.patch
+++ /dev/null
@@ -1,47 +0,0 @@
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -1,9 +1,7 @@
- PROJECT(ponyprog)
-
- # Configure CMake ...
--CMAKE_MINIMUM_REQUIRED(VERSION 2.8 FATAL_ERROR)
--# CMAKE_POLICY(SET CMP0003 OLD)
--# CMAKE_POLICY(SET CMP0015 OLD)
-+CMAKE_MINIMUM_REQUIRED(VERSION 2.8.12 FATAL_ERROR)
-
- # set the Qt version to 4 or 5
- OPTION (USE_QT5 "Using of Qt5 version for compiling" ON)
-@@ -52,15 +50,7 @@
- OPTION (USE_PROFILER "Include in binary file profiling information" OFF)
-
-
--
--IF(${USE_DEBUGGER})
-- SET(CMAKE_BUILD_TYPE Debug)
-- SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS_DEBUG} -Wall")
--ELSE()
-- SET(CMAKE_BUILD_TYPE Release)
-- SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS_RELEASE} -Wall")
--ENDIF()
--
-+ADD_COMPILE_OPTIONS("-Wall")
- MESSAGE(STATUS "CMAKE_CXX_FLAGS ${CMAKE_CXX_FLAGS}")
-
- INCLUDE(CheckIncludeFile)
-@@ -202,7 +192,6 @@
- SET ( UI_HEADERS_DIR temp )
- SET ( UI_SOURCES_DIR temp )
-
--ADD_SUBDIRECTORY(qhexedit2/src)
- ADD_SUBDIRECTORY(SrcPony)
-
- INCLUDE_DIRECTORIES( ${CMAKE_SOURCE_DIR} ${CMAKE_CURRENT_SOURCE_DIR}/qhexedit2/src/ ${CMAKE_CURRENT_SOURCE_DIR}/SrcPony/ )
-@@ -265,6 +254,8 @@
- MESSAGE(STATUS "QT LIBRARIES: ${QT_LIBRARIES} ${Qt5Widgets_LIBRARIES} ${Qt5Multimedia_LIBRARIES} ${Qt5PrintSupport_LIBRARIES} ${Qt5Core_LIBRARIES}")
- ENDIF()
-
-+TARGET_LINK_LIBRARIES(${CMAKE_PROJECT_NAME} qhexedit)
-+
- ADD_CUSTOM_TARGET (tags
- COMMAND ctags -R -f tags ${CMAKE_SOURCE_DIR}/SrcPony
- WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
diff --git a/dev-embedded/ponyprog/ponyprog-3.1.2.ebuild b/dev-embedded/ponyprog/ponyprog-3.1.2.ebuild
deleted file mode 100644
index 33d6f998f1ff..000000000000
--- a/dev-embedded/ponyprog/ponyprog-3.1.2.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="EEPROM and microcontroller programmer/flasher"
-HOMEPAGE="https://github.com/lancos/ponyprog/"
-SRC_URI="https://github.com/lancos/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc"
-
-DEPEND="
- >=app-editors/qhexedit2-0.8.6_p20190316
- dev-embedded/libftdi:1[cxx]
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtmultimedia:5
- dev-qt/qtprintsupport:5
- dev-qt/qtwidgets:5
- virtual/libusb:1
-"
-# blocker on libftdi-1.5-r2: see #775116
-RDEPEND="${DEPEND}
- !=dev-embedded/libftdi-1.5-r2
-"
-
-PATCHES=( "${FILESDIR}"/${P}-fix-build-system.patch )
-
-pkg_postinst() {
- elog "To use the COM port in user mode (not as root), you need to"
- elog "be in the 'uucp' group."
- elog
- elog "To use the LPT port in user mode (not as root) you need a kernel with"
- elog "ppdev, parport and parport_pc compiled in or as modules. You need the"
- elog "rights to write to /dev/parport? devices."
-}