summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-12 08:18:41 +0000
committerSam James <sam@gentoo.org>2021-12-12 08:18:41 +0000
commit75eb25cad20af177b18a87e835ab9f514742d5d2 (patch)
tree7ab6daa4cbb16d308817e71380d2d30966e601fa /dev-embedded
parentdev-python/ajsonrpc: update upstream metadata (diff)
downloadgentoo-75eb25cad20af177b18a87e835ab9f514742d5d2.tar.gz
gentoo-75eb25cad20af177b18a87e835ab9f514742d5d2.tar.bz2
gentoo-75eb25cad20af177b18a87e835ab9f514742d5d2.zip
dev-embedded/platformio: run tests
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-embedded')
-rw-r--r--dev-embedded/platformio/platformio-5.2.3.ebuild23
1 files changed, 20 insertions, 3 deletions
diff --git a/dev-embedded/platformio/platformio-5.2.3.ebuild b/dev-embedded/platformio/platformio-5.2.3.ebuild
index 4e9d42889936..a76ad9f23ca8 100644
--- a/dev-embedded/platformio/platformio-5.2.3.ebuild
+++ b/dev-embedded/platformio/platformio-5.2.3.ebuild
@@ -17,9 +17,6 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-# Needs some more work to get running
-RESTRICT="test"
-
RDEPEND="
$(python_gen_cond_dep '
=dev-python/aiofiles-0.7.0*[${PYTHON_USEDEP}]
@@ -45,4 +42,24 @@ RDEPEND="
')"
BDEPEND="test? ( $(python_gen_cond_dep 'dev-python/jsondiff[${PYTHON_USEDEP}]') )"
+# This list could be refined a bit to have individual tests which need network
+# (within EPYTEST_DESELECT) but so many need it that it doesn't seem worth it right now.
+EPYTEST_IGNORE=(
+ # Requires network access
+ tests/test_builder.py
+ tests/package/test_manager.py
+ tests/package/test_manifest.py
+ tests/commands/test_platform.py
+ tests/commands/test_test.py
+ tests/commands/test_ci.py
+ tests/commands/test_init.py
+ tests/commands/test_lib.py
+ tests/commands/test_lib_complex.py
+ tests/commands/test_boards.py
+ tests/commands/test_check.py
+ tests/test_ino2cpp.py
+ tests/test_maintenance.py
+ tests/test_misc.py
+)
+
distutils_enable_tests pytest