summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2022-07-07 11:58:15 +0200
committerJakov Smolić <jsmolic@gentoo.org>2022-07-07 11:58:15 +0200
commit9a76a9aa80ba00d63cee9efc14fb5f16f26e1686 (patch)
tree5095949773ef7917de6532b4080a6c32677cc355 /dev-embedded
parentdev-libs/urdfdom: bump to 3.1.0 (diff)
downloadgentoo-9a76a9aa80ba00d63cee9efc14fb5f16f26e1686.tar.gz
gentoo-9a76a9aa80ba00d63cee9efc14fb5f16f26e1686.tar.bz2
gentoo-9a76a9aa80ba00d63cee9efc14fb5f16f26e1686.zip
dev-embedded/u-boot-tools: Fix cross-compilation
Cross CFLAGS and LDFLAGS are leaking into host CFLAGS and LDFLAGS and thus it's breaking cross compilation. Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'dev-embedded')
-rw-r--r--dev-embedded/u-boot-tools/u-boot-tools-2022.04.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/dev-embedded/u-boot-tools/u-boot-tools-2022.04.ebuild b/dev-embedded/u-boot-tools/u-boot-tools-2022.04.ebuild
index 92b7d18e73fb..7bf924633a93 100644
--- a/dev-embedded/u-boot-tools/u-boot-tools-2022.04.ebuild
+++ b/dev-embedded/u-boot-tools/u-boot-tools-2022.04.ebuild
@@ -34,6 +34,7 @@ src_prepare() {
src_configure() {
tc-export AR BUILD_CC CC PKG_CONFIG
+ tc-export_build_env
}
src_compile() {
@@ -45,8 +46,8 @@ src_compile() {
AR="${AR}"
CC="${CC}"
HOSTCC="${BUILD_CC}"
- HOSTCFLAGS="${CFLAGS} ${CPPFLAGS}"' $(HOSTCPPFLAGS)'
- HOSTLDFLAGS="${LDFLAGS}"
+ HOSTCFLAGS="${BUILD_CFLAGS} ${BUILD_CPPFLAGS}"' $(HOSTCPPFLAGS)'
+ HOSTLDFLAGS="${BUILD_LDFLAGS}"
)
emake "${myemakeargs[@]}" tools-only_defconfig