summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flo@geekplace.eu>2021-04-08 09:03:44 +0200
committerSam James <sam@gentoo.org>2021-06-01 09:35:39 +0000
commitf4f65de7f9882d678081ba63b0202b5ac710cb20 (patch)
tree4ced0e5f3c0dff2ffcdf67fea19a97a0ee84c3db /dev-erlang/ezlib/ezlib-1.0.9.ebuild
parentdev-erlang/stringprep: add 1.0.25 (diff)
downloadgentoo-f4f65de7f9882d678081ba63b0202b5ac710cb20.tar.gz
gentoo-f4f65de7f9882d678081ba63b0202b5ac710cb20.tar.bz2
gentoo-f4f65de7f9882d678081ba63b0202b5ac710cb20.zip
dev-erlang/ezlib: add 1.0.9
Bug: https://bugs.gentoo.org/766686 Signed-off-by: Florian Schmaus <flo@geekplace.eu> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-erlang/ezlib/ezlib-1.0.9.ebuild')
-rw-r--r--dev-erlang/ezlib/ezlib-1.0.9.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-erlang/ezlib/ezlib-1.0.9.ebuild b/dev-erlang/ezlib/ezlib-1.0.9.ebuild
new file mode 100644
index 000000000000..b160950131dd
--- /dev/null
+++ b/dev-erlang/ezlib/ezlib-1.0.9.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit rebar
+
+DESCRIPTION="Native zlib driver for Erlang and Elixir"
+HOMEPAGE="https://github.com/processone/ezlib"
+SRC_URI="https://github.com/processone/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~sparc ~x86"
+
+DEPEND=">=dev-lang/erlang-17.1:=
+ sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+DOCS=( CHANGELOG.md README.md )