summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmadeusz Żołnowski <aidecoe@gentoo.org>2016-11-10 22:13:25 +0000
committerAmadeusz Żołnowski <aidecoe@gentoo.org>2016-11-11 20:14:48 +0000
commitc8ae9fe8d0772f130b2c8d866ecdf1a5847b3af0 (patch)
tree6de29cf4e4cb0e57ab0a539b611e6b070e7f0309 /dev-erlang/fast_xml/fast_xml-1.1.15.ebuild
parentdev-erlang/stringprep: Bump version to 1.0.6 (diff)
downloadgentoo-c8ae9fe8d0772f130b2c8d866ecdf1a5847b3af0.tar.gz
gentoo-c8ae9fe8d0772f130b2c8d866ecdf1a5847b3af0.tar.bz2
gentoo-c8ae9fe8d0772f130b2c8d866ecdf1a5847b3af0.zip
dev-erlang/fast_xml: Bump version to 1.1.15
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-erlang/fast_xml/fast_xml-1.1.15.ebuild')
-rw-r--r--dev-erlang/fast_xml/fast_xml-1.1.15.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-erlang/fast_xml/fast_xml-1.1.15.ebuild b/dev-erlang/fast_xml/fast_xml-1.1.15.ebuild
new file mode 100644
index 000000000000..1816e7e997d4
--- /dev/null
+++ b/dev-erlang/fast_xml/fast_xml-1.1.15.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit rebar
+
+DESCRIPTION="Fast Expat based Erlang XML parsing library"
+HOMEPAGE="https://github.com/processone/fast_xml"
+SRC_URI="https://github.com/processone/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~sparc ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-erlang/p1_utils-1.0.5
+ >=dev-lang/erlang-17.1
+ dev-libs/expat"
+DEPEND="${RDEPEND}
+ test? ( >=dev-lang/elixir-1.1 )"
+
+DOCS=( CHANGELOG.md README.md )