summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno <hanno@gentoo.org>2019-08-31 16:27:45 +0200
committerHanno <hanno@gentoo.org>2019-08-31 16:27:45 +0200
commitc381cbb5ee395e7f01ff395e3d1081efbb252b6e (patch)
tree948e079893c7f37b8ee6ee48fef5825e02cc2eeb /dev-erlang/fast_yaml/fast_yaml-1.0.20.ebuild
parentdev-erlang/fast_tls: Version bump (diff)
downloadgentoo-c381cbb5ee395e7f01ff395e3d1081efbb252b6e.tar.gz
gentoo-c381cbb5ee395e7f01ff395e3d1081efbb252b6e.tar.bz2
gentoo-c381cbb5ee395e7f01ff395e3d1081efbb252b6e.zip
dev-erlang/fast_yaml: Version bump.
Add upstream commit to avoid producing invalid yaml. Ebuild provided by Andrey Tikhomirov in bug #626260. Signed-off-by: Hanno Boeck <hanno@gentoo.org> Package-Manager: Portage-2.3.74, Repoman-2.3.17
Diffstat (limited to 'dev-erlang/fast_yaml/fast_yaml-1.0.20.ebuild')
-rw-r--r--dev-erlang/fast_yaml/fast_yaml-1.0.20.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-erlang/fast_yaml/fast_yaml-1.0.20.ebuild b/dev-erlang/fast_yaml/fast_yaml-1.0.20.ebuild
new file mode 100644
index 000000000000..5dfaaa979349
--- /dev/null
+++ b/dev-erlang/fast_yaml/fast_yaml-1.0.20.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit rebar
+
+DESCRIPTION="Fast Yaml native library for Erlang and Elixir"
+HOMEPAGE="https://github.com/processone/fast_yaml"
+SRC_URI="https://github.com/processone/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~sparc ~x86"
+
+DEPEND=">=dev-erlang/p1_utils-1.0.16
+ >=dev-lang/erlang-18.0
+ dev-libs/libyaml"
+RDEPEND="${DEPEND}"
+
+DOCS=( CHANGELOG.md README.md )
+
+# from upstream:
+# https://github.com/processone/fast_yaml/commit/e789f68895f71b7ad31057177810ca0161bf790e
+PATCHES=(
+ "${FILESDIR}/${P}-dont-escape-simple-quote.patch"
+)