summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flo@geekplace.eu>2021-04-08 19:55:40 +0200
committerSam James <sam@gentoo.org>2021-06-01 09:35:32 +0000
commit3a7c112932469d726e68fe8f48b234ad7a95d35a (patch)
tree32cf42c4ca444d95ffd11648bc3fa3245d65aa36 /dev-erlang/idna/idna-6.0.0-r1.ebuild
parentdev-erlang/yconf: add 1.0.11 (diff)
downloadgentoo-3a7c112932469d726e68fe8f48b234ad7a95d35a.tar.gz
gentoo-3a7c112932469d726e68fe8f48b234ad7a95d35a.tar.bz2
gentoo-3a7c112932469d726e68fe8f48b234ad7a95d35a.zip
dev-erlang/idna: fix "remove unicode_util_compat" patch
The existing patch was incomplete, unicode_util_compat had also to be patched out of src/idna.app.src. Otherwise ejabberd would potentially fail with Apr 07 21:04:38 example.org ejabberdctl[606236]: 2021-04-07 21:04:38.066241+02:00 [critical] Failed to start ejabberd application: Exception occurred during configuration processing. Apr 07 21:04:38 example.org ejabberdctl[606236]: ** exception error: nif_not_loaded Apr 07 21:04:38 example.org ejabberdctl[606236]: in function erlang:nif_error/1 Apr 07 21:04:38 example.org ejabberdctl[606236]: called as erlang:nif_error(nif_not_loaded) Apr 07 21:04:38 example.org ejabberdctl[606236]: in call from jid:string_to_usr/1 (src/jid.erl, line 121) Apr 07 21:04:38 example.org ejabberdctl[606236]: in call from jid:decode/1 (src/jid.erl, line 136) Apr 07 21:04:38 example.org ejabberdctl[606236]: in call from econf:'-domain/0-fun-0-'/1 (src/econf.erl, line 479) Apr 07 21:04:38 example.org ejabberdctl[606236]: in call from yconf:'-list/2-fun-0-'/3 (src/yconf.erl, line 542) Apr 07 21:04:38 example.org ejabberdctl[606236]: in call from lists:mapfoldl/3 (lists.erl, line 1358) Apr 07 21:04:38 example.org ejabberdctl[606236]: in call from yconf:'-list/2-fun-1-'/3 (src/yconf.erl, line 538) Apr 07 21:04:38 example.org ejabberdctl[606236]: in call from yconf:'-non_empty/1-fun-0-'/2 (src/yconf.erl, line 523) Apr 07 21:04:38 example.org systemd[1]: ejabberd.service: Main process exited, code=exited, status=1/FAILURE Bug: https://bugs.gentoo.org/766686 Signed-off-by: Florian Schmaus <flo@geekplace.eu> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-erlang/idna/idna-6.0.0-r1.ebuild')
-rw-r--r--dev-erlang/idna/idna-6.0.0-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-erlang/idna/idna-6.0.0-r1.ebuild b/dev-erlang/idna/idna-6.0.0-r1.ebuild
new file mode 100644
index 000000000000..853b273e7c8a
--- /dev/null
+++ b/dev-erlang/idna/idna-6.0.0-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit rebar
+
+DESCRIPTION="Erlang IDNA implementation"
+HOMEPAGE="https://github.com/benoitc/erlang-idna"
+SRC_URI="https://github.com/benoitc/erlang-idna/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ia64 ~ppc ~sparc x86"
+
+DEPEND=">=dev-lang/erlang-21.0"
+
+DOCS=( CHANGELOG README.md )
+
+S="${WORKDIR}/erlang-idna-${PV}"
+
+# Removes dependency to workaround for older erlang versions.
+# Patch based on https://github.com/benoitc/erlang-idna/pull/31
+PATCHES=( "${FILESDIR}/0001-Remove-dependency-on-unicode_util_compat.patch" )