summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno <hanno@gentoo.org>2019-11-02 14:07:18 +0100
committerHanno <hanno@gentoo.org>2019-11-02 14:07:18 +0100
commite85e19067f4629b655709bee6376bcafb993b7db (patch)
tree1c7156945f4de4c05b195fd1c8e48ae19ecb9eb5 /dev-erlang/idna/idna-6.0.0.ebuild
parentdev-erlang/eimp: Assign to ejabberd project. (diff)
downloadgentoo-e85e19067f4629b655709bee6376bcafb993b7db.tar.gz
gentoo-e85e19067f4629b655709bee6376bcafb993b7db.tar.bz2
gentoo-e85e19067f4629b655709bee6376bcafb993b7db.zip
dev-erlang/idna: Initial commit
Dependency of latest dev-erlang/xmpp version. Use upstream patch to avoid adding a compatibility package for older erlang versions. Signed-off-by: Hanno Boeck <hanno@gentoo.org> Package-Manager: Portage-2.3.78, Repoman-2.3.17
Diffstat (limited to 'dev-erlang/idna/idna-6.0.0.ebuild')
-rw-r--r--dev-erlang/idna/idna-6.0.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-erlang/idna/idna-6.0.0.ebuild b/dev-erlang/idna/idna-6.0.0.ebuild
new file mode 100644
index 000000000000..243854541657
--- /dev/null
+++ b/dev-erlang/idna/idna-6.0.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit rebar
+
+DESCRIPTION="Erlang IDNA implementation"
+HOMEPAGE="https://github.com/benoitc/erlang-idna"
+SRC_URI="https://github.com/benoitc/erlang-idna/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND=">=dev-lang/erlang-21.0"
+
+DOCS=( CHANGELOG README.md )
+
+S="${WORKDIR}/erlang-idna-${PV}"
+
+# Removes dependency to workaround for older erlang versions.
+# Patch from https://github.com/benoitc/erlang-idna/pull/31
+PATCHES=( "${FILESDIR}/idna-remove-unicode_util_compat.diff" )