summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno <hanno@gentoo.org>2019-08-31 17:37:36 +0200
committerHanno <hanno@gentoo.org>2019-08-31 17:37:36 +0200
commit63a781de5dcc1316217eceb2bcbdfec06ca0a3c6 (patch)
tree51ddc08cd1bc918c5430eaef37d2bdfa7fb1c6d0 /dev-erlang/p1_oauth2/p1_oauth2-0.6.5.ebuild
parentdev-erlang/p1_mysql: Version bump (diff)
downloadgentoo-63a781de5dcc1316217eceb2bcbdfec06ca0a3c6.tar.gz
gentoo-63a781de5dcc1316217eceb2bcbdfec06ca0a3c6.tar.bz2
gentoo-63a781de5dcc1316217eceb2bcbdfec06ca0a3c6.zip
dev-erlang/p1_oauth2: Version bump
Signed-off-by: Hanno Boeck <hanno@gentoo.org> Package-Manager: Portage-2.3.74, Repoman-2.3.17
Diffstat (limited to 'dev-erlang/p1_oauth2/p1_oauth2-0.6.5.ebuild')
-rw-r--r--dev-erlang/p1_oauth2/p1_oauth2-0.6.5.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-erlang/p1_oauth2/p1_oauth2-0.6.5.ebuild b/dev-erlang/p1_oauth2/p1_oauth2-0.6.5.ebuild
new file mode 100644
index 000000000000..ba3919e1090f
--- /dev/null
+++ b/dev-erlang/p1_oauth2/p1_oauth2-0.6.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit rebar
+
+DESCRIPTION="Erlang OAuth 2.0 implementation"
+HOMEPAGE="https://github.com/processone/p1_oauth2"
+SRC_URI="https://github.com/processone/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~sparc ~x86"
+IUSE="test"
+
+CDEPEND=">=dev-lang/erlang-17.1"
+DEPEND="${CDEPEND}
+ test? (
+ >=dev-erlang/meck-0.8.7
+ >=dev-erlang/proper-1.3
+ )"
+RDEPEND="${CDEPEND}"
+
+DOCS=( CHANGELOG.md README.md )
+
+src_prepare() {
+ rebar_src_prepare
+ rebar_remove_deps rebar.test.config
+}
+
+src_test() {
+ erebar -C rebar.test.config compile eunit
+}