summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-10 23:02:54 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-11 00:22:38 +0100
commit064af661d0c9a31cecdf348632bc5603333a9149 (patch)
tree2202373a7cafcb8a761d32747d4f62263aed64d5 /dev-erlang/p1_oauth2
parentdev-python/passlib: keyworded 1.7.1-r2 for hppa, bug #700918 (diff)
downloadgentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.gz
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.bz2
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.zip
*/*: [QA] Fix trivial cases of MissingTestRestrict
The result was achieved via the following pipeline: pkgcheck scan -c RestrictTestCheck -R FormatReporter \ --format '{category}/{package}/{package}-{version}.ebuild' | xargs -n32 grep -L RESTRICT | xargs -n32 sed -i -e '/^IUSE=.*test/aRESTRICT="!test? ( test )"' The resulting metadata was compared before and after the change. Few Go ebuilds had to be fixed manually due to implicit RESTRICT=strip added by the eclass. Two ebuilds have to be fixed because of multiline IUSE. Suggested-by: Robin H. Johnson <robbat2@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/13942 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-erlang/p1_oauth2')
-rw-r--r--dev-erlang/p1_oauth2/p1_oauth2-0.6.1.ebuild3
-rw-r--r--dev-erlang/p1_oauth2/p1_oauth2-0.6.5.ebuild1
2 files changed, 3 insertions, 1 deletions
diff --git a/dev-erlang/p1_oauth2/p1_oauth2-0.6.1.ebuild b/dev-erlang/p1_oauth2/p1_oauth2-0.6.1.ebuild
index f151840da6e5..45a97620b3b4 100644
--- a/dev-erlang/p1_oauth2/p1_oauth2-0.6.1.ebuild
+++ b/dev-erlang/p1_oauth2/p1_oauth2-0.6.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -14,6 +14,7 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 ~arm ~ia64 ppc ~sparc x86"
IUSE="test"
+RESTRICT="!test? ( test )"
CDEPEND=">=dev-lang/erlang-17.1"
DEPEND="${CDEPEND}
diff --git a/dev-erlang/p1_oauth2/p1_oauth2-0.6.5.ebuild b/dev-erlang/p1_oauth2/p1_oauth2-0.6.5.ebuild
index ba3919e1090f..87f8db520570 100644
--- a/dev-erlang/p1_oauth2/p1_oauth2-0.6.5.ebuild
+++ b/dev-erlang/p1_oauth2/p1_oauth2-0.6.5.ebuild
@@ -14,6 +14,7 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~sparc ~x86"
IUSE="test"
+RESTRICT="!test? ( test )"
CDEPEND=">=dev-lang/erlang-17.1"
DEPEND="${CDEPEND}