summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flo@geekplace.eu>2021-04-10 09:18:39 +0200
committerSam James <sam@gentoo.org>2021-06-01 09:35:24 +0000
commitc333e4edb79f74a3823841bd08330150a71c369f (patch)
tree48c0284e4b645ca173d177d1073b9acc6cc92c2e /dev-erlang
parentacct-group/epam: initial import (diff)
downloadgentoo-c333e4edb79f74a3823841bd08330150a71c369f.tar.gz
gentoo-c333e4edb79f74a3823841bd08330150a71c369f.tar.bz2
gentoo-c333e4edb79f74a3823841bd08330150a71c369f.zip
dev-erlang/epam: migrate to GLEP 81: depend on acct-group/epam
Closes: https://bugs.gentoo.org/755185 Signed-off-by: Florian Schmaus <flo@geekplace.eu> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-erlang')
-rw-r--r--dev-erlang/epam/epam-1.0.8-r1.ebuild (renamed from dev-erlang/epam/epam-1.0.8.ebuild)15
-rw-r--r--dev-erlang/epam/epam-1.0.9-r1.ebuild (renamed from dev-erlang/epam/epam-1.0.9.ebuild)15
2 files changed, 14 insertions, 16 deletions
diff --git a/dev-erlang/epam/epam-1.0.8.ebuild b/dev-erlang/epam/epam-1.0.8-r1.ebuild
index 8d61dee63ee8..cc1bc6c2e84d 100644
--- a/dev-erlang/epam/epam-1.0.8.ebuild
+++ b/dev-erlang/epam/epam-1.0.8-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit rebar user
+inherit rebar
DESCRIPTION="epam for ejabberd to help with PAM authentication support"
HOMEPAGE="https://github.com/processone/epam"
@@ -14,16 +14,15 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86"
-DEPEND=">=dev-lang/erlang-17.1
- sys-libs/pam"
+DEPEND="
+ acct-group/epam
+ >=dev-lang/erlang-17.1
+ sys-libs/pam
+"
RDEPEND="${DEPEND}"
DOCS=( CHANGELOG.md README.md )
-pkg_setup() {
- enewgroup "${PN}"
-}
-
src_install() {
rebar_src_install
diff --git a/dev-erlang/epam/epam-1.0.9.ebuild b/dev-erlang/epam/epam-1.0.9-r1.ebuild
index bc3c599bafe4..ced309ebcc0a 100644
--- a/dev-erlang/epam/epam-1.0.9.ebuild
+++ b/dev-erlang/epam/epam-1.0.9-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit rebar user
+inherit rebar
DESCRIPTION="epam for ejabberd to help with PAM authentication support"
HOMEPAGE="https://github.com/processone/epam"
@@ -14,16 +14,15 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-DEPEND=">=dev-lang/erlang-17.1
- sys-libs/pam"
+DEPEND="
+ acct-group/epam
+ >=dev-lang/erlang-17.1
+ sys-libs/pam
+"
RDEPEND="${DEPEND}"
DOCS=( CHANGELOG.md README.md )
-pkg_setup() {
- enewgroup "${PN}"
-}
-
src_install() {
rebar_src_install