summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-games/KXL
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-games/KXL')
-rw-r--r--dev-games/KXL/KXL-1.1.7-r2.ebuild34
-rw-r--r--dev-games/KXL/Manifest1
-rw-r--r--dev-games/KXL/files/KXL-1.1.7-amd64.patch95
-rw-r--r--dev-games/KXL/files/KXL-1.1.7-as-needed.patch8
-rw-r--r--dev-games/KXL/files/KXL-1.1.7-ldflags.patch10
-rw-r--r--dev-games/KXL/files/KXL-1.1.7-m4.patch9
-rw-r--r--dev-games/KXL/metadata.xml19
7 files changed, 176 insertions, 0 deletions
diff --git a/dev-games/KXL/KXL-1.1.7-r2.ebuild b/dev-games/KXL/KXL-1.1.7-r2.ebuild
new file mode 100644
index 000000000000..c0f2d113c1ae
--- /dev/null
+++ b/dev-games/KXL/KXL-1.1.7-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils autotools
+
+DESCRIPTION="Development Library for making games for X"
+HOMEPAGE="http://kxl.orz.hm/"
+SRC_URI="http://kxl.hn.org/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="static-libs"
+
+DEPEND="x11-libs/libX11"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-m4.patch \
+ "${FILESDIR}"/${P}-amd64.patch \
+ "${FILESDIR}"/${P}-as-needed.patch \
+ "${FILESDIR}"/${P}-ldflags.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ use static-libs || prune_libtool_files
+}
diff --git a/dev-games/KXL/Manifest b/dev-games/KXL/Manifest
new file mode 100644
index 000000000000..fffe482117c1
--- /dev/null
+++ b/dev-games/KXL/Manifest
@@ -0,0 +1 @@
+DIST KXL-1.1.7.tar.gz 192070 SHA256 118b704befa24992031b51c9da1bc3786da153cfb21a0452bae97b1d479bdd98 SHA512 f3a9051b0e8916745725a2809097df07c59f8811f336574def7e479c992175d0bd49661817f9da35d122d291aff0bde5d4c27e5b17a3f09878e71b2c7a709adb WHIRLPOOL 1aa271911adee47bc9d954f409c5bb0b93bdb51ead0313ee9461889b6591823cd93a4ec8dbd08329498c731840d472ed2cb7048dfa936fa1a0f311f927c833a5
diff --git a/dev-games/KXL/files/KXL-1.1.7-amd64.patch b/dev-games/KXL/files/KXL-1.1.7-amd64.patch
new file mode 100644
index 000000000000..ec4b141d2a3e
--- /dev/null
+++ b/dev-games/KXL/files/KXL-1.1.7-amd64.patch
@@ -0,0 +1,95 @@
+--- src/KXLsound.c.old 2007-05-13 21:59:27.000000000 +0200
++++ src/KXLsound.c 2007-05-13 22:09:19.000000000 +0200
+@@ -4,6 +4,9 @@
+ #include <sys/ioctl.h>
+ #include <sys/time.h>
+ #include <linux/soundcard.h>
++#include <stdlib.h>
++#include <errno.h>
++#include <string.h>
+ #include "KXL.h"
+
+ #define MIN(a, b) (((a) < (b)) ? (a) : (b))
+@@ -22,7 +24,7 @@
+ struct {
+ Uint16 ListCnt;
+ Sint32 ID;
+- Sint32 Pipe[2];
++ int Pipe[2];
+ Sint32 Device;
+ Uint16 PlayCnt;
+ KXL_SoundControl PlaySound[MAX_SOUNDS_PLAYING];
+@@ -242,11 +244,19 @@
+ KXL_SoundOk = False;
+
+ KXL_LoadSoundData(path, fname);
+- // device check
+- if ((KXL_SoundData.Device = open("/dev/dsp", O_WRONLY)) == -1) {
+- fprintf(stderr, "KXL error message\nnot found sound card\n");
++ // Open the sound device in non-blocking mode, because ALSA's OSS
++ // emulation and some broken OSS drivers would make a blocking call
++ // wait forever until the device is available. Since this breaks the
++ // OSS spec, we immediately put it back to blocking mode if the
++ // operation was successful.
++ KXL_SoundData.Device = open("/dev/dsp", O_WRONLY|O_NDELAY);
++ if (KXL_SoundData.Device < 0) {
++ fprintf(stderr, "KXL error message\ncould not open sound card (%s)\n",
++ strerror(errno));
+ return;
+ }
++ fcntl( KXL_SoundData.Device, F_SETFL,
++ fcntl( KXL_SoundData.Device, F_GETFL ) &~ FNDELAY );
+ // create pipe
+ if (pipe(KXL_SoundData.Pipe) < 0) {
+ fprintf(stderr, "KXL error message\npipe error\n");
+--- src/KXL.h.old 2007-05-13 22:25:11.000000000 +0200
++++ src/KXL.h 2007-05-13 22:25:47.000000000 +0200
+@@ -205,6 +205,7 @@
+ KXL_Frame *Frame; // Pointer of frame structure
+ GC FontGC; // GC of font
+ XFontStruct *WinFont; // Pointer of font structrue
++ Bool DetectAutoRepeat; // Does the server have detectable auto repeat
+ } KXL_Window;
+ // RGBE palette
+ typedef struct {
+--- src/KXLimage.c.old 2007-05-13 22:29:02.000000000 +0200
++++ src/KXLimage.c 2007-05-13 22:29:33.000000000 +0200
+@@ -1,4 +1,5 @@
+ #include <stdio.h>
++#include <stdlib.h>
+ #include "KXL.h"
+
+ extern KXL_Window *KXL_Root;
+--- src/KXLvisual.c.old 2007-05-13 22:22:34.000000000 +0200
++++ src/KXLvisual.c 2007-05-13 22:28:39.000000000 +0200
+@@ -1,4 +1,6 @@
+ #include <stdio.h>
++#include <stdlib.h>
++#include <string.h>
+ #include "KXL.h"
+
+ //================================================================
+@@ -364,7 +366,11 @@
+ KXL_ReSizeFrame(w, h);
+ KXL_Clear_Frame(0, 0, w, h);
+ // Auto repeat off
+- XAutoRepeatOff(KXL_Root->Display);
++ XkbSetDetectableAutoRepeat(KXL_Root->Display, True,
++ &KXL_Root->DetectAutoRepeat);
++ if(!KXL_Root->DetectAutoRepeat) {
++ XAutoRepeatOff(KXL_Root->Display);
++ }
+ }
+
+ //==============================================================
+@@ -377,7 +383,9 @@
+ XFreeGC(KXL_Root->Display, KXL_Root->Frame->Gc);
+ KXL_Free(KXL_Root->Frame);
+ // Auto repeat on
+- XAutoRepeatOn(KXL_Root->Display);
++ if(!KXL_Root->DetectAutoRepeat) {
++ XAutoRepeatOn(KXL_Root->Display);
++ }
+ // Delete font
+ XFreeGC(KXL_Root->Display, KXL_Root->FontGC);
+ // Delete window
diff --git a/dev-games/KXL/files/KXL-1.1.7-as-needed.patch b/dev-games/KXL/files/KXL-1.1.7-as-needed.patch
new file mode 100644
index 000000000000..d99564202ecd
--- /dev/null
+++ b/dev-games/KXL/files/KXL-1.1.7-as-needed.patch
@@ -0,0 +1,8 @@
+--- src/Makefile.am.old 2009-01-28 16:03:27.000000000 +0100
++++ src/Makefile.am 2009-01-28 16:03:47.000000000 +0100
+@@ -2,3 +2,4 @@
+ libKXL_la_SOURCES = KXLmisc.c KXLsound.c KXLjoystick.c KXLvisual.c KXLimage.c
+ include_HEADERS = KXL.h
+ libKXL_la_LDFLAGS = -release $(VERSION)
++libKXL_la_LIBADD = -lX11
+
diff --git a/dev-games/KXL/files/KXL-1.1.7-ldflags.patch b/dev-games/KXL/files/KXL-1.1.7-ldflags.patch
new file mode 100644
index 000000000000..e628b5d2170f
--- /dev/null
+++ b/dev-games/KXL/files/KXL-1.1.7-ldflags.patch
@@ -0,0 +1,10 @@
+--- KXL.m4.old 2010-09-23 14:20:45.000000000 +0200
++++ KXL.m4 2010-09-23 14:21:08.000000000 +0200
+@@ -29,7 +29,6 @@
+
+ dnl add the KXL library
+ KXL_LIBS="$KXL_LIBS -lKXL"
+-LDFLAGS="$KXL_LIBS"
+ AC_MSG_RESULT($KXL_LIBS)
+
+ AC_PATH_XTRA
diff --git a/dev-games/KXL/files/KXL-1.1.7-m4.patch b/dev-games/KXL/files/KXL-1.1.7-m4.patch
new file mode 100644
index 000000000000..f039974e6f98
--- /dev/null
+++ b/dev-games/KXL/files/KXL-1.1.7-m4.patch
@@ -0,0 +1,9 @@
+Get rid of aclocal warning:
+/usr/share/aclocal/KXL.m4:6: warning: underquoted definition of AM_PATH_KXL
+--- KXL-1.1.7/KXL.m4
++++ KXL-1.1.7/KXL.m4
+@@ -5,3 +5,3 @@
+ dnl
+-AC_DEFUN(AM_PATH_KXL,
++AC_DEFUN([AM_PATH_KXL],
+ [dnl
diff --git a/dev-games/KXL/metadata.xml b/dev-games/KXL/metadata.xml
new file mode 100644
index 000000000000..d5af03e3e537
--- /dev/null
+++ b/dev-games/KXL/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<longdescription>
+KXL is the library developed for the purpose of the ability to develop a
+game easily on X Window System of Linux.
+
+KXL is the composition of the window of one sheet, and the frame buffer
+of one sheet.
+
+KXL corresponds to reading of a bitmap picture, and offers a still
+simple drawing function and a wave sound function.
+
+KXL is written only using xlib.
+
+KXL is written by the C language.
+</longdescription>
+</pkgmetadata>