summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-games/aseprite/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-games/aseprite/files')
-rw-r--r--dev-games/aseprite/files/aseprite-0.9.5-as-needed.patch38
-rw-r--r--dev-games/aseprite/files/aseprite-0.9.5-underlinking.patch21
-rw-r--r--dev-games/aseprite/files/aseprite-1.0.6-obinary.patch27
-rw-r--r--dev-games/aseprite/files/aseprite-1.0.6-png_sizeof.patch11
4 files changed, 97 insertions, 0 deletions
diff --git a/dev-games/aseprite/files/aseprite-0.9.5-as-needed.patch b/dev-games/aseprite/files/aseprite-0.9.5-as-needed.patch
new file mode 100644
index 000000000000..9f50c25979ba
--- /dev/null
+++ b/dev-games/aseprite/files/aseprite-0.9.5-as-needed.patch
@@ -0,0 +1,38 @@
+Description: fix FTBFS with --as-needed linker option
+ Libraries must be placed after object files in command line.
+Author: Ilya Barygin <randomaction@ubuntu.com>
+
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -135,6 +135,10 @@
+ # All libraries for .exe files
+ set(all_libs ${aseprite_libraries} ${libs3rdparty} ${sys_libs})
+
++if(LIBALLEGRO4_LINK_FLAGS)
++ set(all_libs ${all_libs} ${LIBALLEGRO4_LINK_FLAGS})
++endif()
++
+ ######################################################################
+ # ASEPRITE libraries
+
+@@ -405,10 +409,6 @@
+
+ add_executable(aseprite WIN32 main.cpp ${win32_resources} ${x11_resources})
+ target_link_libraries(aseprite ${all_libs})
+-if(LIBALLEGRO4_LINK_FLAGS)
+- set_target_properties(aseprite
+- PROPERTIES LINK_FLAGS ${LIBALLEGRO4_LINK_FLAGS})
+-endif()
+
+ install(TARGETS aseprite
+ RUNTIME DESTINATION bin)
+@@ -450,8 +450,7 @@
+ endif()
+
+ if(LIBALLEGRO4_LINK_FLAGS)
+- set_target_properties(${testname}
+- PROPERTIES LINK_FLAGS ${LIBALLEGRO4_LINK_FLAGS})
++ target_link_libraries(${testname} ${LIBALLEGRO4_LINK_FLAGS})
+ endif()
+
+ if(extra_definitions)
diff --git a/dev-games/aseprite/files/aseprite-0.9.5-underlinking.patch b/dev-games/aseprite/files/aseprite-0.9.5-underlinking.patch
new file mode 100644
index 000000000000..8f3027d4baf7
--- /dev/null
+++ b/dev-games/aseprite/files/aseprite-0.9.5-underlinking.patch
@@ -0,0 +1,21 @@
+From 169edeaa69cce2670213c39232a249a487670883 Mon Sep 17 00:00:00 2001
+From: hasufell <hasufell@hasufell.de>
+Date: Sun, 2 Nov 2014 16:58:33 +0100
+Subject: [PATCH] Fix underlinking with USE_SHARED_ALLEGRO4=ON
+
+---
+ src/CMakeLists.txt | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 21c3352..0ce11d2 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -58,6 +58,7 @@ if(USE_SHARED_ALLEGRO4)
+ OUTPUT_VARIABLE LIBALLEGRO4_LINK_FLAGS
+ OUTPUT_STRIP_TRAILING_WHITESPACE)
+
++ set(LIBALLEGRO4_LINK_FLAGS ${LIBALLEGRO4_LINK_FLAGS} ${PLATFORM_LIBS})
+ include_directories(${LIBALLEGRO4_INCLUDE_DIR})
+ else()
+ add_definitions(-DALLEGRO4_WITH_RESIZE_PATCH)
diff --git a/dev-games/aseprite/files/aseprite-1.0.6-obinary.patch b/dev-games/aseprite/files/aseprite-1.0.6-obinary.patch
new file mode 100644
index 000000000000..4536fc53a217
--- /dev/null
+++ b/dev-games/aseprite/files/aseprite-1.0.6-obinary.patch
@@ -0,0 +1,27 @@
+From 9997ad9fcbb0dcef16e4e8224e4238ecdfe56b66 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Matthias=20Mail=C3=A4nder?=
+ <Mailaender@users.noreply.github.com>
+Date: Sun, 28 Sep 2014 06:38:18 +0200
+Subject: [PATCH] always declare O_BINARY
+
+closes #461
+---
+ src/base/file_handle.cpp | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/src/base/file_handle.cpp b/src/base/file_handle.cpp
+index 0ba214e..f336513 100644
+--- a/src/base/file_handle.cpp
++++ b/src/base/file_handle.cpp
+@@ -21,6 +21,11 @@
+ #include <fcntl.h>
+ #endif
+
++#ifndef O_BINARY
++#define O_BINARY 0
++#define O_TEXT 0
++#endif
++
+ using namespace std;
+
+ namespace base {
diff --git a/dev-games/aseprite/files/aseprite-1.0.6-png_sizeof.patch b/dev-games/aseprite/files/aseprite-1.0.6-png_sizeof.patch
new file mode 100644
index 000000000000..02fa48006646
--- /dev/null
+++ b/dev-games/aseprite/files/aseprite-1.0.6-png_sizeof.patch
@@ -0,0 +1,11 @@
+--- src/app/file/png_format.cpp
++++ src/app/file/png_format.cpp
+@@ -413,7 +413,7 @@
+ #endif
+
+ // Save the color palette.
+- palette = (png_colorp)png_malloc(png_ptr, PNG_MAX_PALETTE_LENGTH * png_sizeof(png_color));
++ palette = (png_colorp)png_malloc(png_ptr, PNG_MAX_PALETTE_LENGTH * sizeof(png_color));
+ for (c = 0; c < PNG_MAX_PALETTE_LENGTH; c++) {
+ fop_sequence_get_color(fop, c, &r, &g, &b);
+ palette[c].red = r;