summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-games/clanlib
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-games/clanlib')
-rw-r--r--dev-games/clanlib/Manifest2
-rw-r--r--dev-games/clanlib/clanlib-0.8.1.ebuild77
-rw-r--r--dev-games/clanlib/clanlib-2.3.7.ebuild98
-rw-r--r--dev-games/clanlib/files/clanlib-0.8.1-gcc43.patch28
-rw-r--r--dev-games/clanlib/files/clanlib-0.8.1-gcc44.patch33
-rw-r--r--dev-games/clanlib/files/clanlib-0.8.1-gcc47.patch10
-rw-r--r--dev-games/clanlib/files/clanlib-0.8.1-libpng15.patch11
-rw-r--r--dev-games/clanlib/files/clanlib-0.8.1-ndebug.patch21
-rw-r--r--dev-games/clanlib/files/clanlib-2.3.7-autotools.patch45
-rw-r--r--dev-games/clanlib/files/clanlib-2.3.7-doc.patch14
-rw-r--r--dev-games/clanlib/metadata.xml55
11 files changed, 394 insertions, 0 deletions
diff --git a/dev-games/clanlib/Manifest b/dev-games/clanlib/Manifest
new file mode 100644
index 000000000000..4fda43feeb23
--- /dev/null
+++ b/dev-games/clanlib/Manifest
@@ -0,0 +1,2 @@
+DIST ClanLib-0.8.1.tgz 7629019 SHA256 094331dda35b0d263431d1551991eb208d8e969824434925548a9fcd1d34e495 SHA512 277daaf1055ae0198be7a6bbfd415c79cfae9e2145f62553e83849d670f56e50b8484c83f8b85f23290002e0b0c72c1e01ca597ad608a0954a4add828177293b WHIRLPOOL be486125f406a307676c4957f977b6ccc6bc2ce527a72fb4febcb3d1c7e2acdc4fc6706b66b75412184c3a0744c53e962011b0c3ac22958da5e987f0fccc9d87
+DIST ClanLib-2.3.7.tgz 26132425 SHA256 d46127c08103f48d15936ceb9f95b3dfb1ff8ccba667cef1b3f8e639cb2601c2 SHA512 73169afc0f639390f80403150757a8a14f842bc291a9457c9bca1319642b78bc4d03a93327d75254230e39545c5b4b690e56dc0149ed7b60b223e5a5364e882a WHIRLPOOL a6547d0bc8d254e887c427dfff63deb2b69790124da3db49d54cf853f8c834d44172a06e92ef7fc5222c8c81f903ab29f186f85da698dc085f4138d147ddad68
diff --git a/dev-games/clanlib/clanlib-0.8.1.ebuild b/dev-games/clanlib/clanlib-0.8.1.ebuild
new file mode 100644
index 000000000000..ac7688f2f6db
--- /dev/null
+++ b/dev-games/clanlib/clanlib-0.8.1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit flag-o-matic eutils
+
+DESCRIPTION="multi-platform game development library"
+HOMEPAGE="http://www.clanlib.org/"
+SRC_URI="http://clanlib.org/download/releases-${PV:0:3}/ClanLib-${PV}.tgz"
+
+LICENSE="ZLIB"
+SLOT="0.8"
+KEYWORDS="amd64 x86" #not big endian safe #82779
+IUSE="doc ipv6 mikmod opengl sdl static-libs vorbis"
+
+# opengl keyword does not drop the GL/GLU requirement.
+# Autoconf files need to be fixed
+RDEPEND="media-libs/libpng
+ virtual/jpeg
+ virtual/glu
+ virtual/opengl
+ sdl? (
+ media-libs/libsdl
+ media-libs/sdl-gfx
+ )
+ x11-libs/libXi
+ x11-libs/libXmu
+ x11-libs/libXxf86vm
+ media-libs/alsa-lib
+ mikmod? ( media-libs/libmikmod )
+ vorbis? ( media-libs/libvorbis )"
+DEPEND="${RDEPEND}
+ x11-proto/xf86vidmodeproto"
+
+S=${WORKDIR}/ClanLib-${PV}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-ndebug.patch \
+ "${FILESDIR}"/${P}-gcc43.patch \
+ "${FILESDIR}"/${P}-gcc44.patch \
+ "${FILESDIR}"/${P}-gcc47.patch \
+ "${FILESDIR}"/${P}-libpng15.patch
+}
+
+src_configure() {
+ #clanSound only controls mikmod/vorbis so there's
+ # no need to pass --{en,dis}able-clanSound ...
+ #clanDisplay only controls X, SDL, OpenGL plugins
+ # so no need to pass --{en,dis}able-clanDisplay
+ # also same reason why we don't have to use clanGUI
+ econf \
+ --enable-dyn \
+ --enable-clanNetwork \
+ --disable-dependency-tracking \
+ $(use_enable x86 asm386) \
+ $(use_enable doc docs) \
+ $(use_enable opengl clanGL) \
+ $(use_enable sdl clanSDL) \
+ $(use_enable vorbis clanVorbis) \
+ $(use_enable mikmod clanMikMod) \
+ $(use_enable ipv6 getaddr) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ DOCS="CODING_STYLE CREDITS NEWS PATCHES README* INSTALL.linux" \
+ default
+ if use doc ; then
+ dodir /usr/share/doc/${PF}/html
+ mv "${D}"/usr/share/doc/clanlib/* "${D}"/usr/share/doc/${PF}/html/ || die
+ rm -rf "${D}"/usr/share/doc/clanlib
+ cp -r Examples Resources "${D}"/usr/share/doc/${PF}/ || die
+ fi
+ prune_libtool_files
+}
diff --git a/dev-games/clanlib/clanlib-2.3.7.ebuild b/dev-games/clanlib/clanlib-2.3.7.ebuild
new file mode 100644
index 000000000000..9d108de0d902
--- /dev/null
+++ b/dev-games/clanlib/clanlib-2.3.7.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit flag-o-matic eutils autotools-utils
+
+MY_P=ClanLib-${PV}
+
+DESCRIPTION="multi-platform game development library"
+HOMEPAGE="http://www.clanlib.org/"
+SRC_URI="http://clanlib.org/download/releases-2.0/${MY_P}.tgz"
+
+LICENSE="ZLIB"
+SLOT="2.3"
+KEYWORDS="amd64 x86" #not big endian safe #82779
+IUSE="doc ipv6 mikmod opengl sound sqlite cpu_flags_x86_sse2 static-libs vorbis X"
+REQUIRED_USE="opengl? ( X )"
+
+RDEPEND="sys-libs/zlib
+ X? (
+ media-libs/libpng
+ virtual/jpeg
+ media-libs/freetype
+ media-libs/fontconfig
+ opengl? ( virtual/opengl )
+ app-arch/bzip2
+ x11-libs/libX11
+ )
+ sqlite? ( dev-db/sqlite )
+ sound? ( media-libs/alsa-lib )
+ mikmod? (
+ media-libs/libmikmod
+ media-libs/alsa-lib
+ )
+ vorbis? (
+ media-libs/libogg
+ media-libs/libvorbis
+ media-libs/alsa-lib
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen dev-lang/perl )"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-autotools.patch
+ "${FILESDIR}"/${P}-doc.patch
+)
+AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_IN_SOURCE_BUILD=1
+DOCS=(
+ CODING_STYLE
+ CREDITS
+ PATCHES
+ README
+)
+
+src_prepare() {
+ autotools-utils_src_prepare
+ ln -sf ../../../Sources/API Documentation/Utilities/ReferenceDocs/ClanLib
+}
+
+src_configure() {
+ myeconfargs=(
+ $(use_enable doc docs)
+ $(use_enable cpu_flags_x86_sse2 sse2)
+ $(use_enable opengl clanGL)
+ $(use_enable opengl clanGL1)
+ $(use_enable opengl clanGUI)
+ $(use_enable X clanDisplay)
+ $(use_enable vorbis clanVorbis)
+ $(use_enable mikmod clanMikMod)
+ $(use_enable sqlite clanSqlite)
+ $(use_enable ipv6 getaddr)
+ )
+ use sound \
+ || use vorbis \
+ || use mikmod \
+ || myeconfargs+=( --disable-clanSound )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile
+ use doc && autotools-utils_src_compile html
+}
+
+# html files are keeped in a directory that is dependent on the SLOT
+# so to keep eventual bookmarks to the doc from version to version
+src_install() {
+ autotools-utils_src_install
+ if use doc ; then
+ emake DESTDIR="${D}" install-html
+ dodoc -r Examples Resources
+ fi
+}
diff --git a/dev-games/clanlib/files/clanlib-0.8.1-gcc43.patch b/dev-games/clanlib/files/clanlib-0.8.1-gcc43.patch
new file mode 100644
index 000000000000..ca1d898ce5ab
--- /dev/null
+++ b/dev-games/clanlib/files/clanlib-0.8.1-gcc43.patch
@@ -0,0 +1,28 @@
+--- Sources/GL/opengl.cpp
++++ Sources/GL/opengl.cpp
+@@ -51,6 +51,8 @@
+ #endif
+ #endif
+
++#include <cstring>
++
+ std::vector<std::string> CL_OpenGL::m_ignored_gl_extension;
+
+ CL_ProcAddress *CL_OpenGL::get_proc_address(const std::string& function_name)
+@@ -414,4 +416,4 @@
+ #endif
+
+ m_ignored_gl_extension.push_back(extension_name);
+-}
+\ No newline at end of file
++}
+--- Sources/Network/Socket/ip_address_getsock.cpp
++++ Sources/Network/Socket/ip_address_getsock.cpp
+@@ -40,6 +40,7 @@
+ #include "ip_address_getsock.h"
+
+ #include <cstdlib>
++#include <cstring>
+
+ #ifndef WIN32
+ #include <sys/socket.h>
diff --git a/dev-games/clanlib/files/clanlib-0.8.1-gcc44.patch b/dev-games/clanlib/files/clanlib-0.8.1-gcc44.patch
new file mode 100644
index 000000000000..ddf5a170b027
--- /dev/null
+++ b/dev-games/clanlib/files/clanlib-0.8.1-gcc44.patch
@@ -0,0 +1,33 @@
+diff -Naur ClanLib-0.8.1-old/Sources/GL/canvas_opengl.cpp ClanLib-0.8.1/Sources/GL/canvas_opengl.cpp
+--- ClanLib-0.8.1-old/Sources/GL/canvas_opengl.cpp 2009-08-01 18:15:44.000000000 +0200
++++ ClanLib-0.8.1/Sources/GL/canvas_opengl.cpp 2009-08-01 18:08:55.000000000 +0200
+@@ -48,6 +48,7 @@
+ #include "graphic_context_opengl.h"
+ #include "surface_target_opengl.h"
+ #include <cstring>
++#include <cstdio>
+
+ /////////////////////////////////////////////////////////////////////////////
+ // CL_Canvas_OpenGL construction:
+diff -Naur ClanLib-0.8.1-old/Sources/GL/GLX/input_device_linuxevent.cpp ClanLib-0.8.1/Sources/GL/GLX/input_device_linuxevent.cpp
+--- ClanLib-0.8.1-old/Sources/GL/GLX/input_device_linuxevent.cpp 2009-08-01 18:17:25.000000000 +0200
++++ ClanLib-0.8.1/Sources/GL/GLX/input_device_linuxevent.cpp 2009-08-01 18:11:23.000000000 +0200
+@@ -35,6 +35,7 @@
+ #include <iostream>
+ #include <errno.h>
+ #include <cstring>
++#include <cstdio>
+
+ #include "API/Core/System/error.h"
+ #include "API/Core/System/clanstring.h"
+diff -Naur ClanLib-0.8.1-old/Sources/GL/GLX/input_device_xinput.cpp ClanLib-0.8.1/Sources/GL/GLX/input_device_xinput.cpp
+--- ClanLib-0.8.1-old/Sources/GL/GLX/input_device_xinput.cpp 2009-08-01 18:17:41.000000000 +0200
++++ ClanLib-0.8.1/Sources/GL/GLX/input_device_xinput.cpp 2009-08-01 18:12:56.000000000 +0200
+@@ -29,6 +29,7 @@
+
+ #include <iostream>
+ #include <cstring>
++#include <cstdio>
+ #include "API/Core/System/log.h"
+ #include "API/Display/input_device.h"
+ #include "API/Display/input_event.h"
diff --git a/dev-games/clanlib/files/clanlib-0.8.1-gcc47.patch b/dev-games/clanlib/files/clanlib-0.8.1-gcc47.patch
new file mode 100644
index 000000000000..19ebab6fd07d
--- /dev/null
+++ b/dev-games/clanlib/files/clanlib-0.8.1-gcc47.patch
@@ -0,0 +1,10 @@
+--- ./Sources/Core/IOData/Generic/inputsource_file.cpp.orig 2012-12-30 01:49:01.698950614 +0400
++++ ./Sources/Core/IOData/Generic/inputsource_file.cpp 2012-12-30 01:49:27.714977456 +0400
+@@ -32,6 +32,7 @@
+ #ifdef WIN32
+ #include <direct.h>
+ #endif
++#include <unistd.h>
+ #include <cstring>
+ #include <API/Core/IOData/inputsource_file.h>
+
diff --git a/dev-games/clanlib/files/clanlib-0.8.1-libpng15.patch b/dev-games/clanlib/files/clanlib-0.8.1-libpng15.patch
new file mode 100644
index 000000000000..03d0ba536acf
--- /dev/null
+++ b/dev-games/clanlib/files/clanlib-0.8.1-libpng15.patch
@@ -0,0 +1,11 @@
+--- Sources/Display/Providers/png_provider_generic.cpp
++++ Sources/Display/Providers/png_provider_generic.cpp
+@@ -107,7 +107,7 @@
+ png_destroy_read_struct(&png_ptr, &info_ptr, (png_infopp) NULL);
+ cl_assert(false);
+ }
+- if (setjmp(png_ptr->jmpbuf))
++ if (setjmp(png_jmpbuf(png_ptr)))
+ {
+ png_destroy_read_struct(&png_ptr, &info_ptr, &end_info);
+ cl_assert(false);
diff --git a/dev-games/clanlib/files/clanlib-0.8.1-ndebug.patch b/dev-games/clanlib/files/clanlib-0.8.1-ndebug.patch
new file mode 100644
index 000000000000..e41bae1a3296
--- /dev/null
+++ b/dev-games/clanlib/files/clanlib-0.8.1-ndebug.patch
@@ -0,0 +1,21 @@
+Patch for clanlib-0.7.8-r2 Bug 154513:
+
+Signal handler deinit() was not declared.
+
+This leads to a compilation failure when a release version
+rather than a debug version is built (-DNDEBUG).
+
+This patch adds the missing declaration, thus make the
+file compile with or without -DNDEBUG.
+
+diff -Naur clanlib-0.7.8-r2.orig/work/ClanLib-0.7.8/Sources/Core/System/Unix/init_linux.cpp clanlib-0.7.8-r2/work/ClanLib-0.7.8/Sources/Core/System/Unix/init_linux.cpp
+--- clanlib-0.7.8-r2.orig/work/ClanLib-0.7.8/Sources/Core/System/Unix/init_linux.cpp 2003-09-19 10:33:02.000000000 +0000
++++ clanlib-0.7.8-r2/work/ClanLib-0.7.8/Sources/Core/System/Unix/init_linux.cpp 2007-10-26 13:36:39.000000000 +0000
+@@ -52,6 +52,7 @@
+ _begin_time = (long) tv.tv_sec*(long) 1000+(long) tv.tv_usec/(long) 1000;
+
+ #ifdef NDEBUG
++ sighandler_t deinit;
+ signal(SIGSEGV, deinit);
+ #endif
+ }
diff --git a/dev-games/clanlib/files/clanlib-2.3.7-autotools.patch b/dev-games/clanlib/files/clanlib-2.3.7-autotools.patch
new file mode 100644
index 000000000000..97db79ac4245
--- /dev/null
+++ b/dev-games/clanlib/files/clanlib-2.3.7-autotools.patch
@@ -0,0 +1,45 @@
+--- Documentation/Reference/Makefile.am.old 2012-09-25 10:39:25.973544935 +0200
++++ Documentation/Reference/Makefile.am 2012-09-25 10:39:42.560554053 +0200
+@@ -10,7 +10,7 @@
+ mkdir doxyoutput;
+ mkdir reftest
+ doxygen ./clanlib.doxygen
+- make -C ../Utilities/ReferenceDocs
++ $(MAKE) -C ../Utilities/ReferenceDocs
+ ../Utilities/ReferenceDocs/ReferenceDocs
+
+ install-html:
+--- configure.ac.old 2012-09-25 11:07:38.412537590 +0200
++++ configure.ac 2012-09-25 11:09:41.133939131 +0200
+@@ -337,11 +337,9 @@
+
+ dnl Optional linux/joystick.h
+ AC_CHECK_HEADERS(linux/joystick.h, linux_joystick=yes)
+- AM_CONDITIONAL(LINUX_JOYSTICK, test x$linux_joystick = xyes)
+
+ dnl Optional linux/input.h
+ AC_CHECK_HEADERS(linux/input.h, linux_input=yes)
+- AM_CONDITIONAL(LINUX_INPUT, test x$linux_input = xyes)
+
+ if test "$WIN32" = "no" && test "$enable_clanDisplay" != "no"; then
+ CLANLIB_CHECK_LIB(fontconfig, [`cat $srcdir/Setup/Tests/fontconfig.cpp`], clanDisplay, [ *** Cannot find fontconfig (See http://fontconfig.org/ ) (Try libfontconfig1-dev or better) ], [-lfontconfig])
+@@ -358,6 +356,8 @@
+ clanDisplay, [ *** Cannot find version 8 of DirectInput], [-ldxguid -lole32 -ldinput8])
+ fi
+ fi
++AM_CONDITIONAL(LINUX_JOYSTICK, test x$linux_joystick = xyes)
++AM_CONDITIONAL(LINUX_INPUT, test x$linux_input = xyes)
+
+ have_xrender=no
+
+@@ -515,9 +515,9 @@
+ fi
+
+ if test "$enable_clanSound" = "auto"; then enable_clanSound=yes; fi
+- AM_CONDITIONAL(ALSA, test x$have_alsa = xyes)
+
+ fi
++AM_CONDITIONAL(ALSA, test x$have_alsa = xyes)
+
+ if test "$enable_clanSound" != "no"; then
+ enable_clanSound=yes
diff --git a/dev-games/clanlib/files/clanlib-2.3.7-doc.patch b/dev-games/clanlib/files/clanlib-2.3.7-doc.patch
new file mode 100644
index 000000000000..627df26785b4
--- /dev/null
+++ b/dev-games/clanlib/files/clanlib-2.3.7-doc.patch
@@ -0,0 +1,14 @@
+--- Documentation/Utilities/ReferenceDocs/Makefile.old 2014-09-12 20:06:52.970459560 +0200
++++ Documentation/Utilities/ReferenceDocs/Makefile 2014-09-12 20:08:17.387048685 +0200
+@@ -3,7 +3,10 @@
+ LIBS=clanCore
+ EXTRA_LIBS=-lpthread
+
+-include ../../../Examples/Makefile.conf
++CXXFLAGS += -pthread -std=c++0x -I.
++all: $(EXAMPLE_BIN)
++$(EXAMPLE_BIN): $(OBJF)
++ $(CXX) $(CXXFLAGS) $(OBJF) -o $(EXAMPLE_BIN) -Wl,-R../../Sources/Core/.libs -L../../../Sources/Core/.libs -lclan23Core $(EXTRA_LIBS)
+
+ # EOF #
+
diff --git a/dev-games/clanlib/metadata.xml b/dev-games/clanlib/metadata.xml
new file mode 100644
index 000000000000..741984228bd1
--- /dev/null
+++ b/dev-games/clanlib/metadata.xml
@@ -0,0 +1,55 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<longdescription>
+Welcome to ClanLib, a multi-platform game development library.
+
+ClanLib is a medium level development kit. At its lowest level, it provides a
+platform independent (as much as that is possible in C++) way of dealing with
+display, sound, input, networking, files, threadding and such.
+
+On top of that, ClanLib builds a generic game development framework, giving you
+easy handling of resources, network object replication, graphical user
+interfaces (GUI) with theme support, game scripting and more.
+
+The goal of ClanLib is to allow the game developer to focus on stuff that
+matters, avoiding all those nasty (and boring) lowlevel trivials like setting up
+a directdraw window, sound mixing, reading image files, etc. All those things
+are simplified into object oriented classes and function calls, making it a joy
+to write your game.
+
+ClanLib uses a resource system to keep track of images, fonts, samples and
+music. It supports Targa, PCX, JPEG, PNG and BMP for images. Wave files for
+sample. Ogg Vorbis (open sound format that has same sound quality as mp3) and
+MikMod for music. By using a resource system, you cleanly seperate the physical
+data formats from your code, and makes it easy to make themes and other plugins
+for your game. The resource system is written in a manner that allows you to add
+your own custom resources.
+
+All classes in clanlib focus on making simple interfaces that are customizeable
+and expandable. This keeps your game code clean and simple; but still allows you
+to do advanced stuff. As an example, look at some sound code:
+CL_SoundBuffer my_sample("Weapon/Minigun/sound", resources);
+my_sample.play();
+
+In this example, we play a simple sound effect, and afterwards forget all about
+it. Nice and simple. But if we want to adjust the frequency during its playback
+(eg. for a dobbler effect), it could look like this:
+CL_SoundBuffer_Session playback = my_sample.play();
+playback.set_frequency(1.2f); // increase frequency by 20%
+
+We only need to keep the session handle if we are going to use it. Keep things
+simple when they are simple, and make them complex when they are complex. :)
+
+The object oriented nature of ClanLib allows you to operate both at high and low
+levels, minimizing redundant code and still allows you to do stuff that isnt
+supported by clanlib's high level APIs.
+
+ClanLib currently support Windows 98, Windows 2000, Windows XP and Linux. The
+following display targets are supported under linux: X11 and OpenGL. Some parts
+of ClanLib still isnt entirely endian clean, so it will currently only work
+without problems on the x86 architecture. Work is underway for a MacOS port.
+Current compilers supported is VC++ 6.0, VC++ 7.0, GCC, Borland and MingW.
+</longdescription>
+</pkgmetadata>