summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-games/ode/ode-0.12.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-games/ode/ode-0.12.ebuild')
-rw-r--r--dev-games/ode/ode-0.12.ebuild73
1 files changed, 73 insertions, 0 deletions
diff --git a/dev-games/ode/ode-0.12.ebuild b/dev-games/ode/ode-0.12.ebuild
new file mode 100644
index 000000000000..cecc087f4725
--- /dev/null
+++ b/dev-games/ode/ode-0.12.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="Open Dynamics Engine SDK"
+HOMEPAGE="http://ode.org/"
+SRC_URI="mirror://sourceforge/opende/${P}.tar.bz2"
+
+LICENSE="|| ( LGPL-2.1 BSD )"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="debug doc double-precision examples gyroscopic static-libs"
+
+RDEPEND="examples? (
+ virtual/opengl
+ )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ sed -i \
+ -e "s:\$.*/drawstuff/textures:/usr/share/doc/${PF}/examples:" \
+ drawstuff/src/Makefile.in \
+ ode/demo/Makefile.in || die
+}
+
+src_configure() {
+ # use bash (bug #335760)
+ CONFIG_SHELL=/bin/bash \
+ econf \
+ --enable-shared \
+ $(use_enable static-libs static) \
+ $(use_enable debug asserts) \
+ $(use_enable double-precision) \
+ $(use_enable examples demos) \
+ $(use_enable gyroscopic) \
+ $(use_with examples drawstuff X11)
+}
+
+src_compile() {
+ emake
+ if use doc ; then
+ cd ode/doc
+ doxygen Doxyfile || die
+ fi
+}
+
+src_install() {
+ DOCS="CHANGELOG.txt README.txt" \
+ default
+ prune_libtool_files
+ if use doc ; then
+ dohtml docs/*
+ fi
+ if use examples; then
+ cd ode/demo
+ exeinto /usr/share/doc/${PF}/examples
+ local f
+ for f in *.c* ; do
+ doexe .libs/${f%.*}
+ done
+ cd ../..
+ doexe drawstuff/dstest/dstest
+ insinto /usr/share/doc/${PF}/examples
+ doins ode/demo/*.{c,cpp,h} \
+ drawstuff/textures/*.ppm \
+ drawstuff/dstest/dstest.cpp \
+ drawstuff/src/{drawstuff.cpp,internal.h,x11.cpp}
+ fi
+}