summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMykyta Holubakha <hilobakho@gmail.com>2017-04-24 02:44:08 +0300
committerMaciej Mrozowski <reavertm@gentoo.org>2017-05-18 05:05:32 +0200
commit22f9cf4bf967ae1c680b60dd20b4e721b79c988a (patch)
treef955c25b105f66fad6ad1c3f9550ed05ee2ef77d /dev-games/openscenegraph-qt/openscenegraph-qt-3.5.5.ebuild
parentdev-games/openscenegraph: Remove old (diff)
downloadgentoo-22f9cf4bf967ae1c680b60dd20b4e721b79c988a.tar.gz
gentoo-22f9cf4bf967ae1c680b60dd20b4e721b79c988a.tar.bz2
gentoo-22f9cf4bf967ae1c680b60dd20b4e721b79c988a.zip
dev-games/openscenegraph: version bump to 3.5.5, masked
dev-games/openscenegraph-qt: new package (Qt support split off osg in a separate package), masked Closes: https://github.com/gentoo/gentoo/pull/4485
Diffstat (limited to 'dev-games/openscenegraph-qt/openscenegraph-qt-3.5.5.ebuild')
-rw-r--r--dev-games/openscenegraph-qt/openscenegraph-qt-3.5.5.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-games/openscenegraph-qt/openscenegraph-qt-3.5.5.ebuild b/dev-games/openscenegraph-qt/openscenegraph-qt-3.5.5.ebuild
new file mode 100644
index 000000000000..b0d18aaf7f45
--- /dev/null
+++ b/dev-games/openscenegraph-qt/openscenegraph-qt-3.5.5.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="osgQt"
+MY_P=${MY_PN}-${PV}
+
+inherit cmake-utils
+DESCRIPTION="Qt support for OpenSceneGraph"
+HOMEPAGE="http://www.openscenegraph.org/"
+SRC_URI="https://github.com/openscenegraph/${MY_PN}/archive/${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="wxWinLL-3 LGPL-2.1"
+SLOT="0/145" # NOTE: CHECK WHEN BUMPING! Subslot is SOVERSION
+KEYWORDS="~amd64 ~hppa ~ppc64 ~x86"
+IUSE="debug examples"
+
+RDEPEND="
+ dev-games/openscenegraph:${SLOT}
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtopengl:5
+ dev-qt/qtwebkit:5
+ examples? ( dev-qt/qtwidgets:5 )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.5.5-cmake.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DDYNAMIC_OPENSCENEGRAPH=ON
+ -DDESIRED_QT_VERSION=5
+ -DBUILD_OSG_EXAMPLES=$(usex examples)
+ )
+
+ cmake-utils_src_configure
+}