summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-11-06 14:40:10 +0100
committerLars Wendler <polynomial-c@gentoo.org>2017-11-06 16:29:07 +0100
commitd088afe598420e5f7cb964af3cd94c9aa7fbe70b (patch)
tree221521a32f185c1851bf9c2b4f7630d4174cf5fa /dev-games/physfs/physfs-3.0.1.ebuild
parentsys-apps/paludis: Bump to a fresh snapshot (diff)
downloadgentoo-d088afe598420e5f7cb964af3cd94c9aa7fbe70b.tar.gz
gentoo-d088afe598420e5f7cb964af3cd94c9aa7fbe70b.tar.bz2
gentoo-d088afe598420e5f7cb964af3cd94c9aa7fbe70b.zip
dev-games/physfs: Bump to version 3.0.1
Package-Manager: Portage-2.3.13, Repoman-2.3.4
Diffstat (limited to 'dev-games/physfs/physfs-3.0.1.ebuild')
-rw-r--r--dev-games/physfs/physfs-3.0.1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-games/physfs/physfs-3.0.1.ebuild b/dev-games/physfs/physfs-3.0.1.ebuild
new file mode 100644
index 000000000000..4b0afd2bd59b
--- /dev/null
+++ b/dev-games/physfs/physfs-3.0.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit cmake-multilib
+
+DESCRIPTION="Abstraction layer for filesystem and archive access"
+HOMEPAGE="http://icculus.org/physfs/"
+SRC_URI="http://icculus.org/physfs/downloads/${P}.tar.bz2"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc64 ~x86 ~x86-fbsd"
+IUSE="grp hog mvl qpak static-libs wad +zip"
+
+RDEPEND=""
+DEPEND=""
+
+DOCS=( docs/CHANGELOG.txt docs/CREDITS.txt docs/TODO.txt )
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ sed -i -e 's:-Werror::' CMakeLists.txt || die
+ # make sure these libs aren't used
+ rm -rf lzma zlib*
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DPHYSFS_ARCHIVE_7Z=OFF
+ -DPHYSFS_BUILD_SHARED=ON
+ -DPHYSFS_BUILD_TEST=OFF
+ -DPHYSFS_BUILD_WX_TEST=OFF
+ -DPHYSFS_INTERNAL_ZLIB=OFF
+ -DPHYSFS_BUILD_STATIC="$(usex static-libs)"
+ -DPHYSFS_ARCHIVE_GRP="$(usex grp)"
+ -DPHYSFS_ARCHIVE_HOG="$(usex hog)"
+ -DPHYSFS_ARCHIVE_MVL="$(usex mvl)"
+ -DPHYSFS_ARCHIVE_WAD="$(usex wad)"
+ -DPHYSFS_ARCHIVE_QPAK="$(usex qpak)"
+ -DPHYSFS_ARCHIVE_ZIP="$(usex zip)"
+ )
+
+ cmake-multilib_src_configure
+}