summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Mrozowski <reavertm@gentoo.org>2016-05-28 02:50:15 +0200
committerMaciej Mrozowski <reavertm@gentoo.org>2016-05-28 02:51:56 +0200
commit8ab62f779ba52e3ccafdb38ce55303da14d70beb (patch)
treea6a514fb964fddf4cf40753e0703a508d1611e20 /dev-games/simgear/simgear-2016.2.1.ebuild
parentapp-text/tkinfo: EAPI 6 bump. (diff)
downloadgentoo-8ab62f779ba52e3ccafdb38ce55303da14d70beb.tar.gz
gentoo-8ab62f779ba52e3ccafdb38ce55303da14d70beb.tar.bz2
gentoo-8ab62f779ba52e3ccafdb38ce55303da14d70beb.zip
games-simulation/flightgear: Version bump 2016.2.1, bug 584302.
Diffstat (limited to 'dev-games/simgear/simgear-2016.2.1.ebuild')
-rw-r--r--dev-games/simgear/simgear-2016.2.1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-games/simgear/simgear-2016.2.1.ebuild b/dev-games/simgear/simgear-2016.2.1.ebuild
new file mode 100644
index 000000000000..91045754dc27
--- /dev/null
+++ b/dev-games/simgear/simgear-2016.2.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils cmake-utils
+
+DESCRIPTION="Development library for simulation games"
+HOMEPAGE="http://www.simgear.org/"
+SRC_URI="mirror://sourceforge/flightgear/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+SLOT="0"
+IUSE="+dns debug subversion test"
+
+COMMON_DEPEND="
+ dev-libs/expat
+ >=dev-games/openscenegraph-3.2.0
+ media-libs/openal
+ net-misc/curl
+ sys-libs/zlib
+ virtual/opengl
+ dns? ( net-libs/udns )
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-libs/boost-1.44
+"
+RDEPEND="${COMMON_DEPEND}
+ subversion? ( dev-vcs/subversion )
+"
+
+PATCHES=(
+ "${FILESDIR}/simgear-2016.2.1-unbundle-udns.patch"
+)
+
+DOCS=(AUTHORS ChangeLog NEWS README Thanks)
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_DNS=$(usex dns)
+ -DENABLE_PKGUTIL=ON
+ -DENABLE_RTI=OFF
+ -DENABLE_SOUND=ON
+ -DENABLE_TESTS=$(usex test)
+ -DSIMGEAR_HEADLESS=OFF
+ -DSIMGEAR_SHARED=ON
+ -DSYSTEM_EXPAT=ON
+ -DSYSTEM_UDNS=ON
+ )
+ cmake-utils_src_configure
+}