summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Mrozowski <reavertm@gentoo.org>2017-03-06 00:20:17 +0100
committerMaciej Mrozowski <reavertm@gentoo.org>2017-03-06 00:24:30 +0100
commitd647eba30bef1720b55aeddf89f6670b9cdda475 (patch)
tree120ec6755ebd008fce013d39660f6cff3cbaeec0 /dev-games/simgear/simgear-2017.1.2.ebuild
parentkde-apps/kleopatra: Raise DEPEND on fixed kde-apps/kdepimlibs (diff)
downloadgentoo-d647eba30bef1720b55aeddf89f6670b9cdda475.tar.gz
gentoo-d647eba30bef1720b55aeddf89f6670b9cdda475.tar.bz2
gentoo-d647eba30bef1720b55aeddf89f6670b9cdda475.zip
games-simulation/flightgear: Version bump 2017.1.2, fix speexdps, bug 611674, enable SIMD intrinsics, sync live ebuild a bit. Drop PPC.
Diffstat (limited to 'dev-games/simgear/simgear-2017.1.2.ebuild')
-rw-r--r--dev-games/simgear/simgear-2017.1.2.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-games/simgear/simgear-2017.1.2.ebuild b/dev-games/simgear/simgear-2017.1.2.ebuild
new file mode 100644
index 000000000000..d1fdac8b30b5
--- /dev/null
+++ b/dev-games/simgear/simgear-2017.1.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils cmake-utils
+
+DESCRIPTION="Development library for simulation games"
+HOMEPAGE="http://www.simgear.org/"
+SRC_URI="mirror://sourceforge/flightgear/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+SLOT="0"
+IUSE="+dns debug subversion test"
+
+COMMON_DEPEND="
+ dev-libs/expat
+ >=dev-games/openscenegraph-3.2.0
+ media-libs/openal
+ net-misc/curl
+ sys-libs/zlib
+ virtual/opengl
+ dns? ( net-libs/udns )
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-libs/boost-1.44
+"
+RDEPEND="${COMMON_DEPEND}
+ subversion? ( dev-vcs/subversion )
+"
+
+DOCS=(AUTHORS ChangeLog NEWS README Thanks)
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_DNS=$(usex dns)
+ -DENABLE_PKGUTIL=ON
+ -DENABLE_RTI=OFF
+ -DENABLE_SIMD=ON
+ -DENABLE_SOUND=ON
+ -DENABLE_TESTS=$(usex test)
+ -DSIMGEAR_HEADLESS=OFF
+ -DSIMGEAR_SHARED=ON
+ -DSYSTEM_EXPAT=ON
+ -DSYSTEM_UDNS=ON
+ -DUSE_AEONWAVE=OFF
+ -DOSG_FSTREAM_EXPORT_FIXED=OFF # TODO perhaps track it
+ )
+ cmake-utils_src_configure
+}