summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Mrozowski <reavertm@gentoo.org>2019-03-18 00:35:32 +0100
committerMaciej Mrozowski <reavertm@gentoo.org>2019-03-18 00:40:27 +0100
commit76fbe622c5c4c49cfebfa2d85e42c016ee0366b6 (patch)
treec13d386620e1e27117ab3b66d2770a3bcb5ab3a1 /dev-games/simgear/simgear-9999.ebuild
parentnet-misc/putty: Version 0.71 (diff)
downloadgentoo-76fbe622c5c4c49cfebfa2d85e42c016ee0366b6.tar.gz
gentoo-76fbe622c5c4c49cfebfa2d85e42c016ee0366b6.tar.bz2
gentoo-76fbe622c5c4c49cfebfa2d85e42c016ee0366b6.zip
games-simulation/flightgear: Version bump 2018.3.2
Signed-off-by: Maciej Mrozowski <reavertm@gentoo.org>
Diffstat (limited to 'dev-games/simgear/simgear-9999.ebuild')
-rw-r--r--dev-games/simgear/simgear-9999.ebuild14
1 files changed, 10 insertions, 4 deletions
diff --git a/dev-games/simgear/simgear-9999.ebuild b/dev-games/simgear/simgear-9999.ebuild
index 10462f88d9fc..4ef9fc550b61 100644
--- a/dev-games/simgear/simgear-9999.ebuild
+++ b/dev-games/simgear/simgear-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit eutils cmake-utils toolchain-funcs git-r3
+inherit eutils cmake-utils toolchain-funcs flag-o-matic git-r3
DESCRIPTION="Development library for simulation games"
HOMEPAGE="http://www.simgear.org/"
@@ -14,7 +14,7 @@ EGIT_BRANCH="next"
LICENSE="GPL-2"
KEYWORDS=""
SLOT="0"
-IUSE="+dns debug gdal openmp subversion test"
+IUSE="cpu_flags_x86_sse2 +dns debug gdal openmp subversion test"
COMMON_DEPEND="
dev-libs/expat
@@ -48,7 +48,8 @@ src_configure() {
-DENABLE_OPENMP=$(usex openmp)
-DENABLE_PKGUTIL=ON
-DENABLE_RTI=OFF
- -DENABLE_SIMD=ON
+ -DENABLE_SIMD=OFF # see CPU_FLAGS
+ -DENABLE_SIMD_CODE=OFF
-DENABLE_SOUND=ON
-DENABLE_TESTS=$(usex test)
-DSIMGEAR_HEADLESS=OFF
@@ -58,5 +59,10 @@ src_configure() {
-DUSE_AEONWAVE=OFF
-DOSG_FSTREAM_EXPORT_FIXED=OFF # TODO perhaps track it
)
+
+ if use cpu_flags_x86_sse2; then
+ append-flags -msse2 -mfpmath=sse -ftree-vectorize -ftree-slp-vectorize
+ fi
+
cmake-utils_src_configure
}