summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Mrozowski <reavertm@gentoo.org>2017-06-15 05:36:55 +0200
committerMaciej Mrozowski <reavertm@gentoo.org>2017-06-15 05:45:08 +0200
commitc4ad6b25be4e46fe9f36968d2b32cbf707d42fd9 (patch)
tree20c132141b16176aa4b50552820bc59cad900fc2 /dev-games/simgear/simgear-9999.ebuild
parentsystemd.eclass: Improve systemd_install_serviced documentation (diff)
downloadgentoo-c4ad6b25be4e46fe9f36968d2b32cbf707d42fd9.tar.gz
gentoo-c4ad6b25be4e46fe9f36968d2b32cbf707d42fd9.tar.bz2
gentoo-c4ad6b25be4e46fe9f36968d2b32cbf707d42fd9.zip
games-simulation/flightgear: Version bump 2017.2.1
Diffstat (limited to 'dev-games/simgear/simgear-9999.ebuild')
-rw-r--r--dev-games/simgear/simgear-9999.ebuild13
1 files changed, 11 insertions, 2 deletions
diff --git a/dev-games/simgear/simgear-9999.ebuild b/dev-games/simgear/simgear-9999.ebuild
index b18a51cc4e30..00072326c7c9 100644
--- a/dev-games/simgear/simgear-9999.ebuild
+++ b/dev-games/simgear/simgear-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit eutils cmake-utils git-r3
+inherit eutils cmake-utils toolchain-funcs git-r3
DESCRIPTION="Development library for simulation games"
HOMEPAGE="http://www.simgear.org/"
@@ -14,7 +14,7 @@ EGIT_BRANCH="next"
LICENSE="GPL-2"
KEYWORDS=""
SLOT="0"
-IUSE="+dns debug subversion test"
+IUSE="+dns debug gdal openmp subversion test"
COMMON_DEPEND="
dev-libs/expat
@@ -24,6 +24,7 @@ COMMON_DEPEND="
sys-libs/zlib
virtual/opengl
dns? ( net-libs/udns )
+ gdal? ( sci-libs/gdal )
"
DEPEND="${COMMON_DEPEND}
>=dev-libs/boost-1.44
@@ -32,11 +33,19 @@ RDEPEND="${COMMON_DEPEND}
subversion? ( dev-vcs/subversion )
"
+PATCHES=( "${FILESDIR}/simgear-2017.2.1-gdal-underlinking.patch" )
+
DOCS=(AUTHORS ChangeLog NEWS README Thanks)
+pkg_pretend() {
+ use openmp && tc-check-openmp
+}
+
src_configure() {
local mycmakeargs=(
-DENABLE_DNS=$(usex dns)
+ -DENABLE_GDAL=$(usex gdal)
+ -DENABLE_OPENMP=$(usex openmp)
-DENABLE_PKGUTIL=ON
-DENABLE_RTI=OFF
-DENABLE_SIMD=ON