summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-09-16 14:35:56 +0200
committerDavid Seifert <soap@gentoo.org>2017-09-16 14:37:24 +0200
commit4535ab51db127d0875f29075366e46e849f81656 (patch)
tree7576430520b441adbd8077f912fa089f068f6833 /dev-games/simgear
parentx11-terms/sakura: Version bump. (diff)
downloadgentoo-4535ab51db127d0875f29075366e46e849f81656.tar.gz
gentoo-4535ab51db127d0875f29075366e46e849f81656.tar.bz2
gentoo-4535ab51db127d0875f29075366e46e849f81656.zip
dev-games/simgear: Fix boost TR1 header include
Closes: https://bugs.gentoo.org/630234 Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-games/simgear')
-rw-r--r--dev-games/simgear/files/simgear-2017.2.1-boost-1.65-tr1-removal.patch47
-rw-r--r--dev-games/simgear/simgear-2017.2.1.ebuild17
2 files changed, 58 insertions, 6 deletions
diff --git a/dev-games/simgear/files/simgear-2017.2.1-boost-1.65-tr1-removal.patch b/dev-games/simgear/files/simgear-2017.2.1-boost-1.65-tr1-removal.patch
new file mode 100644
index 000000000000..a9ebe507cee4
--- /dev/null
+++ b/dev-games/simgear/files/simgear-2017.2.1-boost-1.65-tr1-removal.patch
@@ -0,0 +1,47 @@
+--- a/simgear/scene/material/Effect.cxx
++++ b/simgear/scene/material/Effect.cxx
+@@ -32,7 +32,7 @@
+ #include <map>
+ #include <queue>
+ #include <utility>
+-#include <boost/tr1/unordered_map.hpp>
++#include <boost/unordered_map.hpp>
+
+ #include <boost/bind.hpp>
+ #include <boost/foreach.hpp>
+@@ -832,13 +832,13 @@
+
+ // XXX Should these be protected by a mutex? Probably
+
+-typedef tr1::unordered_map<ProgramKey, ref_ptr<Program>,
++typedef boost::unordered_map<ProgramKey, ref_ptr<Program>,
+ boost::hash<ProgramKey>, ProgramKey::EqualTo>
+ ProgramMap;
+ ProgramMap programMap;
+ ProgramMap resolvedProgramMap; // map with resolved shader file names
+
+-typedef tr1::unordered_map<ShaderKey, ref_ptr<Shader>, boost::hash<ShaderKey> >
++typedef boost::unordered_map<ShaderKey, ref_ptr<Shader>, boost::hash<ShaderKey> >
+ ShaderMap;
+ ShaderMap shaderMap;
+
+--- a/simgear/scene/material/Effect.hxx
++++ b/simgear/scene/material/Effect.hxx
+@@ -19,7 +19,7 @@
+
+ #include <vector>
+ #include <string>
+-#include <boost/tr1/unordered_map.hpp>
++#include <boost/unordered_map.hpp>
+
+ #include <boost/functional/hash.hpp>
+
+@@ -127,7 +127,7 @@
+ bool operator()(const Key& lhs, const Key& rhs) const;
+ };
+ };
+- typedef std::tr1::unordered_map<Key, osg::observer_ptr<Effect>,
++ typedef boost::unordered_map<Key, osg::observer_ptr<Effect>,
+ boost::hash<Key>, Key::EqualTo> Cache;
+ Cache* getCache()
+ {
diff --git a/dev-games/simgear/simgear-2017.2.1.ebuild b/dev-games/simgear/simgear-2017.2.1.ebuild
index fcdd831b3043..10aad3a8c38b 100644
--- a/dev-games/simgear/simgear-2017.2.1.ebuild
+++ b/dev-games/simgear/simgear-2017.2.1.ebuild
@@ -3,15 +3,15 @@
EAPI=6
-inherit eutils cmake-utils toolchain-funcs
+inherit cmake-utils toolchain-funcs
DESCRIPTION="Development library for simulation games"
HOMEPAGE="http://www.simgear.org/"
SRC_URI="mirror://sourceforge/flightgear/${P}.tar.bz2"
LICENSE="GPL-2"
-KEYWORDS="~amd64 ~x86"
SLOT="0"
+KEYWORDS="~amd64 ~x86"
IUSE="+dns debug gdal openmp subversion test"
COMMON_DEPEND="
@@ -31,12 +31,17 @@ RDEPEND="${COMMON_DEPEND}
subversion? ( dev-vcs/subversion )
"
-PATCHES=( "${FILESDIR}/simgear-2017.2.1-gdal-underlinking.patch" )
-
-DOCS=(AUTHORS ChangeLog NEWS README Thanks)
+PATCHES=(
+ "${FILESDIR}"/${PN}-2017.2.1-gdal-underlinking.patch
+ "${FILESDIR}"/${PN}-2017.2.1-boost-1.65-tr1-removal.patch
+)
pkg_pretend() {
- use openmp && tc-check-openmp
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
src_configure() {