summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-games/simgear
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-games/simgear')
-rw-r--r--dev-games/simgear/Manifest1
-rw-r--r--dev-games/simgear/metadata.xml16
-rw-r--r--dev-games/simgear/simgear-3.4.0.ebuild45
3 files changed, 62 insertions, 0 deletions
diff --git a/dev-games/simgear/Manifest b/dev-games/simgear/Manifest
new file mode 100644
index 000000000000..df7d42c1d160
--- /dev/null
+++ b/dev-games/simgear/Manifest
@@ -0,0 +1 @@
+DIST simgear-3.4.0.tar.bz2 1057455 SHA256 927d66fe72aacb9dacced4506430bd5fc7726bc8d3d07d6f1866bc4cb11a5894 SHA512 9ebf49ea2f024f0e52a4d18ba6f77361e7b9f51a0e7238661b4b2fd9db0176bdd948612d9b4aec3ae4d8210676e7533dfc0308b9c71bdeb22e99a68b90d81320 WHIRLPOOL bb48b6640409a96816ade77c22a91f88c452d339165dd0241354c26ff27572a14538ecfd91265c239def4621657be8766c081cffc237711a691d7ef54461b548
diff --git a/dev-games/simgear/metadata.xml b/dev-games/simgear/metadata.xml
new file mode 100644
index 000000000000..dc1208cc442b
--- /dev/null
+++ b/dev-games/simgear/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<maintainer>
+ <email>reavertm@gentoo.org</email>
+ <name>Maciej Mrozowski</name>
+</maintainer>
+<longdescription>
+SimGear is a set of open-source libraries designed to be used as building blocks for
+quickly assembling 3d simulations, games, and visualization applications.
+</longdescription>
+<use>
+ <flag name="subversion">Enables terrasync scenery downloader</flag>
+</use>
+</pkgmetadata>
diff --git a/dev-games/simgear/simgear-3.4.0.ebuild b/dev-games/simgear/simgear-3.4.0.ebuild
new file mode 100644
index 000000000000..579b7279af05
--- /dev/null
+++ b/dev-games/simgear/simgear-3.4.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils cmake-utils
+
+DESCRIPTION="Development library for simulation games"
+HOMEPAGE="http://www.simgear.org/"
+SRC_URI="http://mirrors.ibiblio.org/pub/mirrors/simgear/ftp/Source/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="amd64 ~ppc x86"
+SLOT="0"
+IUSE="debug subversion test"
+
+COMMON_DEPEND="
+ dev-libs/expat
+ >=dev-games/openscenegraph-3.2.0
+ media-libs/openal
+ sys-libs/zlib
+ virtual/opengl
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-libs/boost-1.44
+"
+RDEPEND="${COMMON_DEPEND}
+ subversion? ( dev-vcs/subversion )
+"
+
+DOCS=(AUTHORS ChangeLog NEWS README Thanks)
+
+src_configure() {
+ local mycmakeargs=(
+ -ENABLE_PKGUTIL=OFF
+ -DENABLE_RTI=OFF
+ -DENABLE_SOUND=ON
+ -DSIMGEAR_HEADLESS=OFF
+ -DSIMGEAR_SHARED=ON
+ -DSYSTEM_EXPAT=ON
+ $(cmake-utils_use_enable test TESTS)
+ )
+ cmake-utils_src_configure
+}