summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Mrozowski <reavertm@gentoo.org>2020-02-06 02:37:08 +0100
committerMaciej Mrozowski <reavertm@gentoo.org>2020-02-06 02:43:00 +0100
commitcd0a651403cba5edd2fb89c622b4de953c96af83 (patch)
tree7af1d1cebe0daead806536a9229083383e8d7563 /dev-games/simgear
parentdev-python/python-levenshtein-0.12.0: Drop doc USE flag as it needs python2 (diff)
downloadgentoo-cd0a651403cba5edd2fb89c622b4de953c96af83.tar.gz
gentoo-cd0a651403cba5edd2fb89c622b4de953c96af83.tar.bz2
gentoo-cd0a651403cba5edd2fb89c622b4de953c96af83.zip
dev-games/simgear: Build against sci-libs/gdal:3, bug 688130
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Maciej Mrozowski <reavertm@gentoo.org>
Diffstat (limited to 'dev-games/simgear')
-rw-r--r--dev-games/simgear/files/simgear-2019.1.1-gdal3.patch12
-rw-r--r--dev-games/simgear/simgear-2019.1.1.ebuild4
-rw-r--r--dev-games/simgear/simgear-9999.ebuild4
3 files changed, 20 insertions, 0 deletions
diff --git a/dev-games/simgear/files/simgear-2019.1.1-gdal3.patch b/dev-games/simgear/files/simgear-2019.1.1-gdal3.patch
new file mode 100644
index 000000000000..6d48994224c8
--- /dev/null
+++ b/dev-games/simgear/files/simgear-2019.1.1-gdal3.patch
@@ -0,0 +1,12 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 8a2f59f..5916c4c 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -308,6 +308,7 @@ endif(ENABLE_RTI)
+ if(ENABLE_GDAL)
+ find_package(GDAL 2.0.0 REQUIRED)
+ if (GDAL_FOUND)
++ add_compile_definitions(USE_DEPRECATED_SRS_WKT_WGS84)
+ include_directories(${GDAL_INCLUDE_DIR})
+ endif(GDAL_FOUND)
+ endif(ENABLE_GDAL)
diff --git a/dev-games/simgear/simgear-2019.1.1.ebuild b/dev-games/simgear/simgear-2019.1.1.ebuild
index 61da9b322ade..be0ff6416267 100644
--- a/dev-games/simgear/simgear-2019.1.1.ebuild
+++ b/dev-games/simgear/simgear-2019.1.1.ebuild
@@ -33,6 +33,10 @@ RDEPEND="${COMMON_DEPEND}
subversion? ( dev-vcs/subversion )
"
+PATCHES=(
+ "${FILESDIR}/${PN}-2019.1.1-gdal3.patch"
+)
+
pkg_pretend() {
[[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
diff --git a/dev-games/simgear/simgear-9999.ebuild b/dev-games/simgear/simgear-9999.ebuild
index a06b4dfb3dee..d5d560554829 100644
--- a/dev-games/simgear/simgear-9999.ebuild
+++ b/dev-games/simgear/simgear-9999.ebuild
@@ -35,6 +35,10 @@ RDEPEND="${COMMON_DEPEND}
subversion? ( dev-vcs/subversion )
"
+PATCHES=(
+ "${FILESDIR}/${PN}-2019.1.1-gdal3.patch"
+)
+
pkg_pretend() {
[[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}