summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2015-10-13 00:59:55 +1100
committerMichael Palimaka <kensington@gentoo.org>2015-10-13 01:01:30 +1100
commit3be3b2acf10db20d17ada52eca438988a92dec44 (patch)
tree34da01c87d37df900c8ef3ff7102364f0b35c71c /dev-games/tiled/tiled-0.14.2.ebuild
parentdev-util/howdoi: remove old (diff)
downloadgentoo-3be3b2acf10db20d17ada52eca438988a92dec44.tar.gz
gentoo-3be3b2acf10db20d17ada52eca438988a92dec44.tar.bz2
gentoo-3be3b2acf10db20d17ada52eca438988a92dec44.zip
dev-games/tiled: version bump
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-games/tiled/tiled-0.14.2.ebuild')
-rw-r--r--dev-games/tiled/tiled-0.14.2.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/dev-games/tiled/tiled-0.14.2.ebuild b/dev-games/tiled/tiled-0.14.2.ebuild
new file mode 100644
index 000000000000..f2bad72474fb
--- /dev/null
+++ b/dev-games/tiled/tiled-0.14.2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+inherit fdo-mime multilib python-single-r1 qmake-utils
+
+DESCRIPTION="A general purpose tile map editor"
+HOMEPAGE="http://www.mapeditor.org/"
+SRC_URI="https://github.com/bjorn/tiled/archive/v${PV}/${P}.tar.gz"
+
+LICENSE="BSD BSD-2 GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples python"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtopengl:5
+ dev-qt/qtwidgets:5
+ sys-libs/zlib
+ python? ( ${PYTHON_DEPS} )
+"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ eqmake5 LIBDIR="/usr/$(get_libdir)" PREFIX="/usr" DISABLE_PYTHON_PLUGIN="$(usex !python)"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+
+ dodoc AUTHORS COPYING NEWS README.md
+
+ if use examples ; then
+ docompress -x /usr/share/doc/${PF}/examples
+ dodoc -r examples
+ fi
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}