summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2019-07-30 23:50:51 +0300
committerAlexey Shvetsov <alexxy@gentoo.org>2019-07-30 23:51:16 +0300
commit2fc3cd384284c6a3240adbf143019b8b95b3e439 (patch)
treea4527b75ca34342af14ce60f242b94625b88df0d /dev-games
parentdev-python/pysol_cards: Works with python3.7 (diff)
downloadgentoo-2fc3cd384284c6a3240adbf143019b8b95b3e439.tar.gz
gentoo-2fc3cd384284c6a3240adbf143019b8b95b3e439.tar.bz2
gentoo-2fc3cd384284c6a3240adbf143019b8b95b3e439.zip
dev-games/freecell-solver: Works with python3.7
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Alexey Shvetsov <alexxy@gentoo.org>
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/freecell-solver/freecell-solver-5.6.0-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-games/freecell-solver/freecell-solver-5.6.0-r1.ebuild b/dev-games/freecell-solver/freecell-solver-5.6.0-r1.ebuild
new file mode 100644
index 000000000000..159cc4f198b0
--- /dev/null
+++ b/dev-games/freecell-solver/freecell-solver-5.6.0-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+inherit cmake-utils python-single-r1
+
+DESCRIPTION="C library for automatically solving Freecell and some other solitaire variants"
+HOMEPAGE="https://fc-solve.shlomifish.org/"
+SRC_URI="https://fc-solve.shlomifish.org/downloads/fc-solve/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/pysol_cards[${PYTHON_USEDEP}]
+ dev-python/random2[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-perl/Path-Tiny
+ dev-perl/Template-Toolkit
+"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+src_prepare() {
+ sed -i -e "s|share/doc/freecell-solver/|share/doc/${P}|" CMakeLists.txt || die
+
+ python_fix_shebang board_gen
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_STATIC_LIBRARY=OFF
+ -DFCS_BUILD_DOCS=OFF
+ -DFCS_WITH_TEST_SUITE=OFF #requires unpackaged dependencies
+ )
+
+ cmake-utils_src_configure
+}