summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-18 12:30:37 +0100
committerSam James <sam@gentoo.org>2023-04-18 12:30:37 +0100
commit790927a7ccf40f62ce7b5f62ddcd88f69ca83d76 (patch)
treedf02348101c0b1a44eade81d36e2cba3b57227e7 /dev-games
parentdev-cpp/abseil-cpp: fix build w/ gcc 13 (diff)
downloadgentoo-790927a7ccf40f62ce7b5f62ddcd88f69ca83d76.tar.gz
gentoo-790927a7ccf40f62ce7b5f62ddcd88f69ca83d76.tar.bz2
gentoo-790927a7ccf40f62ce7b5f62ddcd88f69ca83d76.zip
dev-games/mygui: fix build w/ gcc 13
Closes: https://bugs.gentoo.org/895098 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/mygui/files/mygui-3.4.1-gcc13.patch23
-rw-r--r--dev-games/mygui/mygui-3.4.1.ebuild3
2 files changed, 25 insertions, 1 deletions
diff --git a/dev-games/mygui/files/mygui-3.4.1-gcc13.patch b/dev-games/mygui/files/mygui-3.4.1-gcc13.patch
new file mode 100644
index 000000000000..542df19bcfc5
--- /dev/null
+++ b/dev-games/mygui/files/mygui-3.4.1-gcc13.patch
@@ -0,0 +1,23 @@
+https://github.com/MyGUI/mygui/pull/249
+
+From f97c85b4e096379f728700d61c2f5780043dfc0a Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Tue, 18 Apr 2023 12:29:08 +0100
+Subject: [PATCH] Fix build with GCC 13
+
+GCC 13 (as usual for new compiler releases) shuffles around some internal includes so some
+are no longer transitively included.
+
+See https://gnu.org/software/gcc/gcc-13/porting_to.html.
+
+Bug: https://bugs.gentoo.org/895098
+--- a/MyGUIEngine/include/MyGUI_Types.h
++++ b/MyGUIEngine/include/MyGUI_Types.h
+@@ -9,6 +9,7 @@
+
+ #include "MyGUI_Prerequest.h"
+
++#include <cstdint>
+ #include <vector>
+ #include <map>
+ #include <string>
diff --git a/dev-games/mygui/mygui-3.4.1.ebuild b/dev-games/mygui/mygui-3.4.1.ebuild
index 182b5dbdf3cd..84c0fdb8b016 100644
--- a/dev-games/mygui/mygui-3.4.1.ebuild
+++ b/dev-games/mygui/mygui-3.4.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -42,6 +42,7 @@ STATIC_BUILD=${WORKDIR}/${P}_build_static
PATCHES=(
"${FILESDIR}"/${P}-build.patch
"${FILESDIR}"/${P}-FHS.patch
+ "${FILESDIR}"/${P}-gcc13.patch
)
pkg_setup() {