summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-02-16 19:45:50 -0500
committerIonen Wolkens <ionen@gentoo.org>2023-02-16 20:43:38 -0500
commit9cd0dbf67043d2630f3582c7609b184be7bb2a8e (patch)
tree6dfa43f570f06f8811e5c5265b0e84a0e54ecb46 /dev-games
parentapp-emacs/tempel: bump to 0.7 (diff)
downloadgentoo-9cd0dbf67043d2630f3582c7609b184be7bb2a8e.tar.gz
gentoo-9cd0dbf67043d2630f3582c7609b184be7bb2a8e.tar.bz2
gentoo-9cd0dbf67043d2630f3582c7609b184be7bb2a8e.zip
dev-games/godot: update musl patch
Used to work but missed that a new godot4 alpha added automagic to enable execinfo. If libexecinfo is ever packaged, could yank this, depend on it for musl and let the automagic do its thing. Not really tested on musl, but it builds. godot:3 should still build fine, it only auto-enables execinfo on BSD. Closes: https://bugs.gentoo.org/894762 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/godot/files/godot-4.0_rc2-musl.patch21
-rw-r--r--dev-games/godot/godot-4.0_rc2.ebuild3
2 files changed, 22 insertions, 2 deletions
diff --git a/dev-games/godot/files/godot-4.0_rc2-musl.patch b/dev-games/godot/files/godot-4.0_rc2-musl.patch
new file mode 100644
index 000000000000..3b9a458ac7d4
--- /dev/null
+++ b/dev-games/godot/files/godot-4.0_rc2-musl.patch
@@ -0,0 +1,21 @@
+Crash handler requires glibc or libexecinfo (not packaged) and is enabled
+if build the editor (implies debug), but can be easily turned off.
+https://bugs.gentoo.org/894762
+--- a/platform/linuxbsd/crash_handler_linuxbsd.cpp
++++ b/platform/linuxbsd/crash_handler_linuxbsd.cpp
+@@ -38,3 +38,3 @@
+
+-#ifdef DEBUG_ENABLED
++#if defined(DEBUG_ENABLED) && defined(__GLIBC__)
+ #define CRASH_HANDLER_ENABLED 1
+--- a/platform/linuxbsd/detect.py
++++ b/platform/linuxbsd/detect.py
+@@ -329,8 +329,2 @@
+
+- if not env["execinfo"] and platform.libc_ver()[0] != "glibc":
+- # The default crash handler depends on glibc, so if the host uses
+- # a different libc (BSD libc, musl), fall back to libexecinfo.
+- print("Note: Using `execinfo=yes` for the crash handler as required on platforms where glibc is missing.")
+- env["execinfo"] = True
+-
+ if env["execinfo"]:
diff --git a/dev-games/godot/godot-4.0_rc2.ebuild b/dev-games/godot/godot-4.0_rc2.ebuild
index 8c124e770a8e..d031d3f1fcaf 100644
--- a/dev-games/godot/godot-4.0_rc2.ebuild
+++ b/dev-games/godot/godot-4.0_rc2.ebuild
@@ -62,9 +62,9 @@ DEPEND="
BDEPEND="virtual/pkgconfig"
PATCHES=(
- "${FILESDIR}"/${PN}-4.0-musl.patch
"${FILESDIR}"/${PN}-4.0_beta3-headless-header.patch
"${FILESDIR}"/${PN}-4.0_beta8-scons.patch
+ "${FILESDIR}"/${PN}-4.0_rc2-musl.patch
)
src_prepare() {
@@ -109,7 +109,6 @@ src_compile() {
verbose=yes
deprecated=$(usex deprecated)
- #execinfo=$(usex !elibc_glibc) # libexecinfo is not packaged
opengl3=$(usex gui)
use_volk=no # unnecessary when linking directly to libvulkan
vulkan=$(usex gui $(usex vulkan))