summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-08-15 07:49:24 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-08-15 20:00:32 -0400
commitd2cfd7cf8626696cbff9f3cdad34e29d9b0b38e5 (patch)
tree19e92d737ab5d0fded295cb22a94c6c935d549ff /dev-games
parentdev-games/godot: new package, add 3.5 (slot:3) (diff)
downloadgentoo-d2cfd7cf8626696cbff9f3cdad34e29d9b0b38e5.tar.gz
gentoo-d2cfd7cf8626696cbff9f3cdad34e29d9b0b38e5.tar.bz2
gentoo-d2cfd7cf8626696cbff9f3cdad34e29d9b0b38e5.zip
dev-games/godot: add 4.0_alpha14 (slot:4), unkeyworded
This entered feature freeze on August 3 and "shouldn't" introduce more breaking changes. Albeit has many known bugs/oddities to be resolved, and --convert-3to4 hasn't been faring so well (new projects should probably start on 4 at this point though). Adding for testing, may look at keywording the first beta which been planned for early September (devs that need godot:3 may want to add the slot to their world file now). Bug: https://bugs.gentoo.org/532730 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/godot/Manifest1
-rw-r--r--dev-games/godot/files/godot-4.0-musl.patch9
-rw-r--r--dev-games/godot/files/godot-4.0_alpha14-scons.patch29
-rw-r--r--dev-games/godot/godot-4.0_alpha14.ebuild246
-rw-r--r--dev-games/godot/metadata.xml1
5 files changed, 286 insertions, 0 deletions
diff --git a/dev-games/godot/Manifest b/dev-games/godot/Manifest
index 8116161b4deb..9d7912698ebb 100644
--- a/dev-games/godot/Manifest
+++ b/dev-games/godot/Manifest
@@ -1 +1,2 @@
DIST godot-3.5-stable.tar.xz 24044340 BLAKE2B 9d77ecdfa6bd90065fff26c2334f13c32bbbc4b26aad111b5aab2563d1e4782457ea6cf2115f1a809e0d8aac3d3ee9a138ad224998068983ad36e54a577d89c3 SHA512 23785e39ccc7e1406c97ee33b5e90f7f397aa907d79d72ed08ea3f4b7e68788030a1bcdd07c9f782a21ee3a84636a2cea47a57dcfc94c24e327fa210ae0515b0
+DIST godot-4.0-alpha14.tar.xz 30970116 BLAKE2B 213616f3a80f97c09580324bf9296d12b6213a2941b3070353b45e160dc7d7bfd32fcae3fc2b64a91fa7d935c23d97fd02a015bc3501441d67261ee6e45e85e1 SHA512 511cb5d3f48c747232350bee25765c17032b99179fd70877f906bcd1a09449260a928c3df9f84c6f3afb47f564b8f4bf75d0a07d37f5a22dd5f5a96d1b1f4df5
diff --git a/dev-games/godot/files/godot-4.0-musl.patch b/dev-games/godot/files/godot-4.0-musl.patch
new file mode 100644
index 000000000000..50c5c334773f
--- /dev/null
+++ b/dev-games/godot/files/godot-4.0-musl.patch
@@ -0,0 +1,9 @@
+crash handler requires glibc or libexecinfo (not packaged),
+and is always enabled if build the editor (release_debug)
+--- a/platform/linuxbsd/crash_handler_linuxbsd.cpp
++++ b/platform/linuxbsd/crash_handler_linuxbsd.cpp
+@@ -38,3 +38,3 @@
+
+-#ifdef DEBUG_ENABLED
++#if defined(DEBUG_ENABLED) && defined(__GLIBC__)
+ #define CRASH_HANDLER_ENABLED 1
diff --git a/dev-games/godot/files/godot-4.0_alpha14-scons.patch b/dev-games/godot/files/godot-4.0_alpha14-scons.patch
new file mode 100644
index 000000000000..295f471d525b
--- /dev/null
+++ b/dev-games/godot/files/godot-4.0_alpha14-scons.patch
@@ -0,0 +1,29 @@
+* add option to respect AR
+ (respecting PKG_CONFIG is handled in the ebuild)
+* fix icu unbundling underlinking
+* handle recastnavigation unbundling
+--- a/SConstruct
++++ b/SConstruct
+@@ -233,4 +233,5 @@
+ opts.Add("CXX", "C++ compiler")
+ opts.Add("CC", "C compiler")
++opts.Add("AR", "Archiver")
+ opts.Add("LINK", "Linker")
+ opts.Add("CCFLAGS", "Custom flags for both the C and C++ compilers")
+--- a/platform/linuxbsd/detect.py
++++ b/platform/linuxbsd/detect.py
+@@ -238,5 +238,5 @@
+
+ if not env["builtin_icu"]:
+- env.ParseConfig("pkg-config icu-uc --cflags --libs")
++ env.ParseConfig("pkg-config icu-i18n --cflags --libs")
+
+ if not env["builtin_harfbuzz"]:
+@@ -249,4 +249,7 @@
+ env.ParseConfig("pkg-config libenet --cflags --libs")
+
++ if not env["builtin_recast"]:
++ env.ParseConfig("pkg-config recastnavigation --cflags --libs")
++
+ if not env["builtin_squish"]:
+ env.ParseConfig("pkg-config libsquish --cflags --libs")
diff --git a/dev-games/godot/godot-4.0_alpha14.ebuild b/dev-games/godot/godot-4.0_alpha14.ebuild
new file mode 100644
index 000000000000..9844ed38787e
--- /dev/null
+++ b/dev-games/godot/godot-4.0_alpha14.ebuild
@@ -0,0 +1,246 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit bash-completion-r1 desktop python-any-r1 scons-utils toolchain-funcs xdg
+
+MY_P="${PN}-$(ver_rs 2 -)"
+
+DESCRIPTION="Multi-platform 2D and 3D game engine with a feature-rich editor"
+HOMEPAGE="https://godotengine.org/"
+SRC_URI="https://downloads.tuxfamily.org/godotengine/$(ver_rs 2 /)/${MY_P}.tar.xz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="
+ MIT
+ Apache-2.0 BSD Boost-1.0 CC0-1.0 Unlicense ZLIB
+ gui? ( CC-BY-4.0 ) tools? ( OFL-1.1 )"
+SLOT="4"
+#KEYWORDS="~amd64" # leaving 4 unkeyworded until at least first _beta
+# Enable roughly same as upstream by default so it works as expected,
+# except raycast (tools-only heavy dependency), and deprecated.
+IUSE="
+ +dbus debug deprecated +fontconfig +gui pulseaudio raycast
+ +runner speech test +theora +tools +udev +upnp +webp"
+RESTRICT="!test? ( test ) !tools? ( test )"
+
+# dlopen: alsa-lib,dbus,fontconfig,pulseaudio,speech-dispatcher,udev
+RDEPEND="
+ app-arch/zstd:=
+ dev-games/recastnavigation:=
+ dev-libs/icu:=
+ dev-libs/libpcre2:=[pcre32]
+ media-libs/freetype[brotli,harfbuzz]
+ media-libs/harfbuzz:=[icu]
+ media-libs/libogg
+ media-libs/libpng:=
+ media-libs/libvorbis
+ <net-libs/mbedtls-3:=
+ net-libs/wslay
+ sys-libs/zlib:=
+ fontconfig? ( media-libs/fontconfig )
+ gui? (
+ dev-util/glslang
+ media-libs/alsa-lib
+ media-libs/libglvnd[X]
+ media-libs/vulkan-loader[X]
+ x11-libs/libX11
+ x11-libs/libXcursor
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ dbus? ( sys-apps/dbus )
+ pulseaudio? ( media-libs/libpulse )
+ tools? ( raycast? ( media-libs/embree:3 ) )
+ udev? ( virtual/udev )
+ )
+ speech? ( app-accessibility/speech-dispatcher )
+ theora? ( media-libs/libtheora )
+ tools? ( app-misc/ca-certificates )
+ upnp? ( net-libs/miniupnpc:= )
+ webp? ( media-libs/libwebp:= )"
+DEPEND="
+ ${RDEPEND}
+ gui? (
+ dev-util/vulkan-headers
+ x11-base/xorg-proto
+ )
+ tools? ( test? ( dev-cpp/doctest ) )"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.0-musl.patch
+ "${FILESDIR}"/${PN}-4.0_alpha14-scons.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i "1,5s/ godot/&${SLOT}/i" misc/dist/linux/godot.6 || die
+ sed -i "/id/s/Godot/&${SLOT}/" misc/dist/linux/org.godotengine.Godot.appdata.xml || die
+ sed -e "s/=godot/&${SLOT}/" -e "/^Name=/s/$/ ${SLOT}/" \
+ -i misc/dist/linux/org.godotengine.Godot.desktop || die
+
+ sed -i "s|pkg-config |$(tc-getPKG_CONFIG) |" platform/linuxbsd/detect.py || die
+
+ # use of builtin_ switches can be messy (see below), delete to be sure
+ local unbundle=(
+ doctest embree freetype glslang graphite harfbuzz icu4c libogg libpng
+ libtheora libvorbis libwebp mbedtls miniupnpc pcre2 recastnavigation
+ volk vulkan/include wslay zlib zstd
+ # certs: unused by generated header, but scons panics if not found
+ )
+ rm -r "${unbundle[@]/#/thirdparty/}" || die
+
+ # do symlinks to avoid too much patching with hardcoded header paths
+ mkdir thirdparty/lib{vorbis,ogg} || die
+ ln -s "${ESYSROOT}"/usr/include thirdparty/zstd || die
+ ln -s "${ESYSROOT}"/usr/include/doctest thirdparty/ || die
+ ln -s "${ESYSROOT}"/usr/include/ogg thirdparty/libogg/ || die
+ ln -s "${ESYSROOT}"/usr/include/vorbis thirdparty/libvorbis/ || die
+}
+
+src_compile() {
+ local -x GODOT_VERSION_STATUS=$(ver_cut 3-4) # for dev versions only
+ local -x BUILD_NAME=gentoo # replaces "custom_build" in version string
+
+ local esconsargs=(
+ AR="$(tc-getAR)" CC="$(tc-getCC)" CXX="$(tc-getCXX)"
+
+ progress=no
+ verbose=yes
+
+ deprecated=$(usex deprecated)
+ #execinfo=$(usex !elibc_glibc) # libexecinfo is not packaged
+ fontconfig=$(usex fontconfig)
+ minizip=yes # uses a modified bundled copy
+ opengl3=$(usex gui)
+ pulseaudio=$(usex gui $(usex pulseaudio))
+ speechd=$(usex speech)
+ udev=$(usex gui $(usex udev))
+ use_dbus=$(usex gui $(usex dbus))
+ use_volk=no # unnecessary when linking directly to libvulkan
+ vulkan=$(usex gui) # hard-required and favored by upstream over gles3
+ x11=$(usex gui)
+
+ system_certs_path="${EPREFIX}"/etc/ssl/certs/ca-certificates.crt
+
+ # platform/*/detect.py uses builtin_* switches to check if need
+ # to link with system libraries, but ignores whether the dep is
+ # actually used, so "enable" deleted builtins on disabled deps
+ builtin_certs=no
+ builtin_embree=$(usex !gui yes $(usex !tools yes $(usex !raycast)))
+ builtin_enet=yes # bundled copy is patched for IPv6+DTLS support
+ builtin_freetype=no
+ builtin_glslang=$(usex !gui)
+ builtin_graphite=no
+ builtin_harfbuzz=no
+ builtin_icu=no
+ builtin_libogg=no
+ builtin_libpng=no
+ builtin_libtheora=$(usex !theora)
+ builtin_libvorbis=no
+ builtin_libwebp=$(usex !webp)
+ builtin_mbedtls=no
+ builtin_miniupnpc=$(usex !upnp)
+ builtin_msdfgen=yes # not wired for unbundling nor packaged
+ builtin_pcre2=no
+ builtin_recast=no
+ builtin_rvo2=yes # bundled copy has godot-specific changes
+ builtin_squish=yes # ^ likewise, may not be safe to unbundle
+ builtin_wslay=no
+ builtin_xatlas=yes # not wired for unbundling nor packaged
+ builtin_zlib=no
+ builtin_zstd=no
+ # also bundled but lacking a builtin_* switch:
+ # amd-fsr, basis_universal, cvtt, etcpak, fonts, glad,
+ # jpeg-compressor, meshoptimizer, minimp3, minizip (patched to
+ # seek in archives), noise, oidn, openxr, spirv-reflect, thorvg,
+ # tinyexr, vhacd, vulkan (minus include/) and the misc directory.
+
+ # modules with optional dependencies, "possible" to disable more but
+ # gets messy and breaks all sorts of features (expected enabled)
+ module_glslang_enabled=$(usex gui)
+ module_gridmap_enabled=$(usex deprecated) # fails without deprecated
+ module_mono_enabled=no # unhandled
+ # note raycast is disabled on many arches, see raycast/config.py
+ module_raycast_enabled=$(usex gui $(usex tools $(usex raycast)))
+ module_theora_enabled=$(usex theora)
+ module_upnp_enabled=$(usex upnp)
+ module_webp_enabled=$(usex webp)
+
+ # let *FLAGS handle these, e.g. can pass -flto as-is
+ debug_symbols=no
+ optimize=none
+ use_lto=no
+ use_static_cpp=no
+ )
+
+ if use runner && use tools; then
+ # build alternate faster + ~60% smaller binary for running
+ # games or servers without game development debug paths
+ escons extra_suffix=runner target=release tools=no "${esconsargs[@]}"
+ fi
+
+ esconsargs+=(
+ # debug: debug for godot itself
+ # release_debug: debug for game development
+ # release: no debugging paths, only available with tools=no
+ target=$(usex debug{,} $(usex tools release_debug release))
+ tools=$(usex tools)
+
+ # harmless but note this bakes in --test in the final binary
+ tests=$(usex tools $(usex test))
+ )
+
+ escons extra_suffix=main "${esconsargs[@]}"
+}
+
+src_test() {
+ xdg_environment_reset
+ bin/godot*.main --headless --test || die
+}
+
+src_install() {
+ local s=godot${SLOT}
+
+ newbin bin/godot*.main ${s}
+ if use runner && use tools; then
+ newbin bin/godot*.runner ${s}-runner
+ else
+ # always available, revdeps shouldn't depend on [runner]
+ dosym ${s} /usr/bin/${s}-runner
+ fi
+
+ newman misc/dist/linux/godot.6 ${s}.6
+ dodoc AUTHORS.md CHANGELOG.md DONORS.md README.md
+
+ if use gui; then
+ newicon icon.svg ${s}.svg
+ newmenu misc/dist/linux/org.godotengine.Godot.desktop \
+ org.godotengine.${s^}.desktop
+
+ insinto /usr/share/metainfo
+ newins misc/dist/linux/org.godotengine.Godot.appdata.xml \
+ org.godotengine.${s^}.appdata.xml
+
+ insinto /usr/share/mime/application
+ newins misc/dist/linux/org.godotengine.Godot.xml \
+ org.godotengine.${s^}.xml
+ fi
+
+ newbashcomp misc/dist/shell/godot.bash-completion ${s}
+ bashcomp_alias ${s}{,-runner}
+
+ insinto /usr/share/fish/vendor_completions.d
+ newins misc/dist/shell/godot.fish ${s}.fish
+ dosym ${s}.fish /usr/share/fish/vendor_completions.d/${s}-runner.fish
+
+ insinto /usr/share/zsh/site-functions
+ newins misc/dist/shell/_godot.zsh-completion _${s}
+ dosym _${s} /usr/share/zsh/site-functions/_${s}-runner
+}
diff --git a/dev-games/godot/metadata.xml b/dev-games/godot/metadata.xml
index 71f596fee4e9..a64b3cb9efea 100644
--- a/dev-games/godot/metadata.xml
+++ b/dev-games/godot/metadata.xml
@@ -24,6 +24,7 @@
<flag name="deprecated">Enable support for deprecated features</flag>
<flag name="raycast">Enable the raycast Editor module using <pkg>media-libs/embree</pkg></flag>
<flag name="runner">Build an additional binary optimized for running games (only relevant with USE=tools)</flag>
+ <flag name="speech">Enable text-to-speech support</flag>
<flag name="tools">Enable the Godot Editor for game development</flag>
<flag name="webm">Enable the WebM module</flag>
</use>