summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-11-27 11:40:35 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-11-27 12:07:52 +0100
commite04c9064b89db0019cb71830d6e7a3ee9e6c53ab (patch)
tree7b39914af49c0c4d03a3c0f3b475daca74f96252 /dev-games
parentdev-libs/rinutils: 0.10.0 version bump (diff)
downloadgentoo-e04c9064b89db0019cb71830d6e7a3ee9e6c53ab.tar.gz
gentoo-e04c9064b89db0019cb71830d6e7a3ee9e6c53ab.tar.bz2
gentoo-e04c9064b89db0019cb71830d6e7a3ee9e6c53ab.zip
dev-games/freecell-solver: 6.6.0 version bump
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/freecell-solver/Manifest1
-rw-r--r--dev-games/freecell-solver/files/freecell-solver-6.6.0-no-git-clone-kthxbye.patch39
-rw-r--r--dev-games/freecell-solver/freecell-solver-6.6.0.ebuild56
3 files changed, 96 insertions, 0 deletions
diff --git a/dev-games/freecell-solver/Manifest b/dev-games/freecell-solver/Manifest
index 154ed9481369..9a0b457b2422 100644
--- a/dev-games/freecell-solver/Manifest
+++ b/dev-games/freecell-solver/Manifest
@@ -1 +1,2 @@
DIST freecell-solver-6.2.0.tar.xz 426616 BLAKE2B f48d1b67c56a42f42e00e765a911944ae7d2eb97db81a8ebb58baa1603bd274c9ceb460bdf5c232c4f2b3f54d33acc0057e25c8c0bce897bb862eedc16613f05 SHA512 090f6b93c3f354b5c6bcb1ea67d9313639d23e81998cdc15316246a1cdac26450cf8fd04172bfd5539d875edf407dcdf7ce2c872221b7261f89dbbe309c27560
+DIST freecell-solver-6.6.0.tar.xz 432564 BLAKE2B 8bd4acc29eb2b934ae8666dd2877a428ed7b7f7f9eec87c8c7e395cd364dde91caac98895fa1abe61eeb7fd2ea84c4abf9924fc136879d53f9dd43ec5221b55a SHA512 55844426ca7e8c01916b94aca13ef579923b28ef88376bade6899a2b791a4a8198160a05169915fb484a12363c8c1b2f1bfaa7bd18afbc46c9ba86058cbba2bb
diff --git a/dev-games/freecell-solver/files/freecell-solver-6.6.0-no-git-clone-kthxbye.patch b/dev-games/freecell-solver/files/freecell-solver-6.6.0-no-git-clone-kthxbye.patch
new file mode 100644
index 000000000000..db2cc0bfb915
--- /dev/null
+++ b/dev-games/freecell-solver/files/freecell-solver-6.6.0-no-git-clone-kthxbye.patch
@@ -0,0 +1,39 @@
+From edbcda19be3720b164e9961226bfa74271f2b9b5 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Sat, 27 Nov 2021 11:35:28 +0100
+Subject: [PATCH] Make sure to disable futile external repo fetching
+
+---
+ CMakeLists.txt | 2 +-
+ cmake/rinutils_bootstrap.cmake | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index c991dcb47..b0c13d4ff 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -210,7 +210,7 @@ ENDIF ()
+ # Clone the patsolve repository with the appropriate branch.
+ SET (pats_dir "patsolve")
+
+-IF (NOT EXISTS "${CMAKE_CURRENT_SOURCE_DIR}/${pats_dir}")
++IF (0)
+ EXECUTE_PROCESS(
+ COMMAND "git" "clone" "https://github.com/shlomif/patsolve.git" "${pats_dir}"
+ WORKING_DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}"
+diff --git a/cmake/rinutils_bootstrap.cmake b/cmake/rinutils_bootstrap.cmake
+index 3879bce85..cf2ea168d 100644
+--- a/cmake/rinutils_bootstrap.cmake
++++ b/cmake/rinutils_bootstrap.cmake
+@@ -5,7 +5,7 @@ MACRO(RINUTILS_SET_UP_FLAGS)
+ SET (rinutils_inc_dir "${rinutils_dir_absolute}/rinutils/include")
+ SET (rinutils_git_tag "0.6.0")
+
+- find_package(Rinutils QUIET)
++ find_package(Rinutils REQUIRED)
+ IF ("${Rinutils_FOUND}")
+ INCLUDE_DIRECTORIES(AFTER ${RINUTILS_INCLUDE_DIR} ${RINUTILS_INCLUDE_DIRS})
+ ELSE ()
+--
+2.34.1
+
diff --git a/dev-games/freecell-solver/freecell-solver-6.6.0.ebuild b/dev-games/freecell-solver/freecell-solver-6.6.0.ebuild
new file mode 100644
index 000000000000..29ec00776400
--- /dev/null
+++ b/dev-games/freecell-solver/freecell-solver-6.6.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit cmake python-single-r1
+
+DESCRIPTION="C library for automatically solving Freecell and some other solitaire variants"
+HOMEPAGE="https://fc-solve.shlomifish.org/"
+SRC_URI="https://fc-solve.shlomifish.org/downloads/fc-solve/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+IUSE="tcmalloc"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-libs/rinutils
+ $(python_gen_cond_dep '
+ dev-python/pysol_cards[${PYTHON_USEDEP}]
+ dev-python/random2[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ ')
+ tcmalloc? ( dev-util/google-perftools )
+"
+DEPEND="${RDEPEND}
+ dev-perl/Moo
+ dev-perl/Path-Tiny
+ dev-perl/Template-Toolkit
+"
+
+DOCS=( README.html )
+
+PATCHES=(
+ "${FILESDIR}/${PN}-5.22.1-no-docs.patch"
+ "${FILESDIR}/${P}-no-git-clone-kthxbye.patch"
+)
+
+src_prepare() {
+ cmake_src_prepare
+ python_fix_shebang board_gen
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_STATIC_LIBRARY=OFF
+ -DFCS_BUILD_DOCS=OFF
+ -DFCS_WITH_TEST_SUITE=OFF # requires unpackaged dependencies
+ -DFCS_AVOID_TCMALLOC=$(usex !tcmalloc)
+ )
+
+ cmake_src_configure
+}