summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-10-23 19:52:05 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-10-24 01:26:54 +0200
commitf27b88a6c945884c6b3cd3fa7daaf5865dac83e8 (patch)
tree8a854746619e52675acaaa5d28e77283b1620896 /dev-games
parentdev-java/openjdk-jre-bin: bump to 8.272_p10 (diff)
downloadgentoo-f27b88a6c945884c6b3cd3fa7daaf5865dac83e8.tar.gz
gentoo-f27b88a6c945884c6b3cd3fa7daaf5865dac83e8.tar.bz2
gentoo-f27b88a6c945884c6b3cd3fa7daaf5865dac83e8.zip
dev-games/openscenegraph-qt: Drop IUSE=webkit
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/openscenegraph-qt/openscenegraph-qt-3.5.7-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-games/openscenegraph-qt/openscenegraph-qt-3.5.7-r1.ebuild b/dev-games/openscenegraph-qt/openscenegraph-qt-3.5.7-r1.ebuild
new file mode 100644
index 000000000000..ebbcc46e59cd
--- /dev/null
+++ b/dev-games/openscenegraph-qt/openscenegraph-qt-3.5.7-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="osgQt"
+MY_P=${MY_PN}-${PV}
+inherit cmake
+
+DESCRIPTION="Qt support for OpenSceneGraph"
+HOMEPAGE="http://www.openscenegraph.org/"
+SRC_URI="https://github.com/openscenegraph/${MY_PN}/archive/${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="wxWinLL-3 LGPL-2.1"
+SLOT="0/145" # NOTE: CHECK WHEN BUMPING! Subslot is SOVERSION
+KEYWORDS="amd64 ~ppc64 x86"
+IUSE="examples"
+
+RDEPEND="
+ >=dev-games/openscenegraph-3.6.3:=
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtopengl:5
+ dev-qt/qtwidgets:5
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.5.5-cmake.patch
+ "${FILESDIR}"/${PN}-3.5.5-qt-5.11b3.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DDYNAMIC_OPENSCENEGRAPH=ON
+ -DDESIRED_QT_VERSION=5
+ -DBUILD_OSG_EXAMPLES=$(usex examples)
+ -DCMAKE_DISABLE_USE_FIND_PACKAGE_Qt5WebKitWidgets=ON
+ )
+ cmake_src_configure
+}