summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2023-12-21 10:01:50 -0500
committerMichael Orlitzky <mjo@gentoo.org>2024-01-22 06:29:04 -0500
commitd909bda4eb977f2e427fe402dd983330c6000060 (patch)
treea8aa0e762d8ae33978c42e264afc372b1ca166a8 /dev-gap/datastructures
parentsci-mathematics/gap: PDEPEND on autoloaded packages without USE=minimal (diff)
downloadgentoo-d909bda4eb977f2e427fe402dd983330c6000060.tar.gz
gentoo-d909bda4eb977f2e427fe402dd983330c6000060.tar.bz2
gentoo-d909bda4eb977f2e427fe402dd983330c6000060.zip
dev-gap/datastructures: new package, add 0.3.0
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'dev-gap/datastructures')
-rw-r--r--dev-gap/datastructures/Manifest1
-rw-r--r--dev-gap/datastructures/datastructures-0.3.0.ebuild25
-rw-r--r--dev-gap/datastructures/metadata.xml45
3 files changed, 71 insertions, 0 deletions
diff --git a/dev-gap/datastructures/Manifest b/dev-gap/datastructures/Manifest
new file mode 100644
index 000000000000..88857b977d5d
--- /dev/null
+++ b/dev-gap/datastructures/Manifest
@@ -0,0 +1 @@
+DIST datastructures-0.3.0.tar.gz 410109 BLAKE2B dbc620686ea28c48b2b87b134044b35a13083cbad884ff07b0c3f266f55a661377800ef0f575287b3e08da6e7a2a9fe700eee6f41d7e6082c579792a13342e6d SHA512 8b680a006cd6c0adbe256abe0f3ae5c566aa9b4852f1bcb7f02c4512ea1b9f15b7597ab29d86508a7fd71e8dc5d64794895a22eb45ca74e52a4de1ce9f7d8612
diff --git a/dev-gap/datastructures/datastructures-0.3.0.ebuild b/dev-gap/datastructures/datastructures-0.3.0.ebuild
new file mode 100644
index 000000000000..41d0e97f24c7
--- /dev/null
+++ b/dev-gap/datastructures/datastructures-0.3.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic gap-pkg
+
+DESCRIPTION="Collection of standard data structures for GAP"
+SLOT="0"
+SRC_URI="https://github.com/gap-packages/datastructures/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+KEYWORDS="~amd64"
+
+DEPEND="sci-mathematics/gap"
+
+DOCS=( CHANGES.md README.md )
+
+gap-pkg_enable_tests
+
+src_compile() {
+ # https://github.com/gap-packages/datastructures/issues/151
+ append-cflags -Wno-error=strict-prototypes
+ gap-pkg_src_compile
+}
diff --git a/dev-gap/datastructures/metadata.xml b/dev-gap/datastructures/metadata.xml
new file mode 100644
index 000000000000..32d66c435d99
--- /dev/null
+++ b/dev-gap/datastructures/metadata.xml
@@ -0,0 +1,45 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>frp.bissey@gmail.com</email>
+ <name>François Bissey</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ <name>Gentoo Mathematics Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ The datastructures package aims at providing standard
+ datastructures, consolidating existing code and improving on it, in
+ particular in view of HPC-GAP.
+
+ The datastructures package consists of two parts: interface
+ declarations and implementations. The goal of interface declarations
+ is to define standard interfaces for datastructures and decouple
+ them from the implementations. This enables easy exchangability of
+ implementations, for example for more efficient implementations, or
+ implementations more suited for parallelisation or sequential use.
+
+ The datastructures package declares interfaces for the following
+ datastructures:
+
+ * queues
+ * doubly linked lists
+ * heaps
+ * priority queues
+ * hash tables
+ * dictionaries
+
+ </longdescription>
+ <upstream>
+ <remote-id type="github">gap-packages/datastructures</remote-id>
+ </upstream>
+</pkgmetadata>