summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2023-12-21 09:37:58 -0500
committerMichael Orlitzky <mjo@gentoo.org>2024-01-22 06:28:56 -0500
commit90d4c8d7dee18b177e41dbe258a2d17c61c78d10 (patch)
treef8b6625487854530368be50e2be0cfdbb35b3ab8 /dev-gap/gapdoc
parentprofiles,dev-gap: new category dev-gap for GAP packages (diff)
downloadgentoo-90d4c8d7dee18b177e41dbe258a2d17c61c78d10.tar.gz
gentoo-90d4c8d7dee18b177e41dbe258a2d17c61c78d10.tar.bz2
gentoo-90d4c8d7dee18b177e41dbe258a2d17c61c78d10.zip
dev-gap/gapdoc: new package, add 1.6.6
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'dev-gap/gapdoc')
-rw-r--r--dev-gap/gapdoc/Manifest1
-rw-r--r--dev-gap/gapdoc/gapdoc-1.6.6.ebuild49
-rw-r--r--dev-gap/gapdoc/metadata.xml28
3 files changed, 78 insertions, 0 deletions
diff --git a/dev-gap/gapdoc/Manifest b/dev-gap/gapdoc/Manifest
new file mode 100644
index 000000000000..b4d9ebfe1655
--- /dev/null
+++ b/dev-gap/gapdoc/Manifest
@@ -0,0 +1 @@
+DIST gapdoc-1.6.6.tar.gz 254048 BLAKE2B d9c2e7371aaa97076855bea59e2b58e9458f0bf2f37ca403ec8f35dc9d19a7ad7f2f84cfe1a607aa15cc377a7b304bced4a39f9897e8c95794cde392e2cd2e58 SHA512 48283e54b4d540c35dec11ecca4129cabb824b521ac64b25694e754c4811542a7dc3313d5c7043eadd503db10228ab9838bb250541d1193696223117ccfda2c4
diff --git a/dev-gap/gapdoc/gapdoc-1.6.6.ebuild b/dev-gap/gapdoc/gapdoc-1.6.6.ebuild
new file mode 100644
index 000000000000..3d61575cb76f
--- /dev/null
+++ b/dev-gap/gapdoc/gapdoc-1.6.6.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gap-pkg
+
+MY_PN=GAPDoc
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="GAP documentation structure and tooling"
+SLOT="0"
+SRC_URI="https://github.com/frankluebeck/${MY_PN}/archive/relv${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+# PackageInfo.g defines TestFile := tst/test.tst, but that
+# file doesn't exist!
+RESTRICT=test
+
+DOCS=( CHANGES README.md )
+
+S="${WORKDIR}/${MY_PN}-relv${PV}"
+
+GAP_PKG_EXTRA_INSTALL=(
+ bibxmlext.dtd
+ gapdoc.dtd
+ styles
+ version
+)
+
+src_install(){
+ gap-pkg_src_install
+
+ if use examples; then
+ docinto examples
+ dodoc -r 3k+1
+ fi
+
+ # The "example" directory is mentioned in PackageInfo.g, so we
+ # include it unconditionally, and install it in the gap package
+ # directory (so that the path in PackageInfo.g is accurate).
+ # Afterwards we symlink it into the usual USE=examples path.
+ insinto $(gap-pkg_dir)
+ doins -r example
+ dosym -r $(gap-pkg_dir)/example \
+ "/usr/share/doc/${PF}/examples/example"
+}
diff --git a/dev-gap/gapdoc/metadata.xml b/dev-gap/gapdoc/metadata.xml
new file mode 100644
index 000000000000..70eaabce12e5
--- /dev/null
+++ b/dev-gap/gapdoc/metadata.xml
@@ -0,0 +1,28 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>frp.bissey@gmail.com</email>
+ <name>François Bissey</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ <name>Gentoo Mathematics Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ This package contains a definition of a structure for GAP (package)
+ documentation, based on XML. It also contains conversion programs
+ for producing text-, PDF- or HTML-versions of such documents, with
+ hyperlinks if possible.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">frankluebeck/GAPDoc</remote-id>
+ </upstream>
+</pkgmetadata>