summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2023-12-21 09:47:28 -0500
committerMichael Orlitzky <mjo@gentoo.org>2024-01-22 06:28:57 -0500
commit0633892e6163bef5217a90990a01538d2a8343f3 (patch)
tree7dced74c4764fc91ae84cf67801de7a2d49f38b4 /dev-gap/transgrp
parentdev-gap/smallgrp: new package, add 1.5.3 (diff)
downloadgentoo-0633892e6163bef5217a90990a01538d2a8343f3.tar.gz
gentoo-0633892e6163bef5217a90990a01538d2a8343f3.tar.bz2
gentoo-0633892e6163bef5217a90990a01538d2a8343f3.zip
dev-gap/transgrp: new package, add 3.6.4
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'dev-gap/transgrp')
-rw-r--r--dev-gap/transgrp/Manifest1
-rw-r--r--dev-gap/transgrp/files/transgrp-3.6.4-load-gapdoc-before-tests.patch29
-rw-r--r--dev-gap/transgrp/metadata.xml30
-rw-r--r--dev-gap/transgrp/transgrp-3.6.4.ebuild29
4 files changed, 89 insertions, 0 deletions
diff --git a/dev-gap/transgrp/Manifest b/dev-gap/transgrp/Manifest
new file mode 100644
index 000000000000..e0c2e9e0eb17
--- /dev/null
+++ b/dev-gap/transgrp/Manifest
@@ -0,0 +1 @@
+DIST transgrp3.6.4.tar.gz 59058725 BLAKE2B 4a478e1d1f534e9ec35c5525c3923980f69f12a43147a2fb4ad71daac6bf8353340346e4f36cbcf0266ccf86dba681549a1418894cdadc86d6de5d39335b87fd SHA512 5f0bf207129014ffaa73650e1fd7f4fc81ba360ce58ffcd797b0c773020908e8362e3db62e9f63c76be93fa0cd9471e23a043cbb185ddc123bad09ed457310ae
diff --git a/dev-gap/transgrp/files/transgrp-3.6.4-load-gapdoc-before-tests.patch b/dev-gap/transgrp/files/transgrp-3.6.4-load-gapdoc-before-tests.patch
new file mode 100644
index 000000000000..2d932e7f9635
--- /dev/null
+++ b/dev-gap/transgrp/files/transgrp-3.6.4-load-gapdoc-before-tests.patch
@@ -0,0 +1,29 @@
+From f69df24cf2c37dd8353fa227b03336b52c717d6d Mon Sep 17 00:00:00 2001
+From: Michael Orlitzky <michael@orlitzky.com>
+Date: Wed, 13 Dec 2023 14:39:03 -0500
+Subject: [PATCH] tst/testall.g: load GAPDoc before testing
+
+To help resolve the chicken and egg problem, it's nice to be able to
+launch gap with --bare when testing transgrp. But without GAPDoc
+loaded, the test suite fails. So let's load it explicitly. This won't
+hurt anything under normal circumstances where GAPDoc is loaded
+anyway.
+---
+ tst/testall.g | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/tst/testall.g b/tst/testall.g
+index 19275f8..92a1653 100644
+--- a/tst/testall.g
++++ b/tst/testall.g
+@@ -4,6 +4,7 @@
+ # This file runs package tests. It is also referenced in the package
+ # metadata in PackageInfo.g.
+ #
++LoadPackage( "gapdoc" );
+ LoadPackage( "transgrp" );
+
+ TestDirectory(DirectoriesPackageLibrary( "transgrp", "tst" ),
+--
+2.41.0
+
diff --git a/dev-gap/transgrp/metadata.xml b/dev-gap/transgrp/metadata.xml
new file mode 100644
index 000000000000..11a583ba9f66
--- /dev/null
+++ b/dev-gap/transgrp/metadata.xml
@@ -0,0 +1,30 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>frp.bissey@gmail.com</email>
+ <name>François Bissey</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ <name>Gentoo Mathematics Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ A library of transitive groups.
+
+ Groups of degree 15-30 are due to Alexander Hulpke Degree 32 is due
+ to John Cannon and Derek Holt Degree 34-48 is due to Derek Holt and
+ Gordon Royle. Groups of degree 32 (~30MB) and 48 (~30GB) need to be
+ downloaded separately.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">hulpke/transgrp</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-gap/transgrp/transgrp-3.6.4.ebuild b/dev-gap/transgrp/transgrp-3.6.4.ebuild
new file mode 100644
index 000000000000..7ce80afe9b39
--- /dev/null
+++ b/dev-gap/transgrp/transgrp-3.6.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gap-pkg
+
+DESCRIPTION="GAP transitive groups library"
+SLOT="0"
+SRC_URI="https://www.math.colostate.edu/~hulpke/${PN}/${PN}${PV}.tar.gz"
+
+# Data format is licensed Artistic-2
+# Code is licensed GPL-3
+LICENSE="GPL-3 Artistic-2"
+KEYWORDS="~amd64"
+
+S="${WORKDIR}/${PN}"
+
+# This is one of the four required packages whose dependencies are all
+# listed explicitly.
+BDEPEND="test? ( dev-gap/gapdoc )"
+
+# Again, this is one of the four special packages that won't have gapdoc
+# auto-loaded for its test suite.
+PATCHES=( "${FILESDIR}/${P}-load-gapdoc-before-tests.patch" )
+
+GAP_PKG_HTML_DOCDIR="htm"
+GAP_PKG_EXTRA_INSTALL=( data )
+gap-pkg_enable_tests