summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2023-12-21 18:02:34 -0500
committerMichael Orlitzky <mjo@gentoo.org>2024-01-22 06:29:16 -0500
commit014b2583e997031800781575a18b40b188db59c3 (patch)
tree2cbc5501aa612da63f6b99ce5c74500c985020ca /dev-gap
parentsci-libs/libsemigroups: new package, add 2.7.2 (diff)
downloadgentoo-014b2583e997031800781575a18b40b188db59c3.tar.gz
gentoo-014b2583e997031800781575a18b40b188db59c3.tar.bz2
gentoo-014b2583e997031800781575a18b40b188db59c3.zip
dev-gap/semigroups: new package, add 5.3.2
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'dev-gap')
-rw-r--r--dev-gap/semigroups/Manifest1
-rw-r--r--dev-gap/semigroups/metadata.xml45
-rw-r--r--dev-gap/semigroups/semigroups-5.3.2.ebuild39
3 files changed, 85 insertions, 0 deletions
diff --git a/dev-gap/semigroups/Manifest b/dev-gap/semigroups/Manifest
new file mode 100644
index 000000000000..78ca39a35509
--- /dev/null
+++ b/dev-gap/semigroups/Manifest
@@ -0,0 +1 @@
+DIST semigroups-5.3.2.tar.gz 16984926 BLAKE2B e13e4ed64b1ebd0a88a0201e3b269784f4074f5414edc5e10ec7c5ebe911d71b32fb7f456ffe8b7660950c0ff9499e90e5d17d180d2fa6a4f366c4c11b0bc786 SHA512 f1dacb7c51240ae63159fa452374b2c6dec86adf365c74ef0af98981cd8ed54eb06b9a2482d746789af62c9b744b63babba7406025fd022bfd4e8209d7aa9a50
diff --git a/dev-gap/semigroups/metadata.xml b/dev-gap/semigroups/metadata.xml
new file mode 100644
index 000000000000..4303c485a25d
--- /dev/null
+++ b/dev-gap/semigroups/metadata.xml
@@ -0,0 +1,45 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>frp.bissey@gmail.com</email>
+ <name>François Bissey</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ <name>Gentoo Mathematics Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ The Semigroups package is a GAP package for semigroups, and
+ monoids. There are particularly efficient methods for finitely
+ presented semigroups and monoids, and for semigroups and monoids
+ consisting of transformations, partial permutations, bipartitions,
+ partitioned binary relations, subsemigroups of regular Rees 0-matrix
+ semigroups, and matrices of various semirings including boolean
+ matrices, matrices over finite fields, and certain tropical
+ matrices. Semigroups contains efficient methods for creating
+ semigroups, monoids, and inverse semigroups and monoids, calculating
+ their Green's structure, ideals, size, elements, group of units,
+ small generating sets, testing membership, finding the inverses of a
+ regular element, factorizing elements over the generators, and so
+ on. It is possible to test if a semigroup satisfies a particular
+ property, such as if it is regular, simple, inverse, completely
+ regular, and a large number of further properties. There are methods
+ for finding presentations for a semigroup, the congruences of a
+ semigroup, the maximal subsemigroups of a finite semigroup, smaller
+ degree partial permutation representations, and the character tables
+ of inverse semigroups. There are functions for producing pictures of
+ the Green's structure of a semigroup, and for drawing graphical
+ representations of certain types of elements.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">semigroups/Semigroups</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-gap/semigroups/semigroups-5.3.2.ebuild b/dev-gap/semigroups/semigroups-5.3.2.ebuild
new file mode 100644
index 000000000000..597664c13f4d
--- /dev/null
+++ b/dev-gap/semigroups/semigroups-5.3.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gap-pkg
+
+DESCRIPTION="GAP package for semigroups and monoids"
+SLOT="0"
+SRC_URI="https://github.com/semigroups/Semigroups/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+KEYWORDS="~amd64"
+
+DEPEND="sci-mathematics/gap:=
+ sci-libs/libsemigroups:="
+RDEPEND="${DEPEND}
+ dev-gap/orb
+ dev-gap/io
+ dev-gap/images
+ dev-gap/datastructures
+ dev-gap/digraphs
+ dev-gap/genss"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( CHANGELOG.md README.md CONTRIBUTING.md )
+
+GAP_PKG_EXTRA_INSTALL=( data )
+gap-pkg_enable_tests
+
+src_prepare() {
+ # can't bundle it if it isn't there (belt and suspenders)
+ rm -r libsemigroups || die
+ default
+}
+
+src_configure() {
+ gap-pkg_econf --with-external-libsemigroups
+}