summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAric Belsito <lluixhi@gmail.com>2018-03-28 14:49:40 -0700
committerMichał Górny <mgorny@gentoo.org>2018-03-30 20:08:11 +0200
commit6360f43aa6d931b05cdd5f3bb793c6e4138391bd (patch)
tree133f1d6b720c94c8fea2d1e69854e37eb517faf2 /dev-go/fuzzy
parentdev-go/godebug-pretty: new package (diff)
downloadgentoo-6360f43aa6d931b05cdd5f3bb793c6e4138391bd.tar.gz
gentoo-6360f43aa6d931b05cdd5f3bb793c6e4138391bd.tar.bz2
gentoo-6360f43aa6d931b05cdd5f3bb793c6e4138391bd.zip
dev-go/fuzzy: new package
new dependency of www-plugins/browserpass
Diffstat (limited to 'dev-go/fuzzy')
-rw-r--r--dev-go/fuzzy/Manifest1
-rw-r--r--dev-go/fuzzy/fuzzy-0.0.3.ebuild31
-rw-r--r--dev-go/fuzzy/metadata.xml12
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-go/fuzzy/Manifest b/dev-go/fuzzy/Manifest
new file mode 100644
index 000000000000..4db5ff403a34
--- /dev/null
+++ b/dev-go/fuzzy/Manifest
@@ -0,0 +1 @@
+DIST fuzzy-0.0.3.tar.gz 1931876 BLAKE2B e00c19a8b63f96e2fad8c2614409d8173cca758ae591ead363676c2055fd9ec1d29a038454fcd57153e72f4b08ed78f341dcfef0376a199ba6203369d62651fa SHA512 6ca0c1c0ca57454d183d1eab3cc375dde8f504b1f4726176106953dace7a3d2e42aedf0b9dabb49d9fb8a70dc184c112da7f789c04b01da5e5dff2b9e1e1f398
diff --git a/dev-go/fuzzy/fuzzy-0.0.3.ebuild b/dev-go/fuzzy/fuzzy-0.0.3.ebuild
new file mode 100644
index 000000000000..6ea5cd48cd42
--- /dev/null
+++ b/dev-go/fuzzy/fuzzy-0.0.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGO_PN=github.com/sahilm/fuzzy
+
+if [[ ${PV} = *9999* ]]; then
+ inherit golang-vcs
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ inherit golang-vcs-snapshot
+fi
+inherit golang-build
+
+DESCRIPTION="Go library that provides fuzzy string matching"
+HOMEPAGE="https://github.com/sahilm/fuzzy"
+LICENSE="MIT"
+SLOT="0/${PVR}"
+IUSE="test"
+
+DEPEND="test? ( dev-go/godebug-pretty )"
+RDEPEND=""
+
+src_install() {
+ golang-build_src_install
+
+ pushd "src/${EGO_PN}" >/dev/null || die
+ einstalldocs
+ popd >/dev/null || die
+}
diff --git a/dev-go/fuzzy/metadata.xml b/dev-go/fuzzy/metadata.xml
new file mode 100644
index 000000000000..004ae50f4a5f
--- /dev/null
+++ b/dev-go/fuzzy/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" >
+ <email>lluixhi@gmail.com</email>
+ <name>Aric Belsito</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+</pkgmetadata>