summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-10-28 17:38:31 +0100
committerManuel Rüger <mrueg@gentoo.org>2018-10-28 17:38:31 +0100
commit118534dfb23b51508a5d1fdf9c43b8ca28e3162a (patch)
tree9fb0c9759d2947edd90e5d185de02ecfabc1b9a7 /dev-go/glide/glide-0.13.2.ebuild
parentdev-util/pycharm-professional: Version bump to 2018.2.4 (diff)
downloadgentoo-118534dfb23b51508a5d1fdf9c43b8ca28e3162a.tar.gz
gentoo-118534dfb23b51508a5d1fdf9c43b8ca28e3162a.tar.bz2
gentoo-118534dfb23b51508a5d1fdf9c43b8ca28e3162a.zip
dev-go/glide: Version bump to 0.13.2
Signed-off-by: Manuel Rüger <mrueg@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-go/glide/glide-0.13.2.ebuild')
-rw-r--r--dev-go/glide/glide-0.13.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-go/glide/glide-0.13.2.ebuild b/dev-go/glide/glide-0.13.2.ebuild
new file mode 100644
index 000000000000..40c7e257d7a2
--- /dev/null
+++ b/dev-go/glide/glide-0.13.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGO_PN="github.com/Masterminds/glide"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit golang-vcs
+else
+ SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ inherit golang-vcs-snapshot
+fi
+
+DESCRIPTION="Vendor Package Managment for Golang"
+HOMEPAGE="https://github.com/Masterminds/glide"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RESTRICT="test"
+
+S=${WORKDIR}/${P}/src/${EGO_PN}
+
+src_compile() {
+ GOPATH="${WORKDIR}/${P}:$(get_golibdir_gopath)" go build -ldflags="-X main.version=${PV}" -o "bin/glide" glide.go || die
+}
+
+src_install() {
+ dodoc README.md CHANGELOG.md
+ dobin bin/glide
+}